Skip to main content
Version: v2.x

Postgres

Introduction

Hasura allows connecting to a Postgres database and build an GraphQL API based on the database schema.

Supported Postgres versions

Hasura GraphQL engine supports Postgres 9.5 and above

Postgres flavours

Hasura also supports databases with full Postgres compatibility like Yugabyte, Timescale, Citus, Aurora, RDS.

We have more distributed flavours like CockroachDB coming soon. See GitHub issue.

Curious about any other Postgres flavours? Any other questions? Ask us on GitHub discussions

Know more