<!DOCTYPE html><html lang="en"><head><meta charSet="utf-8" /><meta http-equiv="x-ua-compatible" content="ie=edge" /><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no" /><style data-href="/component---src-templates-events-hasuracon-21-hasura-con-21-presenter-template-js.34f9552adb582f1e9e83.css" id="gatsby-global-css">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</style><style data-href="/styles.57aa03a2fa73c2017058.css" id="gatsby-global-css">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</style><meta name="generator" content="Gatsby 3.4.0" /><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src= 'https://www.googletagmanager.com/gtm.js?id='+i+dl+'';f.parentNode.insertBefore(j,f); })(window,document,'script','dataLayer', 'GTM-KPWB7RN');</script><style data-styled="" data-styled-version="5.2.3"></style><title data-react-helmet="true">HasuraCon’21: An online Hasura GraphQL user conference</title><link data-react-helmet="true" rel="canonical" href="https://hasura.io/events/hasura-con-2021/speakers/antoine-leblanc/" /><meta data-react-helmet="true" name="title" content="HasuraCon’21: An online Hasura GraphQL user conference" /><meta data-react-helmet="true" name="description" content="HasuraCon is a free, online conference happening on 23rd &amp; 24th June. Featuring talks and live, hand-on workshops!" /><meta data-react-helmet="true" property="og:title" content="HasuraCon’21: An online Hasura GraphQL user conference" /><meta data-react-helmet="true" property="og:description" content="HasuraCon is a free, online conference happening on 23rd &amp; 24th June. Featuring talks and live, hand-on workshops!" /><meta data-react-helmet="true" property="og:image" content="https://graphql-engine-cdn.hasura.io/assets/main-site/hasura-con-2021.png" /><meta data-react-helmet="true" property="og:type" content="website" /><meta data-react-helmet="true" name="twitter:card" content="summary_large_image" /><meta data-react-helmet="true" name="twitter:title" content="HasuraCon’21: An online Hasura GraphQL user conference" /><meta data-react-helmet="true" name="twitter:description" content="HasuraCon is a free, online conference happening on 23rd &amp; 24th June. Featuring talks and live, hand-on workshops!" /><link rel="sitemap" type="application/xml" href="/sitemap.xml" /><link rel="icon" href="/favicon-32x32.png?v=6e6e57b4b98fec791dd9f3d077b80810" type="image/png" /><link rel="manifest" href="/manifest.webmanifest" crossorigin="anonymous" /><link rel="apple-touch-icon" sizes="48x48" href="/icons/icon-48x48.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="72x72" href="/icons/icon-72x72.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="96x96" href="/icons/icon-96x96.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="144x144" href="/icons/icon-144x144.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="192x192" href="/icons/icon-192x192.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="256x256" href="/icons/icon-256x256.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="384x384" href="/icons/icon-384x384.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="512x512" href="/icons/icon-512x512.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link crossorigin="" href="https://www.google.com" rel="preconnect" /><link crossorigin="" href="https://stats.g.doubleclick.net" rel="preconnect" /><link crossorigin="" href="https://page.hasura.io" rel="preconnect" /><link crossorigin="" href="https://connect.facebook.net" rel="preconnect" /><link rel="icon" href="/favicon-32x32.png?v=6e6e57b4b98fec791dd9f3d077b80810" type="image/png" /><link rel="manifest" href="/manifest.webmanifest" crossorigin="anonymous" /><meta name="theme-color" content="#663399" /><link rel="apple-touch-icon" sizes="48x48" href="/icons/icon-48x48.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="72x72" href="/icons/icon-72x72.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="96x96" href="/icons/icon-96x96.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="144x144" href="/icons/icon-144x144.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="192x192" href="/icons/icon-192x192.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="256x256" href="/icons/icon-256x256.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="384x384" href="/icons/icon-384x384.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="512x512" href="/icons/icon-512x512.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link as="script" rel="preload" href="/webpack-runtime-48479e5c22ccd00deb2b.js" /><link as="script" rel="preload" href="/framework-660f14b4e2df4188b3f4.js" /><link as="script" rel="preload" href="/app-18d276452a17b31839c1.js" /><link as="script" rel="preload" href="/commons-cfc2e38a7939f12cc44c.js" /><link as="script" rel="preload" href="/cd874db0c1b43e5f7337636626d3ced8d5cb3cfc-9c85d72295812147366b.js" /><link as="script" rel="preload" href="/component---src-templates-events-hasuracon-21-hasura-con-21-presenter-template-js-c0da9df45f4c6c0754c8.js" /><link as="fetch" rel="preload" href="/page-data/events/hasura-con-2021/speakers/antoine-leblanc/page-data.json" crossorigin="anonymous" /><link as="fetch" rel="preload" href="/page-data/app-data.json" crossorigin="anonymous" /><link rel="preload" as="font" href="/fonts/poppins-regular-latin.woff2" type="font/woff2" crossorigin="anonymous" /><link rel="preload" as="font" href="/fonts/poppins-600-latin.woff2" type="font/woff2" crossorigin="anonymous" /><link rel="preload" as="font" href="/fonts/poppins-bold-latin.woff2" type="font/woff2" crossorigin="anonymous" /><link rel="preload" href="https://page.hasura.io/js/forms2/css/forms2.css" as="style" /><link rel="preload" href="https://page.hasura.io/js/forms2/css/forms2-theme-simple.css" as="style" /><script type="application/ld+json">{
              "@context": "http://schema.org/",
              "@type": "Organization",
              "name": "Hasura",
              "logo": "https://hasura.io/logo.svg",
              "url": "https://hasura.io",
              "foundingDate": "2015",
              "address": {
                "@type": "PostalAddress",
                "addressLocality": "Bangalore",
                "addressRegion": "Karnataka",
                "postalCode": "560034",
                "streetAddress": "2nd Floor, Building, No 37/38, 80 Feet Rd, 3rd Block, Koramangala 1A Block, SBI Colony, Koramangala"
              },
              "founders": [{"@type": "Person","name": "Tanmai Gopal"},{"@type": "Person","name": "Rajoshi Ghosh"}],
              "contactPoint": {
                 "@type": "ContactPoint",
                 "contactType": "Sales",
                 "email": "build@hasura.io",
                 "url": "https://hasura.io"
              },
              "sameAs": [
                "https://en.wikipedia.org/wiki/Hasura",
                "https://www.wikidata.org/wiki/Q56676515",
                "https://www.facebook.com/HasuraHQ",
                "https://www.twitter.com/hasurahq",
                "https://www.linkedin.com/company/hasura",
                "https://www.instagram.com/hasurahq",
                "https://www.youtube.com/hasurahq"
              ]
          }</script><script type="application/ld+json">{
              "@context": "http://schema.org",
              "@type": "WebSite",
              "name": "Hasura",
              "url": "https://hasura.io"
          }</script></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KPWB7RN" height="0" width="0" style="display: none; visibility: hidden" aria-hidden="true"></iframe></noscript><div id="___gatsby"><div style="outline:none" tabindex="-1" id="gatsby-focus-wrapper"><div id="viewport" class="hasuraCon2021Wrapper patternWrapper hasuraCon2021WrapperBg"><img class="heroBanRightPattern smallSquarePattern" loading="lazy" src="/static/speaker-detail-1-3fc05b85cfab851a79dcb5f29c36f5dd.png" alt="Speakers Graphic" /><div class="mainWrapper"><div id="navbar" class="topnav"><div class="navBarToggle" aria-label="button" role="button" tabindex="0" id="menuClick"><span class="iconBar"></span><span class="iconBar"></span><span class="iconBar"></span></div><div class="visibleMobile"><ul class="navBarULMobile articleDesc"><li class="registerActive"><a href="/events/hasura-con-2021/register/">Register Now</a></li><li><a href="/events/hasura-con-2021/schedule/">Schedule</a></li><li><a href="/events/hasura-con-2021/speakers/">Speakers</a></li><li><a href="/events/hasura-con-2021/talks/">Talks</a></li><li><a href="/events/hasura-con-2021/talks/">Workshops</a></li><li><a href="https://hasura.io/events/hasura-con-2021/#topics">Topic Tables</a></li><li><a href="/events/hasura-con-2021/jobs/">Jobs</a></li><li><a href="https://hasura.io/events/hasura-con-2021/#sponsors">Sponsors</a></li><li><div class="socialIconWrapper"><a href="https://discord.com/invite/hasura" target="_blank" rel="noopener noreferrer"><img src="data:image/svg+xml;base64,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" alt="Discord" /></a><a href="https://www.linkedin.com/company/hasura" target="_blank" rel="noopener noreferrer"><img src="data:image/svg+xml;base64,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" alt="Linkedin" /></a><a href="https://twitter.com/hasurahq" target="_blank" rel="noopener noreferrer"><img src="data:image/svg+xml;base64,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" alt="Twitter" /></a></div></li></ul></div></div><div class="mainGridWrapper"><div><div class="leftSidebarWrapper"><div class="h2c-brand"><a href="/events/hasura-con-2021/"><img src="/static/hasura-con-brand-ff80a61b24a327b871e5477439cca700.gif" alt="Brand" /></a><div class="articleDescSmall">Jun 23rd - 24th 2021</div></div><ul class="articleDesc"><li class="registerActive"><a class="prettyLink" href="/events/hasura-con-2021/register/">Register Now</a></li><li><a href="/events/hasura-con-2021/schedule/">Schedule</a></li><li><a href="/events/hasura-con-2021/speakers/">Speakers</a></li><li><a href="/events/hasura-con-2021/talks/">Talks</a></li><li><a href="/events/hasura-con-2021/talks/">Workshops</a></li><li><a href="/events/hasura-con-2021/talks/">Topic Tables</a></li><li><a href="/events/hasura-con-2021/jobs/">Jobs</a></li><li><a href="https://hasura.io/events/hasura-con-2021/#sponsors" class="">Sponsors</a></li></ul><div class="leftSidebarFooterWrapper"><div class="socialIconWrapper"><a href="https://discord.com/invite/hasura" target="_blank" rel="noopener noreferrer"><img src="data:image/svg+xml;base64,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" alt="Discord" /></a><a href="https://www.linkedin.com/company/hasura" target="_blank" rel="noopener noreferrer"><img src="data:image/svg+xml;base64,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" alt="Linkedin" /></a><a href="https://twitter.com/hasurahq" target="_blank" rel="noopener noreferrer"><img src="data:image/svg+xml;base64,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" alt="Twitter" /></a></div></div></div></div><div><article class="speakerDetailFull"><section><p class="hasCon21Breadcrumb speakerPage"><a href="/events/hasura-con-2021">Conference</a> /<!-- --> <a href="/events/hasura-con-2021/speakers">Speakers</a> /<!-- --> <!-- -->Antoine Leblanc</p><header class="details"><h1>Antoine Leblanc</h1><p>Head of The Hasura Data Sources Team<!-- -->, <!-- -->Hasura</p></header><main><p>Antoine Leblanc is the lead of Hasura&#x27;s Data Sources team, responsible for bringing new backend to the GraphQL engine and for extending what features are supported across them. They are first and foremost a fan of the Haskell programming language, which they taught for several years as part of Google&#x27;s Haskell Team. They were a Haskell mentor on Exercism for a while, and always welcome questions from Haskell beginners!</p></main><aside><div class="speakerSocials"><a href="https://hasura.io/events/hasura-con-2021/register/" class="inlineBoxCTA">Register for Free →</a><a href="https://twitter.com/nicuveo"><svg width="40" height="40" viewBox="0 0 40 40" fill="none"><circle cx="20" cy="20" r="20"></circle><path d="M30 12.01c-.914.64-1.926 1.129-2.997 1.45a4.282 4.282 0 00-2.189-1.333 4.307 4.307 0 00-2.563.152 4.272 4.272 0 00-2.013 1.582 4.222 4.222 0 00-.738 2.44v.948a10.239 10.239 0 01-4.839-1.075 10.154 10.154 0 01-3.752-3.217s-3.818 8.527 4.773 12.316A11.172 11.172 0 019 27.168c8.59 4.737 19.09 0 19.09-10.895 0-.264-.026-.527-.075-.787A7.3 7.3 0 0030 12.01z"></path></svg></a></div></aside></section><div class="profile"><div class="profileImage" style="background-image:url(/static/antoine-e2084fa35e1c83d1ff277a2c70871021.png);background-size:cover"></div></div></article><article class="presentationDetails hasCon21Card"><section><div><p>Workshop</p></div><header><h1 class="hc21-heading">SQLite: Implementing A New Hasura Backend</h1></header><main><section><header><h1>Description</h1></header><p>We&#x27;ve been working on adding support for more databases to Hasura: Microsoft SQL Server, Google BigQuery, Citus, and soon, MySQL. We have worked to make the process as seamless as possible, and we&#x27;d like to share the knowledge so you can add your favourite source to Hasura!</p></section><section><header><h1>Takeaways</h1></header><p>By attending this workshop, you should gain a good understanding on how to add a new database to Hasura, as well as some insight into the inner workings of the Hasura GraphQL Engine.</p></section><p class="h2c-readmore"><a href="/events/hasura-con-2021/talks/sqlite-implementing-a-new-hasura-backend">Read More &gt;</a></p></main></section><aside><article class="speakerDetails"><div class="speakerDetailsProfile" style="background-image:url(/static/antoine-e2084fa35e1c83d1ff277a2c70871021.png);background-size:cover"></div><div><h1>Antoine Leblanc</h1><p>Head of The Hasura Data Sources Team, Hasura</p></div></article><article class="speakerDetails"><div class="speakerDetailsProfile" style="background-image:url(/static/philip-78802bc6af2ecf05705a1b9881f3fdd4.png);background-size:cover"></div><div><h1>Philip Carlsen</h1><p>Software Developer, Hasura</p></div></article></aside></article><nav class="hasCon21Pagination"><a href="/events/hasura-con-2021/speakers/adron-hall/"><div class="linkBox"><div class="navArrowBox"><svg width="65" height="68" viewBox="0 0 65 68" fill="none"><path d="M14.53 35.88L63 53.482v11.215L4.315 34 63 3.303V14.71L14.537 32.118 9.325 33.99l5.205 1.89z" stroke-width="4"></path><defs><linearGradient id="linearStyle" x1="-6.50002" y1="204.001" x2="74.7581" y2="203.981" gradientUnits="userSpaceOnUse"><stop stop-color="#1EB4D4"></stop><stop offset="0.46875" stop-color="#FFC267"></stop><stop offset="1" stop-color="#F47E7E"></stop></linearGradient></defs></svg></div><div class="navTitleBox"><h1>Adron Hall</h1></div></div></a><a href="/events/hasura-con-2021/speakers/philip-carlsen/"><div class="linkBox"><div class="navTitleBox"><h1>Philip Carlsen</h1></div><div class="navArrowBox right"><svg width="65" height="68" viewBox="0 0 65 68" fill="none"><path d="M14.53 35.88L63 53.482v11.215L4.315 34 63 3.303V14.71L14.537 32.118 9.325 33.99l5.205 1.89z" stroke-width="4"></path><defs><linearGradient id="linearStyle" x1="-6.50002" y1="204.001" x2="74.7581" y2="203.981" gradientUnits="userSpaceOnUse"><stop stop-color="#1EB4D4"></stop><stop offset="0.46875" stop-color="#FFC267"></stop><stop offset="1" stop-color="#F47E7E"></stop></linearGradient></defs></svg></div></div></a></nav></div><div class="footerWrapper removePaddBottom"><div><ul class="articleDesc"><li><a href="/events/hasura-con-2021/code-of-conduct/">Code Of Conduct</a></li><li><a href="/events/hasura-con-2021/#sponsors">Sponsors</a></li><li><a href="/cdn-cgi/l/email-protection#610417040f1512210900121413004f080e">Contact us</a></li></ul><div class="articleDesc">© <!-- -->2021<!-- --> Hasura Inc. All rights reserved</div></div><div class="footerLogoWrapper"><div class="poweredLogo"><a href="https://hasura.io/"><img src="/static/poweredbyhasura-09f9bb210c57117013ccf7d899e8a385.svg" alt="Powered Logo" /></a></div></div></div></div></div></div></div><div id="gatsby-announcer" style="position:absolute;top:0;width:1px;height:1px;padding:0;overflow:hidden;clip:rect(0, 0, 0, 0);white-space:nowrap;border:0" aria-live="assertive" aria-atomic="true"></div></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
          window.IntercomAppId = 'rucirpb3';
          window.IntercomIncludeInDevelopment = false;
          (function(){var w=window;var ic=w.Intercom;if(typeof ic==="function"){ic('reattach_activator');ic('update',intercomSettings);}else{var d=document;var i=function(){i.c(arguments)};i.q=[];i.c=function(args){i.q.push(args)};w.Intercom=i;function l(){var s=d.createElement('script');s.type='text/javascript';s.async=true;s.src='https://widget.intercom.io/widget/rucirpb3';var x=d.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);}function ld(){setTimeout(l, 2000);}if(w.attachEvent){w.attachEvent('onload',ld);}else{w.addEventListener('load',ld,false);}}})();
          </script><script id="gatsby-script-loader">/*<![CDATA[*/window.pagePath="/events/hasura-con-2021/speakers/antoine-leblanc/";/*]]>*/</script><script id="gatsby-chunk-mapping">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</script><script src="/polyfill-3a49c548e242de176d38.js" nomodule=""></script><script src="/component---src-templates-events-hasuracon-21-hasura-con-21-presenter-template-js-c0da9df45f4c6c0754c8.js" async=""></script><script src="/cd874db0c1b43e5f7337636626d3ced8d5cb3cfc-9c85d72295812147366b.js" async=""></script><script src="/commons-cfc2e38a7939f12cc44c.js" async=""></script><script src="/app-18d276452a17b31839c1.js" async=""></script><script src="/framework-660f14b4e2df4188b3f4.js" async=""></script><script src="/webpack-runtime-48479e5c22ccd00deb2b.js" async=""></script></body></html>