<!DOCTYPE html><html lang="en"><head><meta charSet="utf-8" /><meta http-equiv="x-ua-compatible" content="ie=edge" /><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no" /><style data-href="/component---src-components-webinarvideos-webinarvideos-js.87236e79881a7a79b0cf.css" id="gatsby-global-css">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</style><style data-href="/styles.7524a75e2ab03c3b42e2.css" id="gatsby-global-css">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</style><meta name="generator" content="Gatsby 3.4.0" /><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src= 'https://www.googletagmanager.com/gtm.js?id='+i+dl+'';f.parentNode.insertBefore(j,f); })(window,document,'script','dataLayer', 'GTM-KPWB7RN');</script><style data-styled="" data-styled-version="5.2.3"></style><title data-react-helmet="true">GraphQL Observability to Diagnose &amp; Improve Query Performance for your Hasura apps</title><link data-react-helmet="true" rel="canonical" href="https://hasura.io/events/webinar/diagnosing-improving-query-performance/" /><meta data-react-helmet="true" name="title" content="GraphQL Observability to Diagnose &amp; Improve Query Performance for your Hasura apps" /><meta data-react-helmet="true" name="description" content="Learn how you can debug &amp; analyze query performance in your Hasura applications using the monitoring and observability features that Hasura provides." /><meta data-react-helmet="true" property="og:title" content="GraphQL Observability to Diagnose &amp; Improve Query Performance for your Hasura apps" /><meta data-react-helmet="true" property="og:description" content="Learn how you can debug &amp; analyze query performance in your Hasura applications using the monitoring and observability features that Hasura provides." /><meta data-react-helmet="true" property="og:image" content="https://graphql-engine-cdn.hasura.io/assets/main-site/diagnosing-improving-query-performance.png" /><meta data-react-helmet="true" property="og:type" content="website" /><meta data-react-helmet="true" name="twitter:card" content="summary_large_image" /><meta data-react-helmet="true" name="twitter:title" content="GraphQL Observability to Diagnose &amp; Improve Query Performance for your Hasura apps" /><meta data-react-helmet="true" name="twitter:description" content="Learn how you can debug &amp; analyze query performance in your Hasura applications using the monitoring and observability features that Hasura provides." /><link rel="sitemap" type="application/xml" href="/sitemap.xml" /><link rel="icon" href="/favicon-32x32.png?v=6e6e57b4b98fec791dd9f3d077b80810" type="image/png" /><link rel="manifest" href="/manifest.webmanifest" crossorigin="anonymous" /><link rel="apple-touch-icon" sizes="48x48" href="/icons/icon-48x48.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="72x72" href="/icons/icon-72x72.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="96x96" href="/icons/icon-96x96.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="144x144" href="/icons/icon-144x144.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="192x192" href="/icons/icon-192x192.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="256x256" href="/icons/icon-256x256.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="384x384" href="/icons/icon-384x384.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="512x512" href="/icons/icon-512x512.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link crossorigin="" href="https://www.google.com" rel="preconnect" /><link crossorigin="" href="https://stats.g.doubleclick.net" rel="preconnect" /><link crossorigin="" href="https://page.hasura.io" rel="preconnect" /><link crossorigin="" href="https://connect.facebook.net" rel="preconnect" /><link rel="icon" href="/favicon-32x32.png?v=6e6e57b4b98fec791dd9f3d077b80810" type="image/png" /><link rel="manifest" href="/manifest.webmanifest" crossorigin="anonymous" /><meta name="theme-color" content="#663399" /><link rel="apple-touch-icon" sizes="48x48" href="/icons/icon-48x48.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="72x72" href="/icons/icon-72x72.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="96x96" href="/icons/icon-96x96.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="144x144" href="/icons/icon-144x144.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="192x192" href="/icons/icon-192x192.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="256x256" href="/icons/icon-256x256.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="384x384" href="/icons/icon-384x384.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="512x512" href="/icons/icon-512x512.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link as="script" rel="preload" href="/webpack-runtime-dc84cead993b8e9569b1.js" /><link as="script" rel="preload" href="/framework-660f14b4e2df4188b3f4.js" /><link as="script" rel="preload" href="/app-5ea939bc14a95df77faa.js" /><link as="script" rel="preload" href="/commons-cfc2e38a7939f12cc44c.js" /><link as="script" rel="preload" href="/9907c54bf0ca54bed74b9d2db83464f15f5aea10-e0a701e34d43345dd805.js" /><link as="script" rel="preload" href="/d2408637e253f65cafc2b193037e5cb7f90cd981-d3506376003edb8d8c10.js" /><link as="script" rel="preload" href="/1f976be9dd44deba04b081efa6ddc79c24b170ea-98cb8c7f5d91d12880e4.js" /><link as="script" rel="preload" href="/component---src-components-webinarvideos-webinarvideos-js-0221a4c0ade1e432b6d8.js" /><link as="fetch" rel="preload" href="/page-data/events/webinar/diagnosing-improving-query-performance/page-data.json" crossorigin="anonymous" /><link as="fetch" rel="preload" href="/page-data/sq/d/3000892485.json" crossorigin="anonymous" /><link as="fetch" rel="preload" href="/page-data/app-data.json" crossorigin="anonymous" /><link rel="preload" as="font" href="/fonts/poppins-regular-latin.woff2" type="font/woff2" crossorigin="anonymous" /><link rel="preload" as="font" href="/fonts/poppins-600-latin.woff2" type="font/woff2" crossorigin="anonymous" /><link rel="preload" as="font" href="/fonts/poppins-bold-latin.woff2" type="font/woff2" crossorigin="anonymous" /><link rel="preload" href="https://page.hasura.io/js/forms2/css/forms2.css" as="style" /><link rel="preload" href="https://page.hasura.io/js/forms2/css/forms2-theme-simple.css" as="style" /><script type="application/ld+json">{
              "@context": "http://schema.org/",
              "@type": "Organization",
              "name": "Hasura",
              "logo": "https://hasura.io/logo.svg",
              "url": "https://hasura.io",
              "foundingDate": "2015",
              "address": {
                "@type": "PostalAddress",
                "addressLocality": "Bangalore",
                "addressRegion": "Karnataka",
                "postalCode": "560034",
                "streetAddress": "2nd Floor, Building, No 37/38, 80 Feet Rd, 3rd Block, Koramangala 1A Block, SBI Colony, Koramangala"
              },
              "founders": [{"@type": "Person","name": "Tanmai Gopal"},{"@type": "Person","name": "Rajoshi Ghosh"}],
              "contactPoint": {
                 "@type": "ContactPoint",
                 "contactType": "Sales",
                 "email": "build@hasura.io",
                 "url": "https://hasura.io"
              },
              "sameAs": [
                "https://en.wikipedia.org/wiki/Hasura",
                "https://www.wikidata.org/wiki/Q56676515",
                "https://www.facebook.com/HasuraHQ",
                "https://www.twitter.com/hasurahq",
                "https://www.linkedin.com/company/hasura",
                "https://www.instagram.com/hasurahq",
                "https://www.youtube.com/hasurahq"
              ]
          }</script><script type="application/ld+json">{
              "@context": "http://schema.org",
              "@type": "WebSite",
              "name": "Hasura",
              "url": "https://hasura.io"
          }</script></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KPWB7RN" height="0" width="0" style="display: none; visibility: hidden" aria-hidden="true"></iframe></noscript><div id="___gatsby"><div style="outline:none" tabindex="-1" id="gatsby-focus-wrapper"><div id="viewport" class="viewport"><div class="commonBannerStripWrapperBg"><div class="containerWidth"><div class="commonBannerStripWrapper"><a href="https://hasura.io/blog/july-roundup-of-hasuras-product-launches-bigquery-citus-support-database-monitoring/?pg=home&amp;plcmt=banner&amp;cta=read-blog-post&amp;tech=" class="articleDesc hasura-font-bold"><span class="emoji" role="img" aria-label="emoji">👋</span>New product launches in July! Read our roundup<div class="arrow"> &gt;</div></a><div class="closeBanner" role="button" tabindex="0"><svg width="24" height="24" viewBox="0 0 24 24" fill="none" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" clip-rule="evenodd" d="M18.9071 6.50691C19.2976 6.11639 19.2976 5.48322 18.9071 5.0927C18.5166 4.70217 17.8834 4.70217 17.4929 5.0927L12 10.5856L6.50709 5.0927C6.11657 4.70217 5.48341 4.70217 5.09288 5.0927C4.70236 5.48322 4.70236 6.11639 5.09288 6.50691L10.5858 11.9998L5.09288 17.4927C4.70236 17.8832 4.70236 18.5164 5.09288 18.9069C5.48341 19.2974 6.11657 19.2974 6.50709 18.9069L12 13.414L17.4929 18.9069C17.8834 19.2974 18.5166 19.2974 18.9071 18.9069C19.2976 18.5164 19.2976 17.8832 18.9071 17.4927L13.4142 11.9998L18.9071 6.50691Z"></path></svg></div></div></div></div><div class="wd100"><header id="header" class="lightModeHeader"><div class="containerWrapper"><div class="headerWrapper"><div id="navBrand" class="navLeft"><div class="brand"><a href="/"><img src="data:image/svg+xml;base64,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" alt="Hasura Logo" title="Hasura Logo" /></a></div></div><div></div><div class="navCenter hideMobile"><ul class="navBarUL m-nav-t"><li class=""><a href="/products/">PRODUCTS</a></li><li><a href="https://hasura.io/docs/latest/graphql/core/index.html" target="_blank" rel="noopener noreferrer" style="text-decoration:none">DOCS</a></li><li class="dropDownList"><a role="button" tabindex="0">RESOURCES</a><div id="resource-nav" class="zIndex dropDownContent"><div class="navDrapdownWrapper"><div class="containerWrapper"><div class="hasura-ibm-plex-nav mobileNavShow mobileTitleResources">Resources</div><div class="navDrapdownListWrapper"><div class="navListWrapper"><a href="/learn/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">Tutorials</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Real-world GraphQL Tuts</div></div></div></a><a href="https://hasura.io/blog/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTE2LjUgMTcuNUMxNi44OTc4IDE3LjUgMTcuMjc5NCAxNy4zNDIgMTcuNTYwNyAxNy4wNjA3QzE3Ljg0MiAxNi43Nzk0IDE4IDE2LjM5NzggMTggMTZWNEMxOCAzLjE2NzUgMTcuMzI1IDIuNSAxNi41IDIuNUgxMlY3Ljc1TDEwLjEyNSA2LjYyNUw4LjI1IDcuNzVWMi41SDcuNUM3LjEwMjE4IDIuNSA2LjcyMDY0IDIuNjU4MDQgNi40MzkzNCAyLjkzOTM0QzYuMTU4MDQgMy4yMjA2NCA2IDMuNjAyMTggNiA0VjE2QzYgMTYuMzk3OCA2LjE1ODA0IDE2Ljc3OTQgNi40MzkzNCAxNy4wNjA3QzYuNzIwNjQgMTcuMzQyIDcuMTAyMTggMTcuNSA3LjUgMTcuNUgxNi41WiIgZmlsbD0iIzBCNTU5OSIvPgo8L3N2Zz4K" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">Blog</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Editorials and releases</div></div></div></a><a href="/user-stories/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">User stories</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Read user case-studies</div></div></div></a><a href="/events/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTE3LjI1IDE2SDYuNzVWNy43NUgxNy4yNVYxNlpNMTUgMi41VjRIOVYyLjVINy41VjRINi43NUM2LjM1MjE4IDQgNS45NzA2NCA0LjE1ODA0IDUuNjg5MzQgNC40MzkzNEM1LjQwODA0IDQuNzIwNjQgNS4yNSA1LjEwMjE4IDUuMjUgNS41VjE2QzUuMjUgMTYuMzk3OCA1LjQwODA0IDE2Ljc3OTQgNS42ODkzNCAxNy4wNjA3QzUuOTcwNjQgMTcuMzQyIDYuMzUyMTggMTcuNSA2Ljc1IDE3LjVIMTcuMjVDMTcuNjQ3OCAxNy41IDE4LjAyOTQgMTcuMzQyIDE4LjMxMDcgMTcuMDYwN0MxOC41OTIgMTYuNzc5NCAxOC43NSAxNi4zOTc4IDE4Ljc1IDE2VjUuNUMxOC43NSA1LjEwMjE4IDE4LjU5MiA0LjcyMDY0IDE4LjMxMDcgNC40MzkzNEMxOC4wMjk0IDQuMTU4MDQgMTcuNjQ3OCA0IDE3LjI1IDRIMTYuNVYyLjVIMTVaTTExLjE2IDEwLjc1SDguNDUyNUwxMC42NDI1IDEyLjMzMjVMOS44MSAxNC45MkwxMiAxMy4zMjI1TDE0LjE5IDE0LjkyTDEzLjM1IDEyLjM0TDE1LjU0IDEwLjc1SDEyLjg0TDEyIDguMTdMMTEuMTYgMTAuNzVaIiBmaWxsPSIjMEI1NTk5Ii8+Cjwvc3ZnPgo=" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">Events</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Workshops, confs and more</div></div></div></a><a href="/community/contributor-program/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">Contributor Program</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Community and more</div></div></div></a><a href="/graphql/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">graphql</div><div class="hasura-ibm-plex-mono-small mobileNavHide">The GraphQL hub</div></div></div></a><a href="/help/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">help</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Get expert support</div></div></div></a></div><div><a href="/learn/"><div class="navListAnnouncement navLearnBg mb-32"><div class="hasura-ibm-plex-article-desc">Learn with Hasura<div class="arrow"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iOCIgaGVpZ2h0PSIxMCIgdmlld0JveD0iMCAwIDggMTAiIGZpbGw9Im5vbmUiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyI+CjxwYXRoIGQ9Ik0xLjUwMDEzIDlMNi41IDQuOTk5MTJMMS41IDEiIHN0cm9rZT0iI0YzRkZGQSIgc3Ryb2tlLXdpZHRoPSIxLjUiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8L3N2Zz4K" alt="Arrow" /></div></div><div class="hasura-ibm-plex-mono">Get started with GraphQL and Hasura from our selection of over 15 courses</div></div></a><a href="/graphql/database/"><div class="navListAnnouncement navDataBaseBg"><div class="hasura-ibm-plex-article-desc">Supported Databases<div class="arrow"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iOCIgaGVpZ2h0PSIxMCIgdmlld0JveD0iMCAwIDggMTAiIGZpbGw9Im5vbmUiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyI+CjxwYXRoIGQ9Ik0xLjUwMDEzIDlMNi41IDQuOTk5MTJMMS41IDEiIHN0cm9rZT0iI0YzRkZGQSIgc3Ryb2tlLXdpZHRoPSIxLjUiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8L3N2Zz4K" alt="Arrow" /></div></div><div class="hasura-ibm-plex-mono">Auto-generate GraphQL &amp; REST APIs for your data from any of our supported dbs</div></div></a></div></div></div></div></div></li><li class=""><a href="/pricing/">PRICING</a></li></ul></div><div class="navRight hideMobile"><ul class="navBarUL"><li class="m-nav-t navLogIn"><a href="https://cloud.hasura.io/?pg=events_webinar_diagnosing-improving-query-performance&amp;plcmt=header&amp;cta=log-in&amp;tech=default">LOG IN</a></li><li><a href="https://github.com/hasura/graphql-engine"><button class="hasura-btn hasura-btn-sm hasura-gray-github-btn"><img src="data:image/svg+xml;base64,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" alt="Github" /></button></a></li><li><a href="/contact-us/?type=hasuraenterprise"><button class="hasura-btn hasura-btn-sm hasura-gray-btn">CONTACT SALES</button></a></li><li><a href="https://cloud.hasura.io/signup?pg=events_webinar_diagnosing-improving-query-performance&amp;plcmt=header&amp;cta=try-hasura&amp;tech=default"><button class="hasura-btn hasura-btn-sm hasura-green-btn">GET STARTED NOW</button></a></li></ul></div><div id="navbar" class="topnav"><div class="githubMobile"><a href="https://github.com/hasura/graphql-engine"><button class="hasura-btn hasura-btn-sm hasura-gray-github-btn"><img src="data:image/svg+xml;base64,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" alt="Github" /></button></a></div><div class="navBarToggleBg"><span class="navBarToggle" aria-label="button" role="button" tabindex="0" id="menuClick"><span class="iconBar"></span><span class="iconBar"></span><span class="iconBar"></span></span></div><div class="visibleMobile"><div class="brand"><a href="/"><img src="data:image/svg+xml;base64,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" alt="Hasura Logo" title="Hasura Logo" /></a></div><div class="mobileNavListWrapper"><a href="/products/"><button class="hasura-btn hasura-btn-md hasura-light-gray-btn">Products</button></a><a href="/pricing/"><button class="hasura-btn hasura-btn-md hasura-light-gray-btn">Pricing</button></a><a href="https://hasura.io/docs/latest/graphql/core/index.html"><button class="hasura-btn hasura-btn-md hasura-light-gray-btn">Docs</button></a><a href="https://cloud.hasura.io/?pg=events_webinar_diagnosing-improving-query-performance&amp;plcmt=header&amp;cta=log-in&amp;tech=default"><button class="hasura-btn hasura-btn-md hasura-light-gray-btn">LOG IN</button></a></div><div class="navDrapdownWrapper"><div class="containerWrapper"><div class="hasura-ibm-plex-nav mobileNavShow mobileTitleResources">Resources</div><div class="navDrapdownListWrapper"><div class="navListWrapper"><a href="/learn/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">Tutorials</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Real-world GraphQL Tuts</div></div></div></a><a href="https://hasura.io/blog/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTE2LjUgMTcuNUMxNi44OTc4IDE3LjUgMTcuMjc5NCAxNy4zNDIgMTcuNTYwNyAxNy4wNjA3QzE3Ljg0MiAxNi43Nzk0IDE4IDE2LjM5NzggMTggMTZWNEMxOCAzLjE2NzUgMTcuMzI1IDIuNSAxNi41IDIuNUgxMlY3Ljc1TDEwLjEyNSA2LjYyNUw4LjI1IDcuNzVWMi41SDcuNUM3LjEwMjE4IDIuNSA2LjcyMDY0IDIuNjU4MDQgNi40MzkzNCAyLjkzOTM0QzYuMTU4MDQgMy4yMjA2NCA2IDMuNjAyMTggNiA0VjE2QzYgMTYuMzk3OCA2LjE1ODA0IDE2Ljc3OTQgNi40MzkzNCAxNy4wNjA3QzYuNzIwNjQgMTcuMzQyIDcuMTAyMTggMTcuNSA3LjUgMTcuNUgxNi41WiIgZmlsbD0iIzBCNTU5OSIvPgo8L3N2Zz4K" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">Blog</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Editorials and releases</div></div></div></a><a href="/user-stories/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">User stories</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Read user case-studies</div></div></div></a><a href="/events/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTE3LjI1IDE2SDYuNzVWNy43NUgxNy4yNVYxNlpNMTUgMi41VjRIOVYyLjVINy41VjRINi43NUM2LjM1MjE4IDQgNS45NzA2NCA0LjE1ODA0IDUuNjg5MzQgNC40MzkzNEM1LjQwODA0IDQuNzIwNjQgNS4yNSA1LjEwMjE4IDUuMjUgNS41VjE2QzUuMjUgMTYuMzk3OCA1LjQwODA0IDE2Ljc3OTQgNS42ODkzNCAxNy4wNjA3QzUuOTcwNjQgMTcuMzQyIDYuMzUyMTggMTcuNSA2Ljc1IDE3LjVIMTcuMjVDMTcuNjQ3OCAxNy41IDE4LjAyOTQgMTcuMzQyIDE4LjMxMDcgMTcuMDYwN0MxOC41OTIgMTYuNzc5NCAxOC43NSAxNi4zOTc4IDE4Ljc1IDE2VjUuNUMxOC43NSA1LjEwMjE4IDE4LjU5MiA0LjcyMDY0IDE4LjMxMDcgNC40MzkzNEMxOC4wMjk0IDQuMTU4MDQgMTcuNjQ3OCA0IDE3LjI1IDRIMTYuNVYyLjVIMTVaTTExLjE2IDEwLjc1SDguNDUyNUwxMC42NDI1IDEyLjMzMjVMOS44MSAxNC45MkwxMiAxMy4zMjI1TDE0LjE5IDE0LjkyTDEzLjM1IDEyLjM0TDE1LjU0IDEwLjc1SDEyLjg0TDEyIDguMTdMMTEuMTYgMTAuNzVaIiBmaWxsPSIjMEI1NTk5Ii8+Cjwvc3ZnPgo=" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">Events</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Workshops, confs and more</div></div></div></a><a href="/community/contributor-program/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">Contributor Program</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Community and more</div></div></div></a><a href="/graphql/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">graphql</div><div class="hasura-ibm-plex-mono-small mobileNavHide">The GraphQL hub</div></div></div></a><a href="/help/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">help</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Get expert support</div></div></div></a></div><div><a href="/learn/"><div class="navListAnnouncement navLearnBg mb-32"><div class="hasura-ibm-plex-article-desc">Learn with Hasura<div class="arrow"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iOCIgaGVpZ2h0PSIxMCIgdmlld0JveD0iMCAwIDggMTAiIGZpbGw9Im5vbmUiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyI+CjxwYXRoIGQ9Ik0xLjUwMDEzIDlMNi41IDQuOTk5MTJMMS41IDEiIHN0cm9rZT0iI0YzRkZGQSIgc3Ryb2tlLXdpZHRoPSIxLjUiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8L3N2Zz4K" alt="Arrow" /></div></div><div class="hasura-ibm-plex-mono">Get started with GraphQL and Hasura from our selection of over 15 courses</div></div></a><a href="/graphql/database/"><div class="navListAnnouncement navDataBaseBg"><div class="hasura-ibm-plex-article-desc">Supported Databases<div class="arrow"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iOCIgaGVpZ2h0PSIxMCIgdmlld0JveD0iMCAwIDggMTAiIGZpbGw9Im5vbmUiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyI+CjxwYXRoIGQ9Ik0xLjUwMDEzIDlMNi41IDQuOTk5MTJMMS41IDEiIHN0cm9rZT0iI0YzRkZGQSIgc3Ryb2tlLXdpZHRoPSIxLjUiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8L3N2Zz4K" alt="Arrow" /></div></div><div class="hasura-ibm-plex-mono">Auto-generate GraphQL &amp; REST APIs for your data from any of our supported dbs</div></div></a></div></div></div></div><div class="mobileNavButtonWrapper"><a href="https://cloud.hasura.io/signup?pg=events_webinar_diagnosing-improving-query-performance&amp;plcmt=header&amp;cta=try-hasura&amp;tech=default"><button class="hasura-btn hasura-btn-sm hasura-green-btn">GET STARTED NOW</button></a><a href="/contact-us/?type=hasuraenterprise"><button class="hasura-btn hasura-btn-sm hasura-gray-btn">CONTACT SALES</button></a></div></div></div></div></div></header><div class="wd100"><section class="commonSectionWrapper patternWrapper removePaddTop eventLightBlueBgColor"><img class="eventsDetailsLeft" src="/static/webinar-left-pattern-b4fa03176138b1f9382b035366b9507b.svg" alt="Left pattern" /><img class="eventsDetailsRight" src="/static/webinar-right-pattern-45e1a1b0257fa8e942e0a16a77e6957b.svg" alt="Left pattern" /><div class="containerWrapper"><div class="breadCrumbWrapper"><a class="" href="/events/">Events</a><span class="arrow">&gt;</span><a aria-current="page" class="underline" href="/events/webinar/diagnosing-improving-query-performance/">GraphQL Observability to Diagnose &amp; Improve Query Performance for your Hasura apps</a></div><div class="eventsDetailsTopBanner"><div><h1 class="articleTitle">GraphQL Observability to Diagnose &amp; Improve Query Performance for your Hasura apps</h1><div class="articleDescSmall eventMobileShow">Webinar | September 07, 2021 | 9 AM PST</div></div><div class="articleSubTitle alignSelfEnd">Learn how you can debug &amp; analyze query performance in your Hasura applications using the monitoring and observability features that Hasura provides.</div><div class="articleDescSmall eventMobileHide">Webinar | September 07, 2021 | 9 AM PST</div></div></div></section><section class="commonSectionWrapper removePaddTop commonGrayBgColor"><div class="containerWrapper"><div class="eventsDetailsWrapper eventsDetailsMarTopWrapper"><div><div class="formMinHeight"><div class="agendaWrapper"><div class="articleSubTitle">Agenda</div><ul class="articleDesc"><li><span>When you&#x27;re trying to diagnose why a particular GraphQL operation in Hasura is taking a long time to complete, or just want to better understand what&#x27;s going on &#x27;behind-the-scenes&#x27; in your queries, the ability to debug and analyze metrics from your Hasura instance is a critical factor.</span></li><li><span>In this hands-on webinar we will take a look at how to do this by:</span></li></ul><ul class="articleDesc"><li><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMTYiIGhlaWdodD0iMTIiIHZpZXdCb3g9IjAgMCAxNiAxMiIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTE2IDEuMjYxNzRMNS4wMjg1NyAxMkwwIDcuMDc4M0wxLjI4OTE0IDUuODE2NTZMNS4wMjg1NyA5LjQ2NzU2TDE0LjcxMDkgMEwxNiAxLjI2MTc0WiIgZmlsbD0iIzcxNzc4MCIvPgo8L3N2Zz4K" alt="Tick" /><div>Walking through the tools we have available: Analyze Feature on Hasura Console, Metrics Dashboard &amp; Query Tags on Hasura Cloud</div></li><li><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMTYiIGhlaWdodD0iMTIiIHZpZXdCb3g9IjAgMCAxNiAxMiIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTE2IDEuMjYxNzRMNS4wMjg1NyAxMkwwIDcuMDc4M0wxLjI4OTE0IDUuODE2NTZMNS4wMjg1NyA5LjQ2NzU2TDE0LjcxMDkgMEwxNiAxLjI2MTc0WiIgZmlsbD0iIzcxNzc4MCIvPgo8L3N2Zz4K" alt="Tick" /><div>Showcasing how to use these tools with a hands on demo &amp; illustrative examples</div></li><li><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMTYiIGhlaWdodD0iMTIiIHZpZXdCb3g9IjAgMCAxNiAxMiIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTE2IDEuMjYxNzRMNS4wMjg1NyAxMkwwIDcuMDc4M0wxLjI4OTE0IDUuODE2NTZMNS4wMjg1NyA5LjQ2NzU2TDE0LjcxMDkgMEwxNiAxLjI2MTc0WiIgZmlsbD0iIzcxNzc4MCIvPgo8L3N2Zz4K" alt="Tick" /><div>Discussing &#x27;gotchas&#x27; and useful tips as we go, so that you&#x27;re better equipped to avoid pitfalls and common issues</div></li></ul><ul class="articleDesc"><li><span class="fontBold">The webinar will be followed by a live Q&amp;A, so do bring any questions you may have!</span></li></ul></div></div></div><div><div class="formMinHeight"><div><form class="marketoFormWrapper webinarMarAuto" id="mktoForm_1019"></form></div></div><div class="hostDetailWrapper"><div class="hostWrapper"><div class="articleDesc fontBold">About the Presenters</div><div class="authorDetailsWrapper"><div class="authorImg"><img src="/static/gavin-caf8fe5e27fadef18ea029458a85042d.png" alt="Gavin Ray" /></div><div><div class="articleDescSmall fontBold">Gavin Ray</div><div class="articleDescSmall">Developer Advocate at Hasura</div></div></div></div></div></div></div></div></section><section class="commonSectionWrapper commonDarkGrayBgColor"><div class="containerWrapper"><div class="upComingEventWrapper"><div class="eventsHeaderWrapper"><h2 class="articleSubTitle">More Events like this</h2></div><div class="indivEventsWrapper"><a href="/events/webinar/graphql-in-production-with-hasura/"><div class="indivEventsList "><div class="indivEventIcon"><img src="data:image/svg+xml;base64,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" alt="GraphQL in Production" /></div><div class="indivEventsListContainer"><div class="articleDescSmall"><span>Webinar</span></div><div class="articleSubTitle">GraphQL in Production</div><div class="articleDesc">Learn about the powerful features that allow organisations to build and maintain secure, fast and highly scalable apps using our GraphQL API</div><div class="commonLink">View Recording<!-- --> <div class="arrow">→</div></div></div></div></a><a href="/events/webinar/data-federation-hasura-graphql/"><div class="indivEventsList "><div class="indivEventIcon"><img src="data:image/svg+xml;base64,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" alt="Data Federation with Hasura" /></div><div class="indivEventsListContainer"><div class="articleDescSmall"><span>Webinar</span></div><div class="articleSubTitle">Data Federation with Hasura</div><div class="articleDesc">Join data across your databases, microservices &amp; SaaS services (GraphQL &amp; REST) with Hasura</div><div class="commonLink">View Recording<!-- --> <div class="arrow">→</div></div></div></div></a><a href="/events/webinar/migrate-oss-hasura-hasura-cloud/"><div class="indivEventsList "><div class="indivEventIcon"><img src="data:image/svg+xml;base64,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" alt="Moving from OSS to Cloud" /></div><div class="indivEventsListContainer"><div class="articleDescSmall"><span>Live-stream</span></div><div class="articleSubTitle">Moving from OSS to Cloud</div><div class="articleDesc">Learn how to migrate a Hasura OSS instance to Cloud and why it makes sense for you.</div><div class="commonLink">View Recording<!-- --> <div class="arrow">→</div></div></div></div></a></div><div class="buttonWrapper"><a href="/events/"><button class="commonAction commonBlueBtn">Back to Events →</button></a></div></div></div></section></div><section id="events" class="commonSectionWrapper wd100 removePaddBottom"><div class="containerWrapper"><div class="eventsAnnounceWrapper"><div class="eventsAnnounceHeader hasuraGridWrapper twoGridColumnWrapper eventsAnnounceHeaderPos"><h2 class="articleTitle">We’d love to connect with you at one of our many global events.</h2><div class="buttonWrapper alignSelfEnd"><a href="/events/"><button class="hasura-btn hasura-btn-md hasura-blue-btn">See all Events</button></a></div></div><div class="eventsAnnounceImg"><img src="/static/event-img-f3c0ef1db616c7833b7b9e2ec7c4b2e4.png" alt="Event" /></div><div class="commonSectionWrapper removePaddTop eventsAnnounceHeader hasuraGridWrapper twoGridColumnWrapper mpMinus300"><a href="/events/hasura-con-2021/"><img class="mobileHide" src="/static/hasura-con-featured-3bb5b42eb9fe244a25222bc14216a961.png" alt="HasuraCon 2021" /><img class="mobileShow" src="/static/hasura-con-featured-mobile-fe83822181e9ad1fe99b94bc6e8e676d.png" alt="HasuraCon 2021" /></a><a href="/community/community-call/" class="textRight"><img class="smallImg" src="/static/community-call-featured-bf8cb59d588376ff2fb7e1b158686700.svg" alt="Community call" /></a></div></div></div></section><div class="commonSectionWrapper hasura-light-blue-bg-color removePaddTop"><div class="containerWrapper"><div class="newsletterWrapper mtPlus300"><div><div class="hasura-ibm-plex-sub-title">Ready to get started?</div><div class="articleDesc">Start for free on Hasura Cloud or you could contact our sales team for a detailed walk-through on how Hasura may benefit your business.</div><div class="buttonWrapper"><a href="https://cloud.hasura.io/?pg=events_webinar_diagnosing-improving-query-performance&amp;plcmt=footer&amp;cta=try-hasura&amp;tech=default"><button class="hasura-btn hasura-btn-md hasura-blue-btn">Get started now</button></a><a href="/contact-us/?type=hasuraenterprise"><button class="hasura-btn hasura-btn-md hasura-white-btn">CONTACT SALES</button></a></div></div><div class="subscribeNewsletterWrapper removePaddBottom" id="subscribe-updates"><div class="hasura-ibm-plex-sub-title">Get monthly product updates</div><div class="articleDesc">Sign up for full access to our product and community highlights, new features, and occasional baby animal gifs! Oh, and we have a strict no-spam rule.<!-- --> <span role="img" aria-label="Enoji">✌️</span></div> <div><form class="marketoFormWrapper subscribeNewsletterForm" id="mktoForm_1011"></form></div></div></div></div></div><footer class="wd100 hasura-light-blue-bg-color"><div class="containerWrapper"><div></div><div class="footerWrappper wd100"><div class="footerLinks hasura-ibm-plex-nav"><div class="footerLinksHeader">Hasura</div><a class="links" href="/about/">About Us</a><a class="links" href="/press/">Press</a><a href="/careers/" class="links">Careers</a><a class="links" href="/contact-us/">Contact Us</a><a class="links" href="/legal/">Legal Stuff</a></div><div class="footerLinks hasura-ibm-plex-nav"><div class="footerLinksHeader">Support</div><a href="https://hasura.io/docs/latest/graphql/core/index.html" class="links" target="_blank" rel="noopener noreferrer">Documentation</a><a href="https://discord.com/invite/hasura" class="links" target="_blank" rel="noopener noreferrer">Community Forum</a><a href="https://hasura.io/help" class="links">Website chat</a><a href="https://github.com/hasura" class="links" target="_blank" rel="noopener noreferrer">Github</a><a href="https://status.hasura.io/" class="links" target="_blank" rel="noopener noreferrer">Hasura Cloud Status</a><a href="https://hasura.io/cloud-survey/" class="links hide" target="_blank" rel="noopener noreferrer">Hasura Cloud Survey</a></div><div class="footerLinks hasura-ibm-plex-nav"><div class="footerLinksHeader">Tools</div><a href="https://github.com/hasura/graphqurl" class="links" target="_blank" rel="noopener noreferrer">Graphqurl</a><a href="https://github.com/hasura/firebase2graphql" class="links" target="_blank" rel="noopener noreferrer">Firebase2GraphQL</a><a href="https://github.com/hasura/json2graphql" class="links" target="_blank" rel="noopener noreferrer">JSON2GraphQL</a><a href="https://github.com/hasura/graphql2chartjs" class="links" target="_blank" rel="noopener noreferrer">GraphQL2ChartJS</a></div><div class="footerLinks hasura-ibm-plex-nav"><div class="footerLinksHeader">Product</div><a class="links" href="/opensource/">Hasura Open Source</a><a class="links" href="/cloud/">Hasura Cloud</a><a class="links" href="/enterprise/">Hasura Enterprise</a><a class="links" href="/pricing/">Pricing</a><a href="https://github.com/hasura/graphql-engine/releases" class="links" target="_blank" rel="noopener noreferrer">Changelog</a></div><div class="footerLinks hasura-ibm-plex-nav"><div class="footerLinksHeader">Resources</div><a href="https://hasura.io/blog/" class="links" target="_blank" rel="noopener noreferrer">Blog</a><a class="links" href="/user-stories/">User Stories</a><a href="https://3factor.app/" class="links" target="_blank" rel="noopener noreferrer">3Factor Apps</a><a class="links" href="/event-driven-programming/">Event Driven Programming</a><a class="links" href="/react-graphql/">React GraphQL</a><a class="links" href="/vue-graphql/">Vue GraphQL</a><a class="links" href="/diy-graphql-baas/">DIY GraphQL BaaS</a><a class="links" href="/graphql/">GraphQL &amp; Hasura</a><a class="links" href="/security/">Hasura Cloud Security</a></div><div class="footerLinks hasura-ibm-plex-nav"><div class="footerLinksHeader">Community</div><a class="links" href="/community/">Community Resources</a><a href="https://hasura.io/learn/" class="links" target="_blank" rel="noopener noreferrer">GraphQL Tutorials</a><a href="https://github.com/hasura/graphql-engine/wiki" class="links" target="_blank" rel="noopener noreferrer">Community Wiki</a><a class="links" href="/sample-apps/">Sample Apps</a><a class="links" href="/partner-agencies/">Partnership Program</a><a class="links" href="/events/hasura-con-2021/">HasuraCon 2021</a><a href="https://graphql.asia/" class="links" target="_blank" rel="noopener noreferrer">GraphQL Asia</a></div></div></div><div class="copyWriteWrapperBg wd100"><div class="containerWrapper"><div class="copyWriteWrapper"><div class="brand"><img src="data:image/svg+xml;base64,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" alt="Brand logo" /></div><div class="hasura-ibm-plex-mono">© <!-- -->2021<!-- --> Hasura Inc. All rights reserved</div><div class="footerSocialIconsWrapper"><div class="socialBrands"><a href="https://github.com/hasura/graphql-engine" rel="noopener noreferrer" aria-label="Github"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Github" /></a></div><div class="socialBrands"><a href="https://twitter.com/hasurahq" rel="noopener noreferrer" aria-label="Titter"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Titter" /></a></div><div class="socialBrands"><a href="https://discord.com/invite/hasura" rel="noopener noreferrer" aria-label="Discord"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Discord" /></a></div><div class="socialBrands"><a href="https://www.facebook.com/HasuraHQ" rel="noopener noreferrer" aria-label="Facebook"><img loading="lazy" src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTEyIDBDNS4zOTk5OSAwIDAgNS4zODc5OSAwIDEyLjAyNEMwIDE4LjAyNCA0LjM5MTk5IDIzLjAwNCAxMC4xMjggMjMuOTA0VjE1LjUwNEg3LjA3OTk5VjEyLjAyNEgxMC4xMjhWOS4zNzE5OUMxMC4xMjggNi4zNTk5OSAxMS45MTYgNC43MDM5OSAxNC42NjQgNC43MDM5OUMxNS45NzIgNC43MDM5OSAxNy4zNCA0LjkzMTk5IDE3LjM0IDQuOTMxOTlWNy44OTU5OUgxNS44MjhDMTQuMzQgNy44OTU5OSAxMy44NzIgOC44MTk5OSAxMy44NzIgOS43Njc5OVYxMi4wMjRIMTcuMjA4TDE2LjY2OCAxNS41MDRIMTMuODcyVjIzLjkwNEMxNi42OTk3IDIzLjQ1NzQgMTkuMjc0NiAyMi4wMTQ2IDIxLjEzMTkgMTkuODM2QzIyLjk4OTIgMTcuNjU3NSAyNC4wMDY0IDE0Ljg4NjggMjQgMTIuMDI0QzI0IDUuMzg3OTkgMTguNiAwIDEyIDBaIiBmaWxsPSIjNzE3NzgwIi8+Cjwvc3ZnPgo=" alt="Facebook" /></a></div><div class="socialBrands"><a href="https://www.instagram.com/hasurahq/?hl=en" rel="noopener noreferrer" aria-label="Instagram"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Instagram" /></a></div><div class="socialBrands"><a href="https://www.youtube.com/channel/UCZo1ciR8pZvdD3Wxp9aSNhQ" rel="noopener noreferrer" aria-label="Youtube"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Youtube" /></a></div><div class="socialBrands"><a href="https://www.linkedin.com/company/hasura" rel="noopener noreferrer" aria-label="Linkedin"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Linkedin" /></a></div></div></div></div></div></footer></div></div></div><div id="gatsby-announcer" style="position:absolute;top:0;width:1px;height:1px;padding:0;overflow:hidden;clip:rect(0, 0, 0, 0);white-space:nowrap;border:0" aria-live="assertive" aria-atomic="true"></div></div><script id="gatsby-script-loader">/*<![CDATA[*/window.pagePath="/events/webinar/diagnosing-improving-query-performance/";/*]]>*/</script><script id="gatsby-chunk-mapping">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</script><script src="/polyfill-3a49c548e242de176d38.js" nomodule=""></script><script src="/component---src-components-webinarvideos-webinarvideos-js-0221a4c0ade1e432b6d8.js" async=""></script><script src="/1f976be9dd44deba04b081efa6ddc79c24b170ea-98cb8c7f5d91d12880e4.js" async=""></script><script src="/d2408637e253f65cafc2b193037e5cb7f90cd981-d3506376003edb8d8c10.js" async=""></script><script src="/9907c54bf0ca54bed74b9d2db83464f15f5aea10-e0a701e34d43345dd805.js" async=""></script><script src="/commons-cfc2e38a7939f12cc44c.js" async=""></script><script src="/app-5ea939bc14a95df77faa.js" async=""></script><script src="/framework-660f14b4e2df4188b3f4.js" async=""></script><script src="/webpack-runtime-dc84cead993b8e9569b1.js" async=""></script></body></html>