<!DOCTYPE html><html lang="en"><head><meta charSet="utf-8" /><meta http-equiv="x-ua-compatible" content="ie=edge" /><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no" /><style data-href="/component---src-pages-case-studies-cajoo-js.193627c47cec71ce64fb.css" data-identity="gatsby-global-css">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</style><style data-href="/styles.056d4bebb3a23e43fa92.css" data-identity="gatsby-global-css">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</style><meta name="generator" content="Gatsby 3.14.3" /><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src= 'https://www.googletagmanager.com/gtm.js?id='+i+dl+'';f.parentNode.insertBefore(j,f); })(window,document,'script','dataLayer', 'GTM-KPWB7RN');</script><script>
      
      !function(){var analytics=window.analytics=window.analytics||[];if(!analytics.initialize)if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["trackSubmit","trackClick","trackLink","trackForm","pageview","identify","reset","group","track","ready","alias","debug","page","once","off","on","addSourceMiddleware","addIntegrationMiddleware","setAnonymousId","addDestinationMiddleware"];analytics.factory=function(e){return function(){var t=Array.prototype.slice.call(arguments);t.unshift(e);analytics.push(t);return analytics}};for(var e=0;e<analytics.methods.length;e++){var key=analytics.methods[e];analytics[key]=analytics.factory(key)}analytics.load=function(key,e){var t=document.createElement("script");t.type="text/javascript";t.async=!0;t.src="https://cdn.segment.io/analytics.js/v1/" + key + "/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(t,n);analytics._loadOptions=e};analytics._writeKey="RQXoHRpNcmBKllUDihjDjupGv4AHn5TB";analytics.SNIPPET_VERSION="4.13.2";
analytics.load('RQXoHRpNcmBKllUDihjDjupGv4AHn5TB');analytics.page();
}}();
    </script><style data-styled="" data-styled-version="5.3.3">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</style><title data-react-helmet="true">Case Study: Cajoo Migrated From Shopify in 4 weeks with Hasura Cloud</title><link data-react-helmet="true" rel="canonical" href="https://hasura.io/case-studies/cajoo/" /><meta data-react-helmet="true" name="title" content="Case Study: Cajoo Migrated From Shopify in 4 weeks with Hasura Cloud" /><meta data-react-helmet="true" name="description" content="Learn how Cajoo Migrated From Shopify in 4 weeks with Hasura Cloud while cutting down infrastructure costs by 95% and improving product load time" /><meta data-react-helmet="true" property="og:title" content="Case Study: Cajoo Migrated From Shopify in 4 weeks with Hasura Cloud" /><meta data-react-helmet="true" property="og:description" content="Learn how Cajoo Migrated From Shopify in 4 weeks with Hasura Cloud while cutting down infrastructure costs by 95% and improving product load time" /><meta data-react-helmet="true" property="og:image" content="https://graphql-engine-cdn.hasura.io/assets/main-site/hasura-cajoo-case-study.png" /><meta data-react-helmet="true" property="og:type" content="website" /><meta data-react-helmet="true" name="twitter:card" content="summary_large_image" /><meta data-react-helmet="true" name="twitter:title" content="Case Study: Cajoo Migrated From Shopify in 4 weeks with Hasura Cloud" /><meta data-react-helmet="true" name="twitter:description" content="Learn how Cajoo Migrated From Shopify in 4 weeks with Hasura Cloud while cutting down infrastructure costs by 95% and improving product load time" /><link rel="sitemap" type="application/xml" href="/sitemap.xml" /><link rel="icon" href="/favicon-32x32.png?v=6e6e57b4b98fec791dd9f3d077b80810" type="image/png" /><link rel="manifest" href="/manifest.webmanifest" crossorigin="anonymous" /><link rel="apple-touch-icon" sizes="48x48" href="/icons/icon-48x48.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="72x72" href="/icons/icon-72x72.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="96x96" href="/icons/icon-96x96.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="144x144" href="/icons/icon-144x144.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="192x192" href="/icons/icon-192x192.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="256x256" href="/icons/icon-256x256.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="384x384" href="/icons/icon-384x384.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="512x512" href="/icons/icon-512x512.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link crossorigin="" href="https://www.google.com" rel="preconnect" /><link crossorigin="" href="https://stats.g.doubleclick.net" rel="preconnect" /><link crossorigin="" href="https://page.hasura.io" rel="preconnect" /><link crossorigin="" href="https://connect.facebook.net" rel="preconnect" /><link rel="icon" href="/favicon-32x32.png?v=6e6e57b4b98fec791dd9f3d077b80810" type="image/png" /><link rel="manifest" href="/manifest.webmanifest" crossorigin="anonymous" /><meta name="theme-color" content="#663399" /><link rel="apple-touch-icon" sizes="48x48" href="/icons/icon-48x48.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="72x72" href="/icons/icon-72x72.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="96x96" href="/icons/icon-96x96.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="144x144" href="/icons/icon-144x144.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="192x192" href="/icons/icon-192x192.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="256x256" href="/icons/icon-256x256.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="384x384" href="/icons/icon-384x384.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="512x512" href="/icons/icon-512x512.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link as="script" rel="preload" href="/webpack-runtime-e1a814076c1d3ae7fbb1.js" /><link as="script" rel="preload" href="/framework-3bbebef96bf42a53ca88.js" /><link as="script" rel="preload" href="/app-c734dcb178fc22c51047.js" /><link as="script" rel="preload" href="/commons-ac12621159ac0636a9f4.js" /><link as="script" rel="preload" href="/227120c845cf2a80deb37a7a0aabac3b20d08350-6ee45d707eae4c160c26.js" /><link as="script" rel="preload" href="/a1faa3cb5d3d2ce3b26593328f575172e162a29d-3cd470fb01629a9db6eb.js" /><link as="script" rel="preload" href="/3f56c6fd23336a4ca18a1dccbc974164d737940f-dc0d1e1d44a0b52eb42e.js" /><link as="script" rel="preload" href="/0a1310c1dc5d572ceda91879a2dae8fa34cce823-5ac53bad26703e4f886b.js" /><link as="script" rel="preload" href="/component---src-pages-case-studies-cajoo-js-923678cea8d38794b17d.js" /><link as="fetch" rel="preload" href="/page-data/case-studies/cajoo/page-data.json" crossorigin="anonymous" /><link as="fetch" rel="preload" href="/page-data/sq/d/3000892485.json" crossorigin="anonymous" /><link as="fetch" rel="preload" href="/page-data/app-data.json" crossorigin="anonymous" /><link rel="preload" as="font" href="/fonts/IBM-Plex-Sans-600.woff2" type="font/woff2" crossorigin="anonymous" /><link rel="preload" as="font" href="/fonts/IBM-Plex-Sans-700.woff2" type="font/woff2" crossorigin="anonymous" /><link rel="preload" as="font" href="/fonts/IBM-Plex-Mono-300.woff2" type="font/woff2" crossorigin="anonymous" /><link rel="preload" as="font" href="/fonts/IBM-Plex-Mono-200.woff2" type="font/woff2" crossorigin="anonymous" /><link rel="preload" href="https://page.hasura.io/js/forms2/css/forms2.css" as="style" /><link rel="preload" href="https://page.hasura.io/js/forms2/css/forms2-theme-simple.css" as="style" /><script type="application/ld+json">{
              "@context": "http://schema.org/",
              "@type": "Organization",
              "name": "Hasura",
              "logo": "https://hasura.io/logo.svg",
              "url": "https://hasura.io",
              "foundingDate": "2015",
              "address": {
                "@type": "PostalAddress",
                "addressLocality": "Bangalore",
                "addressRegion": "Karnataka",
                "postalCode": "560034",
                "streetAddress": "2nd Floor, Building, No 37/38, 80 Feet Rd, 3rd Block, Koramangala 1A Block, SBI Colony, Koramangala"
              },
              "founders": [{"@type": "Person","name": "Tanmai Gopal"},{"@type": "Person","name": "Rajoshi Ghosh"}],
              "contactPoint": {
                 "@type": "ContactPoint",
                 "contactType": "Sales",
                 "email": "build@hasura.io",
                 "url": "https://hasura.io"
              },
              "sameAs": [
                "https://en.wikipedia.org/wiki/Hasura",
                "https://www.wikidata.org/wiki/Q56676515",
                "https://www.facebook.com/HasuraHQ",
                "https://www.twitter.com/hasurahq",
                "https://www.linkedin.com/company/hasura",
                "https://www.instagram.com/hasurahq",
                "https://www.youtube.com/hasurahq"
              ]
          }</script><script type="application/ld+json">{
              "@context": "http://schema.org",
              "@type": "WebSite",
              "name": "Hasura",
              "url": "https://hasura.io"
          }</script></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KPWB7RN" height="0" width="0" style="display: none; visibility: hidden" aria-hidden="true"></iframe></noscript><div id="___gatsby"><div style="outline:none" tabindex="-1" id="gatsby-focus-wrapper"><div id="layoutContentWrapper" class="viewport"><div class="StyledBanner-sc-1nwrdmh-0 fXFrnA"><div class="commonBannerStripWrapper"><a href="https://hasura.io/events/webinar/rest-connectors/" class="text-contnet mobileBannerHide"><span class="emoji" role="img" aria-label="emoji">👋</span>Introducing REST Connectors in Hasura - Sign up for the Webinar<div class="arrow"> &gt;</div></a><a href="https://hasura.io/events/webinar/rest-connectors/" class="text-contnet hasura-font-bold mobileBannerShow"><div class="mWd">Introducing REST Connectors in Hasura - Sign up for the Webinar<div class="arrow"> &gt;</div></div></a><div class="closeBanner" role="button" tabindex="0"><svg width="24" height="24" viewBox="0 0 24 24" fill="none" xmlns="http://www.w3.org/2000/svg"><g clip-path="url(#clip0)"><path d="M18.2988 5.70744C17.9088 5.31744 17.2788 5.31744 16.8888 5.70744L11.9988 10.5874L7.10875 5.69744C6.71875 5.30744 6.08875 5.30744 5.69875 5.69744C5.30875 6.08744 5.30875 6.71744 5.69875 7.10744L10.5888 11.9974L5.69875 16.8874C5.30875 17.2774 5.30875 17.9074 5.69875 18.2974C6.08875 18.6874 6.71875 18.6874 7.10875 18.2974L11.9988 13.4074L16.8888 18.2974C17.2788 18.6874 17.9088 18.6874 18.2988 18.2974C18.6888 17.9074 18.6888 17.2774 18.2988 16.8874L13.4088 11.9974L18.2988 7.10744C18.6788 6.72744 18.6788 6.08744 18.2988 5.70744Z" fill="white"></path></g><defs><clipPath id="clip0"><rect width="24" height="24" fill="white"></rect></clipPath></defs></svg></div></div></div><div class="wd100"><header id="header" class="lightModeHeader stickyOnMobile"><div class="containerWrapper"><div class="headerWrapper"><div id="navBrand" class="navLeft"><div class="brand"><a href="/"><img src="data:image/svg+xml;base64,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" alt="Hasura Logo" title="Hasura Logo" /></a></div></div><div class="navCenter hideMobile"><ul class="navBarUL"><li class="github-btn-header"><span><a href="https://github.com/hasura/graphql-engine" data-size="large" data-show-count="true" aria-label="Star @hasura on GitHub">Star</a></span></li><li class="dropDownList" id="product-nav-dropdown"><a role="button" tabindex="0" class="dropdown-link-btn">Product</a><div id="product-nav" class="zIndex dropDownContent"><div class="navDrapdownWrapper"><div class="dropdown-column-section product-section"><a href="/products/"><div class="product-content-wrapper"><h4>PRODUCT</h4><img src="data:image/png;base64,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" alt="Product" id="product-illus" /><h2>Hasura Product Offerings</h2><p>Choose from our Open Source Community Edition, fully-managed Hasura Cloud or on-prem Hasura Enterprise Edition.</p><div class="nav-link">Go To Products<img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMTgiIGhlaWdodD0iMTkiIHZpZXdCb3g9IjAgMCAxOCAxOSIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPGcgY2xpcC1wYXRoPSJ1cmwoI2NsaXAwKSI+CjxwYXRoIGQ9Ik02Ljk2OTM4IDUuNzgzMTZDNi42NzY4NyA2LjA3NTY2IDYuNjc2ODcgNi41NDgxNiA2Ljk2OTM4IDYuODQwNjZMOS44NzkzOCA5Ljc1MDY3TDYuOTY5MzggMTIuNjYwN0M2LjY3Njg3IDEyLjk1MzIgNi42NzY4NyAxMy40MjU3IDYuOTY5MzggMTMuNzE4MkM3LjI2MTg4IDE0LjAxMDcgNy43MzQzOCAxNC4wMTA3IDguMDI2ODggMTMuNzE4MkwxMS40Njk0IDEwLjI3NTdDMTEuNzYxOSA5Ljk4MzE3IDExLjc2MTkgOS41MTA2NiAxMS40Njk0IDkuMjE4MTZMOC4wMjY4OCA1Ljc3NTY2QzcuNzQxODggNS40OTA2NiA3LjI2MTg4IDUuNDkwNjYgNi45NjkzOCA1Ljc4MzE2WiIgZmlsbD0iIzAwNzlCRCIvPgo8L2c+CjxkZWZzPgo8Y2xpcFBhdGggaWQ9ImNsaXAwIj4KPHJlY3Qgd2lkdGg9IjE4IiBoZWlnaHQ9IjE4IiBmaWxsPSJ3aGl0ZSIgdHJhbnNmb3JtPSJ0cmFuc2xhdGUoMCAwLjc0OTk4NSkiLz4KPC9jbGlwUGF0aD4KPC9kZWZzPgo8L3N2Zz4K" alt="Arrow" class="arrow-img" /></div></div></a></div><div class="center-content-section dropdown-column-section"><h4>GRAPHQL IN PRODUCTION</h4><a href="/graphql/caching/"><div class="dropdown-hover-effect-div"><h2>Caching</h2><p>Get faster response times</p></div></a><a href="/graphql/security/"><div class="dropdown-hover-effect-div"><h2>Security</h2><p>Declaratively protect your APIs</p></div></a><a href="/graphql/monitoring/"><div class="dropdown-hover-effect-div"><h2>Monitoring and Observability</h2><p>Get insights on your API performance</p></div></a><a href="/graphql/production-ready-existing-apis/"><div class="dropdown-hover-effect-div"><h2>Existing GraphQL APIs</h2><p>Add your GraphQL servers to Hasura </p></div></a></div><div class="navDrapdownListWrapper"><div class="content-div dropdown-column-section"><h4>SUPPORTED DATABASES</h4><a href="/graphql/database/postgresql/"><div class="dropdown-db-link dropdown-hover-effect-div"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iNDgiIGhlaWdodD0iNDgiIHZpZXdCb3g9IjAgMCA0OCA0OCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTcuMjUgOEM3LjI1IDYuNDgxMjIgOC40ODEyMiA1LjI1IDEwIDUuMjVIMzhDMzkuNTE4OCA1LjI1IDQwLjc1IDYuNDgxMjIgNDAuNzUgOFY0MEM0MC43NSA0MS41MTg4IDM5LjUxODggNDIuNzUgMzggNDIuNzVIMTBDOC40ODEyMiA0Mi43NSA3LjI1IDQxLjUxODggNy4yNSA0MFY4WiIgc3Ryb2tlPSIjMTY5OUUyIiBzdHJva2Utd2lkdGg9IjIuNSIgc3Ryb2tlLWxpbmVjYXA9InJvdW5kIiBzdHJva2UtbGluZWpvaW49InJvdW5kIi8+CjxwYXRoIGQ9Ik04IDE3LjVINDAiIHN0cm9rZT0iIzE2OTlFMiIgc3Ryb2tlLXdpZHRoPSIyLjUiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8cGF0aCBkPSJNOCAzMUg0MCIgc3Ryb2tlPSIjMTY5OUUyIiBzdHJva2Utd2lkdGg9IjIuNSIgc3Ryb2tlLWxpbmVjYXA9InJvdW5kIiBzdHJva2UtbGluZWpvaW49InJvdW5kIi8+Cjwvc3ZnPgo=" alt="hasura-database" class="db_icon" /><h2>Postgres</h2></div></a><a href="/graphql/database/sql-server/"><div class="dropdown-db-link dropdown-hover-effect-div"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iNDgiIGhlaWdodD0iNDgiIHZpZXdCb3g9IjAgMCA0OCA0OCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTcuMjUgOEM3LjI1IDYuNDgxMjIgOC40ODEyMiA1LjI1IDEwIDUuMjVIMzhDMzkuNTE4OCA1LjI1IDQwLjc1IDYuNDgxMjIgNDAuNzUgOFY0MEM0MC43NSA0MS41MTg4IDM5LjUxODggNDIuNzUgMzggNDIuNzVIMTBDOC40ODEyMiA0Mi43NSA3LjI1IDQxLjUxODggNy4yNSA0MFY4WiIgc3Ryb2tlPSIjMTY5OUUyIiBzdHJva2Utd2lkdGg9IjIuNSIgc3Ryb2tlLWxpbmVjYXA9InJvdW5kIiBzdHJva2UtbGluZWpvaW49InJvdW5kIi8+CjxwYXRoIGQ9Ik04IDE3LjVINDAiIHN0cm9rZT0iIzE2OTlFMiIgc3Ryb2tlLXdpZHRoPSIyLjUiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8cGF0aCBkPSJNOCAzMUg0MCIgc3Ryb2tlPSIjMTY5OUUyIiBzdHJva2Utd2lkdGg9IjIuNSIgc3Ryb2tlLWxpbmVjYXA9InJvdW5kIiBzdHJva2UtbGluZWpvaW49InJvdW5kIi8+Cjwvc3ZnPgo=" alt="hasura-database" class="db_icon" /><h2>SQL Server</h2></div></a><a href="https://hasura.io/docs/latest/graphql/core/databases/bigquery/getting-started.html"><div class="dropdown-db-link dropdown-hover-effect-div"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iNDgiIGhlaWdodD0iNDgiIHZpZXdCb3g9IjAgMCA0OCA0OCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTcuMjUgOEM3LjI1IDYuNDgxMjIgOC40ODEyMiA1LjI1IDEwIDUuMjVIMzhDMzkuNTE4OCA1LjI1IDQwLjc1IDYuNDgxMjIgNDAuNzUgOFY0MEM0MC43NSA0MS41MTg4IDM5LjUxODggNDIuNzUgMzggNDIuNzVIMTBDOC40ODEyMiA0Mi43NSA3LjI1IDQxLjUxODggNy4yNSA0MFY4WiIgc3Ryb2tlPSIjMTY5OUUyIiBzdHJva2Utd2lkdGg9IjIuNSIgc3Ryb2tlLWxpbmVjYXA9InJvdW5kIiBzdHJva2UtbGluZWpvaW49InJvdW5kIi8+CjxwYXRoIGQ9Ik04IDE3LjVINDAiIHN0cm9rZT0iIzE2OTlFMiIgc3Ryb2tlLXdpZHRoPSIyLjUiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8cGF0aCBkPSJNOCAzMUg0MCIgc3Ryb2tlPSIjMTY5OUUyIiBzdHJva2Utd2lkdGg9IjIuNSIgc3Ryb2tlLWxpbmVjYXA9InJvdW5kIiBzdHJva2UtbGluZWpvaW49InJvdW5kIi8+Cjwvc3ZnPgo=" alt="hasura-database" class="db_icon" /><h2>Big Query</h2></div></a><div class="coming-soon-div"><h4>COMING SOON</h4><div class="db-flex"><a href="/graphql/database/oracle/"><h2>Oracle</h2></a><a href="/graphql/database/mongodb/"><h2>MongoDb</h2></a><a href="/graphql/database/mysql/"><h2>MySQL</h2></a><a href="/graphql/database/elasticsearch/"><h2>Elastic</h2></a></div></div></div></div></div></div></li><li class="dropDownList"><a role="button" tabindex="0" class="dropdown-link-btn">Resources</a><div id="resource-nav" class="zIndex dropDownContent"><div class="navDrapdownWrapper resources-dropdown"><div class="dropdown-column-section developers-section"><h4>LEARNING RESOURCES</h4><a href="/learn/"><div class="navList dropdown-hover-effect-div"><div class="navListImg"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTIzIDEwVjE3TTIzIDEwTDEyIDRMMSAxMEw0LjUgMTJNMjMgMTBMMTIgMTZMNC41IDEyTTQuNSAxMlYxNy41TDEyIDIxLjVMMTkuNSAxNy41VjEyIiBzdHJva2U9IiMwMDc5QkQiIHN0cm9rZS13aWR0aD0iMS41IiBzdHJva2UtbGluZWNhcD0icm91bmQiIHN0cm9rZS1saW5lam9pbj0icm91bmQiLz4KPC9zdmc+Cg==" alt="icon" /></div><h2>Learn</h2></div></a><a href="https://hasura.io/blog/"><div class="navList dropdown-hover-effect-div"><div class="navListImg"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHJlY3QgeD0iNCIgeT0iMiIgd2lkdGg9IjE2IiBoZWlnaHQ9IjIwIiByeD0iMS43Nzc3OCIgc3Ryb2tlPSIjMDA3OUJEIiBzdHJva2Utd2lkdGg9IjEuNSIgc3Ryb2tlLWxpbmVjYXA9InJvdW5kIiBzdHJva2UtbGluZWpvaW49InJvdW5kIi8+CjxwYXRoIGQ9Ik0xMSAxMFYySDE3VjEwTDE0IDhMMTEgMTBaIiBzdHJva2U9IiMwMDc5QkQiIHN0cm9rZS13aWR0aD0iMS41IiBzdHJva2UtbGluZWNhcD0icm91bmQiIHN0cm9rZS1saW5lam9pbj0icm91bmQiLz4KPC9zdmc+Cg==" alt="icon" /></div><h2>Blog</h2></div></a><a href="/events/"><div class="navList dropdown-hover-effect-div"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><h2>Community Events</h2></div></a><a href="/community/contributor-program/"><div class="navList dropdown-hover-effect-div"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><h2>Contributor Program</h2></div></a><a href="/help/"><div class="navList dropdown-hover-effect-div"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><h2>Help</h2></div></a></div><div class="developers-section dropdown-column-section"><h4 id="m-invisible" style="opacity:0">Resources</h4><a href="/case-studies/"><div class="navList dropdown-hover-effect-div"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><h2>Case Studies</h2></div></a><a href="/graphql/"><div class="navList dropdown-hover-effect-div"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><h2>GraphQL Hub</h2></div></a><a href="/why-hasura/"><div class="navList dropdown-hover-effect-div"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><h2>Why Hasura</h2></div></a><a href="/data-hub/"><div class="navList dropdown-hover-effect-div"><div class="navListImg"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHJlY3QgeD0iMTIuNDU5IiB5PSIyIiB3aWR0aD0iMTEuOTYxNiIgaGVpZ2h0PSIxMS45NjE2IiByeD0iMSIgdHJhbnNmb3JtPSJyb3RhdGUoNDUgMTIuNDU5IDIpIiBzdHJva2U9IiMwMDc5QkQiIHN0cm9rZS13aWR0aD0iMS41IiBzdHJva2UtbGluZWNhcD0icm91bmQiIHN0cm9rZS1saW5lam9pbj0icm91bmQiLz4KPHJlY3QgeD0iMTIuNDU5IiB5PSI2LjA4Mzk4IiB3aWR0aD0iMTEuOTYxNiIgaGVpZ2h0PSIxMS45NjE2IiByeD0iMSIgdHJhbnNmb3JtPSJyb3RhdGUoNDUgMTIuNDU5IDYuMDgzOTgpIiBzdHJva2U9IiMwMDc5QkQiIHN0cm9rZS13aWR0aD0iMS41IiBzdHJva2UtbGluZWNhcD0icm91bmQiIHN0cm9rZS1saW5lam9pbj0icm91bmQiLz4KPC9zdmc+Cg==" alt="icon" /></div><h2>Data Hub</h2></div></a></div><div class="navDrapdownListWrapper"><div class="news-div dropdown-column-section"><a href="https://hasura.io/blog/graphql-and-the-data-mesh-developer-productivity-in-an-age-of-exploding-data/" target="_blank" rel="noopener noreferrer"><div class="navListAnnouncement"><div class="flex-heading"><h4 class="mb-24">NEWS</h4><div class="nav-link">Read More <img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMTgiIGhlaWdodD0iMTkiIHZpZXdCb3g9IjAgMCAxOCAxOSIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPGcgY2xpcC1wYXRoPSJ1cmwoI2NsaXAwKSI+CjxwYXRoIGQ9Ik02Ljk2OTM4IDUuNzgzMTZDNi42NzY4NyA2LjA3NTY2IDYuNjc2ODcgNi41NDgxNiA2Ljk2OTM4IDYuODQwNjZMOS44NzkzOCA5Ljc1MDY3TDYuOTY5MzggMTIuNjYwN0M2LjY3Njg3IDEyLjk1MzIgNi42NzY4NyAxMy40MjU3IDYuOTY5MzggMTMuNzE4MkM3LjI2MTg4IDE0LjAxMDcgNy43MzQzOCAxNC4wMTA3IDguMDI2ODggMTMuNzE4MkwxMS40Njk0IDEwLjI3NTdDMTEuNzYxOSA5Ljk4MzE3IDExLjc2MTkgOS41MTA2NiAxMS40Njk0IDkuMjE4MTZMOC4wMjY4OCA1Ljc3NTY2QzcuNzQxODggNS40OTA2NiA3LjI2MTg4IDUuNDkwNjYgNi45NjkzOCA1Ljc4MzE2WiIgZmlsbD0iIzAwNzlCRCIvPgo8L2c+CjxkZWZzPgo8Y2xpcFBhdGggaWQ9ImNsaXAwIj4KPHJlY3Qgd2lkdGg9IjE4IiBoZWlnaHQ9IjE4IiBmaWxsPSJ3aGl0ZSIgdHJhbnNmb3JtPSJ0cmFuc2xhdGUoMCAwLjc0OTk4NSkiLz4KPC9jbGlwUGF0aD4KPC9kZWZzPgo8L3N2Zz4K" alt="Arrow" class="arrow-img" /></div></div><h2>GraphQL &amp; the Data Mesh - developer productivity in an age of exploding data</h2><h4 class="zero-m">Oct 13, 2021</h4></div></a><hr class="news-section-line-break" /><a href="https://us02web.zoom.us/meeting/register/tZcscuuorTotG9d9HENmz-XIoRpHUPIihGHK" target="_blank" rel="noopener noreferrer"><div class="navListAnnouncement"><div class="flex-heading"><h4>Hasura Cloud Office Hours</h4><div class="nav-link">Join In <img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMTgiIGhlaWdodD0iMTkiIHZpZXdCb3g9IjAgMCAxOCAxOSIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPGcgY2xpcC1wYXRoPSJ1cmwoI2NsaXAwKSI+CjxwYXRoIGQ9Ik02Ljk2OTM4IDUuNzgzMTZDNi42NzY4NyA2LjA3NTY2IDYuNjc2ODcgNi41NDgxNiA2Ljk2OTM4IDYuODQwNjZMOS44NzkzOCA5Ljc1MDY3TDYuOTY5MzggMTIuNjYwN0M2LjY3Njg3IDEyLjk1MzIgNi42NzY4NyAxMy40MjU3IDYuOTY5MzggMTMuNzE4MkM3LjI2MTg4IDE0LjAxMDcgNy43MzQzOCAxNC4wMTA3IDguMDI2ODggMTMuNzE4MkwxMS40Njk0IDEwLjI3NTdDMTEuNzYxOSA5Ljk4MzE3IDExLjc2MTkgOS41MTA2NiAxMS40Njk0IDkuMjE4MTZMOC4wMjY4OCA1Ljc3NTY2QzcuNzQxODggNS40OTA2NiA3LjI2MTg4IDUuNDkwNjYgNi45NjkzOCA1Ljc4MzE2WiIgZmlsbD0iIzAwNzlCRCIvPgo8L2c+CjxkZWZzPgo8Y2xpcFBhdGggaWQ9ImNsaXAwIj4KPHJlY3Qgd2lkdGg9IjE4IiBoZWlnaHQ9IjE4IiBmaWxsPSJ3aGl0ZSIgdHJhbnNmb3JtPSJ0cmFuc2xhdGUoMCAwLjc0OTk4NSkiLz4KPC9jbGlwUGF0aD4KPC9kZWZzPgo8L3N2Zz4K" alt="Arrow" class="arrow-img" /></div></div><h2>Join us for Hasura Cloud office hours in November. Every Wednesday at 9:30am PT/ 12:30 pm ET.</h2></div></a></div></div></div></div></li><li><a href="https://hasura.io/docs/latest/graphql/core/index.html" target="_blank" rel="noopener noreferrer" style="text-decoration:none">Docs</a></li><li class=""><a href="/pricing/">Pricing</a></li></ul></div><div class="navRight hideMobile"><ul class="navBarUL"><li class="search-icon search-icon-web"><svg id="search-alt-icon" width="7" height="17" viewBox="0 0 7 17" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M1.5 16.5L5.96718 1.06173" stroke="#1b2738" stroke-width="1.5" stroke-linejoin="round"></path></svg><svg class="styled__StyledSVG-sc-1016hl4-0 jnzEFx" viewBox="0 0 24 24" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M15.5 14H14.71L14.43 13.73C15.41 12.59 16 11.11 16 9.5C16 5.91 13.09 3 9.5 3C5.91 3 3 5.91 3 9.5C3 13.09 5.91 16 9.5 16C11.11 16 12.59 15.41 13.73 14.43L14 14.71V15.5L18.2929 19.7843C18.6835 20.1742 19.3162 20.1738 19.7064 19.7836L19.7836 19.7064C20.1738 19.3162 20.1742 18.6835 19.7843 18.2929L15.5 14ZM9.5 14C7.01 14 5 11.99 5 9.5C5 7.01 7.01 5 9.5 5C11.99 5 14 7.01 14 9.5C14 11.99 11.99 14 9.5 14Z"></path></svg></li><li><a href="/contact-us/?type=hasuraenterprise">Contact Sales</a></li><li class="navLogIn"><a href="https://cloud.hasura.io/login?pg=case-studies_cajoo&amp;plcmt=header&amp;cta=log-in&amp;tech=default">Login</a></li><li><a href="https://cloud.hasura.io/signup?pg=case-studies_cajoo&amp;plcmt=header&amp;cta=try-hasura&amp;tech=default"><button class="hasura-btn hasura-btn-sm hasura-blue-btn">Get Started</button></a></li></ul></div></div></div><div id="navbar" class="topnav" style="height:0px"><div class="navBarToggleBg"><div class="navBarToggle search-icon"><svg class="styled__StyledSVG-sc-1016hl4-0 jnzEFx" viewBox="0 0 24 24" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M15.5 14H14.71L14.43 13.73C15.41 12.59 16 11.11 16 9.5C16 5.91 13.09 3 9.5 3C5.91 3 3 5.91 3 9.5C3 13.09 5.91 16 9.5 16C11.11 16 12.59 15.41 13.73 14.43L14 14.71V15.5L18.2929 19.7843C18.6835 20.1742 19.3162 20.1738 19.7064 19.7836L19.7836 19.7064C20.1738 19.3162 20.1742 18.6835 19.7843 18.2929L15.5 14ZM9.5 14C7.01 14 5 11.99 5 9.5C5 7.01 7.01 5 9.5 5C11.99 5 14 7.01 14 9.5C14 11.99 11.99 14 9.5 14Z"></path></svg></div><span class="navBarToggle" aria-label="button" role="button" tabindex="0" id="menuClick"><span class="iconBar"></span><span class="iconBar"></span><span class="iconBar"></span></span></div><div class="visibleMobile"><div class="mobileNavListWrapper"><div><button class="hasura-btn hasura-btn-md hasura-light-gray-btn grey-border">Product<!-- --> <img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjUiIHZpZXdCb3g9IjAgMCAyNCAyNSIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTkuMjg4NTkgNy4yMDk3OEM4Ljg5ODU5IDcuNTk5NzggOC44OTg1OSA4LjIyOTc4IDkuMjg4NTkgOC42MTk3OEwxMy4xNjg2IDEyLjQ5OThMOS4yODg1OSAxNi4zNzk4QzguODk4NTkgMTYuNzY5OCA4Ljg5ODU5IDE3LjM5OTggOS4yODg1OSAxNy43ODk4QzkuNjc4NTkgMTguMTc5OCAxMC4zMDg2IDE4LjE3OTggMTAuNjk4NiAxNy43ODk4TDE1LjI4ODYgMTMuMTk5OEMxNS42Nzg2IDEyLjgwOTggMTUuNjc4NiAxMi4xNzk4IDE1LjI4ODYgMTEuNzg5OEwxMC42OTg2IDcuMTk5NzhDMTAuMzE4NiA2LjgxOTc4IDkuNjc4NTkgNi44MTk3OCA5LjI4ODU5IDcuMjA5NzhaIiBmaWxsPSIjMDAzMTVGIi8+Cjwvc3ZnPgo=" alt="right-arrow" class="" /></button><button class="hasura-btn hasura-btn-md hasura-light-gray-btn grey-border">Resources<!-- --> <img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjUiIHZpZXdCb3g9IjAgMCAyNCAyNSIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTkuMjg4NTkgNy4yMDk3OEM4Ljg5ODU5IDcuNTk5NzggOC44OTg1OSA4LjIyOTc4IDkuMjg4NTkgOC42MTk3OEwxMy4xNjg2IDEyLjQ5OThMOS4yODg1OSAxNi4zNzk4QzguODk4NTkgMTYuNzY5OCA4Ljg5ODU5IDE3LjM5OTggOS4yODg1OSAxNy43ODk4QzkuNjc4NTkgMTguMTc5OCAxMC4zMDg2IDE4LjE3OTggMTAuNjk4NiAxNy43ODk4TDE1LjI4ODYgMTMuMTk5OEMxNS42Nzg2IDEyLjgwOTggMTUuNjc4NiAxMi4xNzk4IDE1LjI4ODYgMTEuNzg5OEwxMC42OTg2IDcuMTk5NzhDMTAuMzE4NiA2LjgxOTc4IDkuNjc4NTkgNi44MTk3OCA5LjI4ODU5IDcuMjA5NzhaIiBmaWxsPSIjMDAzMTVGIi8+Cjwvc3ZnPgo=" class="" alt="right-arrow" /></button><a href="https://hasura.io/docs/latest/graphql/core/index.html"><button class="hasura-btn hasura-btn-md hasura-light-gray-btn grey-border">Docs</button></a><a href="/pricing/"><button class="hasura-btn hasura-btn-md hasura-light-gray-btn grey-border">Pricing</button></a><button class="hasura-btn hasura-btn-md hasura-light-gray-btn grey-border"><a style="color:#00315f" href="/contact-us/?type=hasuraenterprise">Contact Sales</a><span class="mobile-github-btn-div"><span><a href="https://github.com/hasura/graphql-engine" data-size="large" data-show-count="true" aria-label="Star @hasura on GitHub">Star</a></span></span></button></div><div class="m-get-started" id="mobile-header-cta"><a href="https://cloud.hasura.io/signup?pg=case-studies_cajoo&amp;plcmt=header&amp;cta=try-hasura&amp;tech=default"><button class="hasura-btn hasura-btn-md hasura-blue-btn">Get Started</button></a></div></div></div></div></header><div class="wd100"><div class="StyledCaseStudy-sc-b7y17j-0 bRFksX"><div class="StyledCaseStudyHeader-sc-12v11yx-0 dxygcR"><div class="case-study-header containerWrapper"><div><h2>THE cajoo CASESTUDY</h2></div><div class="nav-points"><a href="https://hasura.io/case-studies/cajoo/#big-hits">THE BIG HITS</a><a href="https://hasura.io/case-studies/cajoo/#problem">PROBLEM</a><a href="https://hasura.io/case-studies/cajoo/#solution">SOLUTION</a><a href="https://hasura.io/case-studies/cajoo/#results">RESULTS</a></div></div></div><div class="landing-banner"><div class="containerWrapper"><div class="pipe-info-div"><p class="case-study-info-desc">In conversation with Jérémy Gotteland</p><h1>How Cajoo Migrated From Shopify in 4 weeks with Hasura Cloud</h1><p id="big-hits"><span><a href="https://www.cajoo.eu/" target="_blank" rel="noopener noreferrer">Cajoo</a> is a French direct-to-customer delivery app that delivers fresh groceries in 15 minutes (from when the order is placed to the customer&#x27;s doorstep). It&#x27;s one of the fastest-growing startups in Europe, gaining <a href="https://sifted.eu/articles/cajoo-carrefour-fundraise/" target="_blank" rel="noopener noreferrer">over 100,000 users</a> in less than nine months and recently raising $40 million in funding.</span></p></div><div class="StyledBigHits-sc-1tw3y9w-0 kJppts"><div class="timeline-card"><div class="number-div">1</div><p>95% monthly cost savings</p></div><div class="timeline-card"><div class="number-div">2</div><p>Four weeks from concept to production with three engineers</p></div><div class="timeline-card"><div class="number-div">3</div><p>Excellent performance that automatically scales to meet client demand</p></div></div></div></div><div class="containerWrapper"><div class="StyledSpeakerCard-sc-181u452-0 cMYlFB"><div class="speaker-img-div"></div><div class="speaker-info-div flex-column justify-center"><h2>“As a team of full-stack developers, we realized that we only had to focus on the frontend because Hasura took care of most of our backend work.”</h2><p>Jérémy Gotteland</p><p class="speaker-info-text">Co-founder and CTO, Cajoo</p></div></div><div class="case-study-content-div" id="problem"><div class="left-section"><div class="left-head-section"><p>The Problem</p><h3>Cajoo needed more flexibility and performance</h3></div><div class="left-section-footer"><h4>“Hasura saved us so much time when building our backend”</h4><p>Jérémy Gotteland</p><p class="pipe-info-text">Co-founder and CTO, Cajoo</p></div></div><div class="right-section"><p class="head-info"><span>Cajoo&#x27;s development team needed to move fast as an early-stage startup.<br /><br />Their initial technical architecture included a React Native mobile app connected to Shopify as their ecommerce backend (their order management system), a third-party warehouse management system, a third-party courier delivery application, and a Nest JS API hosted in Heroku to connect all these systems and handle user authentication.<br /><br />As their customer base grew, they started to observe performance and flexibility bottlenecks affecting user experience and decided to redesign their tech stack to cater to their custom scenarios and meet business demands. The challenges Cajoo faced with the initial tech stack included:</span></p><div class="content-data-row"><h4 class="info-headline">Slow data fetching</h4><p class="info-desc">Cajoo needed to manage different stock quantities per warehouse, which Shopify struggled with. To work around it, they included the warehouse stock information in the product meta field and left the client to handle the filtering. But as the number of warehouses and products increased, fetching product data became cumbersome and slow, leading to slower app response time and a poor user experience.</p></div><div class="content-data-row"><h4 class="info-headline">Small development team</h4><p class="info-desc">Cajoo&#x27;s team needed to stay lean and iterate quickly on new features. The engineers needed to be flexible enough to work on and understand all layers of their system — database, backend, integrations, and the frontend web UI.</p></div><div class="content-data-row"><h4 class="info-headline">Limited architecture flexibility</h4><p class="info-desc">The Cajoo team needed features which the Shopify API did not natively offer. In addition, they wanted to avoid the rate-limiting on Shopify APIs, which caused their application to struggle, especially during peak periods.</p></div><div class="content-data-row"><h4 class="info-headline">Technical debt</h4><p class="info-desc">The Cajoo team wanted to move away from overreliance on third-party proprietary software. Building in-house order management and warehouse inventory software meant they had complete control of the technology supply chain.</p></div></div></div><div class="StyledImageHighlightCard-sc-2pn2vu-0 gALspu"><div class="highlight-img-div"></div><p>Cajoo’s initial tech architecture</p></div><div class="StyledHighlightCard-sc-z4ly8x-0 cUYJDJ"><h2>“Hasura reduced our client data fetching time from 10 seconds to less than 1 second, which greatly improved the user experience.”</h2><p>Jérémy Gotteland</p><p>Co-founder and CTO, Cajoo</p></div><div id="solution"><div class="case-study-content-div mb-50" id="why-pipe-chose-hasura"><div class="left-section"><div class="left-head-section"><p>The Solution</p><h3>Hasura Cloud provides more control and flexibility</h3></div></div><div class="right-section"><p class="head-info">As Cajoo started investigating solutions to the challenges above, they discovered Hasura while browsing Hacker News and decided to try it out. They migrated their entire ecommerce backend from Shopify to their proprietary in-house software in four weeks with just three engineers.<br /><br />The Cajoo team settled on Hasura because it provided features such as instant GraphQL APIs on their databases, subscriptions, aggregates, and event triggers that aligned with the direction of their future tech stack.</p></div></div><div class="StyledImageHighlightCard-sc-2pn2vu-0 dgSXWa"><div class="highlight-img-div"></div><p>Cajoo’s new tech architecture</p></div><div class="case-study-content-div"><div class="left-section"><div class="left-head-section"></div></div><div class="right-section"><div class="content-data-row"><h4 class="info-headline">Ease of use</h4><p class="info-desc">Hasura&#x27;s intuitive user interface and documentation made it easy to set up and connect their Postgres database, making their data instantly accessible over GraphQL APIs. Hasura also took care of their API data layer, allowing them to focus on architecture and custom business logic while saving them development and maintenance time.</p></div><div class="content-data-row"><h4 class="info-headline">Flexible</h4><p class="info-desc">Hasura offered the flexibility and control Cajoo was seeking, as it is open-source and can be run locally or in the cloud. It can also connect to a private database instance so Cajoo can essentially control its data and avoid third-party vendor lock-ins.</p></div><div class="content-data-row"><h4 class="info-headline">Security and authorization</h4><p class="info-desc">Hasura provided built-in security and authorization capabilities, which allowed for a role and user-based authorization down to the individual column and row level. Having this feature out-of-the-box saved Cajoo development time and ensured security was baked right into every application&#x27;s data layer.</p></div><div class="content-data-row"><h4 class="info-headline">Subscription and aggregates</h4><p class="info-desc">Hasura provided out-of-the-box support for subscriptions and aggregates. Cajoo could implement real-time delivery tracking with subscriptions, so the client&#x27;s screen gets updated anytime there&#x27;s a change to the order status. Having aggregates automatically generated with the GraphQL API meant the backend could easily carry out queries such as order counting and filtering with a single line of text.</p></div><div class="content-data-row"><h4 class="info-headline">Event triggers</h4><p class="info-desc">Cajoo&#x27;s infrastructure relied heavily on events such as notifying the client via email when an order was placed and notifying warehouses via Slack to let them know the new order was to be fulfilled. Hasura offered a reliable and easy way to create event triggers on specified tables and invoke webhooks (like listening to Stripes API for payment success) to carry out business logic.<br /><br />Cajoo also utilized Hasura Event Triggers and webhooks to provide real-time integrations to the multiple AWS Lambda functions they&#x27;re using.</p></div></div></div></div><div class="case-study-content-div" id="results"><div class="left-section"><div class="left-head-section"><p>The Results</p><h3>Cajoo cut infrastructure costs by 95% and improved product load time</h3></div></div><div class="right-section"><p class="head-info"><span>Utilizing Hasura for their ecommerce backend worked so well they then replaced other pieces of their stack using the same architecture: their warehouse management system and the courier delivery application.<br /><br />Some of the other benefits they attributed to using Hasura include:</span></p><div class="content-data-row"><h4 class="info-headline">Improved application performance</h4><p class="info-desc">Cajoo saw improved performance on their client&#x27;s applications after implementing Hasura. The client&#x27;s data fetching time improved from 10 seconds to load all products in a category to less than 1 second, which greatly improved customer experience and kept customers from bouncing off a page that took too long to load.</p></div><div class="content-data-row"><h4 class="info-headline">Faster development time</h4><p class="info-desc">Hasura&#x27;s simplified GraphQL data fetching architecture made it easy to add new features in less time. Cajoo was able to migrate their ecommerce backend from Shopify in less than four weeks and roll out their custom delivery tracking application in less than a month because of the speed at which Hasura helped them operate.</p></div><div class="content-data-row"><h4 class="info-headline">Cost savings</h4><p class="info-desc">Cajoo experienced significant cost savings with Hasura. Monthly infrastructure costs went from over $2,000 to just $100 with Hasura (about a 95% reduction in cost).</p></div><div class="content-data-row"><h4 class="info-headline">Cleaner architecture</h4><p class="info-desc">Hasura enabled Cajoo to move to a cleaner and more reliable application architecture. They could migrate to a serverless architecture using AWS Lambda with a one-on-one relationship to Hasura event triggers, helping them encapsulate their business logic and keep it separate from the delivery mechanism. Moving to Hasura gave Cajoo more flexibility with its technical architecture, allowing them to quickly adapt to changing technology and interfaces.</p></div><div class="content-data-row"><h4 class="info-headline">Less reliance on third-party proprietary software</h4><p class="info-desc">Hasura enabled Cajoo to quickly replace their third-party warehousing and Courier delivery software with in-house custom software, which gave them more control of their tech stack.</p></div></div></div><div class="case-study-content-div"><div class="left-section"><div class="left-head-section"><p>Closing Note</p><h3>What’s Next for Cajoo</h3></div></div><div class="right-section pipe-closing-notes-text"><p class="pipe-closing-notes-text"><span>Cajoo has experienced tremendous growth in both users and employees in the past year and still has ongoing expansion plans. The development team started with just three developers and has grown to 15-20 developers.<br /><br />The Cajoo team continues to work closely with Hasura to improve developer tooling and boost developer productivity even as they continue to innovate and improve their product offerings.</span></p></div></div><div class="StyledOtherStudies-sc-1vei6qz-0 bRUjfN"><p>Other Stories</p><h3>Learn more from of our<br /> users’ experience</h3><div class="other-stories-div"><a href="/case-studies/pipe"><div class="story-link-card"><div class="img-div"><img src="data:image/svg+xml;base64,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" alt="Pipe" id="Pipe-logo" /></div><div><h2>Pipe</h2><p>How Pipe went from prototype to production in 11 days with Hasura</p></div></div></a><a href="/case-studies/athlane"><div class="story-link-card"><div class="img-div"><img src="data:image/svg+xml;base64,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" alt="Athlane" id="Athlane-logo" /></div><div><h2>Athlane</h2><p>How Athlane uses Hasura Cloud to increase their Developer Velocity 200%</p></div></div></a><a href="/case-studies/optum"><div class="story-link-card"><div class="img-div"><img src="data:image/svg+xml;base64,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" alt="Optum" id="Optum-logo" /></div><div><h2>Optum</h2><p>Healthcare giant Optum goes from concept to production in 100 days with Hasura</p></div></div></a></div></div></div></div></div><section id="footer-newsletter" class="StyledSectionWrapper-sc-eunbva-0 footer___StyledStyledSectionWrapper-sc-1y9m3o4-1 isYyaZ cowna-D"><section class="StyledContainerWrapper-sc-731dqe-0 footer___StyledStyledContainerWrapper-sc-1y9m3o4-2 dCClbK"><div class="footer___StyledDiv-sc-1y9m3o4-3"><div class="footer__StyledNewsletterWrapper-sc-1y9m3o4-0 lfDzLy"><div class="p100"><div class="subscribeNewsletterWrapper removePaddBottom " id="subscribe-updates"><div class="hasura-ibm-plex-sub-title subscribeFooter">Monthly product updates in your inbox. No spam.</div> <div class="subscribeFlexOne"><form class="marketoFormWrapper subscribeNewsletterForm" id="mktoForm_1011"></form></div></div></div><div class="newsLetterImg"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="News letter" /></div></div></div></section></section><footer class="wd100"><div class="footer___StyledDiv2-sc-1y9m3o4-4 containerWrapper"><div class="footer___StyledDiv3-sc-1y9m3o4-5"><div class="footerImg"><img loading="lazy" src="/static/footer-img-79b3cfc0ceb3c7e466198ae09e1d4e6e.png" alt="footer illustration" /></div><div class="footerWrappper wd100"><div class="footerLinks hasura-ibm-plex-nav-btn"><div class="footerLinksHeader">Hasura</div><a class="links" href="/about/">About Us</a><a class="links" href="/press/">Press</a><a href="/careers/" class="links">Careers</a><a class="links" href="/contact-us/">Contact Us</a><a class="links" href="/legal/">Legal Stuff</a></div><div class="footerLinks hasura-ibm-plex-nav-btn"><div class="footerLinksHeader">Support</div><a href="https://hasura.io/docs/latest/graphql/core/index.html" class="links" target="_blank" rel="noopener noreferrer">Documentation</a><a href="https://discord.com/invite/hasura" class="links" target="_blank" rel="noopener noreferrer">Community Forum</a><a href="https://hasura.io/help/" class="links">Website chat</a><a href="https://github.com/hasura" class="links" target="_blank" rel="noopener noreferrer">Github</a><a href="https://status.hasura.io/" class="links" target="_blank" rel="noopener noreferrer">Hasura Cloud Status</a><a href="https://hasura.io/cloud-survey/?id=1101" class="links hide" target="_blank" rel="noopener noreferrer">Hasura Cloud Survey</a></div><div class="footerLinks hasura-ibm-plex-nav-btn"><div class="footerLinksHeader">Tools</div><a href="https://github.com/hasura/graphqurl" class="links" target="_blank" rel="noopener noreferrer">Graphqurl</a><a href="https://github.com/hasura/firebase2graphql" class="links" target="_blank" rel="noopener noreferrer">Firebase2GraphQL</a><a href="https://github.com/hasura/json2graphql" class="links" target="_blank" rel="noopener noreferrer">JSON2GraphQL</a><a href="https://github.com/hasura/graphql2chartjs" class="links" target="_blank" rel="noopener noreferrer">GraphQL2ChartJS</a></div><div class="footerLinks hasura-ibm-plex-nav-btn"><div class="footerLinksHeader">Product</div><a class="links" href="/opensource/">Hasura Open Source</a><a class="links" href="/cloud/">Hasura Cloud</a><a class="links" href="/enterprise/">Hasura Enterprise</a><a class="links" href="/pricing/">Pricing</a><a href="https://github.com/hasura/graphql-engine/releases" class="links" target="_blank" rel="noopener noreferrer">Changelog</a></div><div class="footerLinks hasura-ibm-plex-nav-btn"><div class="footerLinksHeader">Resources</div><a href="https://hasura.io/blog/" class="links" target="_blank" rel="noopener noreferrer">Blog</a><a class="links" href="/case-studies/">Case Studies</a><a href="https://3factor.app/" class="links" target="_blank" rel="noopener noreferrer">3Factor Apps</a><a class="links" href="/event-driven-programming/">Event Driven Programming</a><a class="links" href="/react-graphql/">React GraphQL</a><a class="links" href="/vue-graphql/">Vue GraphQL</a><a class="links" href="/diy-graphql-baas/">DIY GraphQL BaaS</a><a class="links" href="/graphql/">GraphQL &amp; Hasura</a><a class="links" href="/security/">Hasura Cloud Security</a></div><div class="footerLinks hasura-ibm-plex-nav-btn"><div class="footerLinksHeader">Community</div><a class="links" href="/community/">Community Resources</a><a href="https://hasura.io/learn/" class="links" target="_blank" rel="noopener noreferrer">GraphQL Tutorials</a><a href="https://github.com/hasura/graphql-engine/wiki" class="links" target="_blank" rel="noopener noreferrer">Community Wiki</a><a class="links" href="/sample-apps/">Sample Apps</a><a class="links" href="/partner-agencies/">Partnership Program</a><a class="links" href="/events/hasura-con-2021/">HasuraCon 2021</a><a href="https://graphql.asia/" class="links" target="_blank" rel="noopener noreferrer">GraphQL Asia</a></div></div><div class="footerImgMobile"><img src="/static/footer-img-79b3cfc0ceb3c7e466198ae09e1d4e6e.png" alt="footer illustration" /></div></div></div><div class="copyWriteWrapperBg wd100"><div class="CopyWriter___StyledDiv-sc-4k2j2k-0 containerWrapper"><div class="CopyWriter___StyledDiv2-sc-4k2j2k-1"><div class="copyWriteWrapper"><div class="brand"><img src="data:image/svg+xml;base64,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" alt="Brand logo" /></div><div class="hasura-ibm-plex-mono">© <!-- -->2022<!-- --> Hasura Inc. All rights reserved</div><div class="footerSocialIconsWrapper"><div class="socialBrands"><a href="https://github.com/hasura/graphql-engine" rel="noopener noreferrer" aria-label="Github"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Github" /></a></div><div class="socialBrands"><a href="https://twitter.com/hasurahq" rel="noopener noreferrer" aria-label="Titter"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Titter" /></a></div><div class="socialBrands"><a href="https://discord.com/invite/hasura" rel="noopener noreferrer" aria-label="Discord"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Discord" /></a></div><div class="socialBrands"><a href="https://www.facebook.com/HasuraHQ" rel="noopener noreferrer" aria-label="Facebook"><img loading="lazy" src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTEyIDBDNS4zOTk5OSAwIDAgNS4zODc5OSAwIDEyLjAyNEMwIDE4LjAyNCA0LjM5MTk5IDIzLjAwNCAxMC4xMjggMjMuOTA0VjE1LjUwNEg3LjA3OTk5VjEyLjAyNEgxMC4xMjhWOS4zNzE5OUMxMC4xMjggNi4zNTk5OSAxMS45MTYgNC43MDM5OSAxNC42NjQgNC43MDM5OUMxNS45NzIgNC43MDM5OSAxNy4zNCA0LjkzMTk5IDE3LjM0IDQuOTMxOTlWNy44OTU5OUgxNS44MjhDMTQuMzQgNy44OTU5OSAxMy44NzIgOC44MTk5OSAxMy44NzIgOS43Njc5OVYxMi4wMjRIMTcuMjA4TDE2LjY2OCAxNS41MDRIMTMuODcyVjIzLjkwNEMxNi42OTk3IDIzLjQ1NzQgMTkuMjc0NiAyMi4wMTQ2IDIxLjEzMTkgMTkuODM2QzIyLjk4OTIgMTcuNjU3NSAyNC4wMDY0IDE0Ljg4NjggMjQgMTIuMDI0QzI0IDUuMzg3OTkgMTguNiAwIDEyIDBaIiBmaWxsPSIjNzE3NzgwIi8+Cjwvc3ZnPgo=" alt="Facebook" /></a></div><div class="socialBrands"><a href="https://www.instagram.com/hasurahq/?hl=en" rel="noopener noreferrer" aria-label="Instagram"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Instagram" /></a></div><div class="socialBrands"><a href="https://www.youtube.com/channel/UCZo1ciR8pZvdD3Wxp9aSNhQ" rel="noopener noreferrer" aria-label="Youtube"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Youtube" /></a></div><div class="socialBrands"><a href="https://www.linkedin.com/company/hasura" rel="noopener noreferrer" aria-label="Linkedin"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Linkedin" /></a></div></div></div></div></div></div></footer></div></div></div><div id="gatsby-announcer" style="position:absolute;top:0;width:1px;height:1px;padding:0;overflow:hidden;clip:rect(0, 0, 0, 0);white-space:nowrap;border:0" aria-live="assertive" aria-atomic="true"></div></div><script id="gatsby-script-loader">/*<![CDATA[*/window.pagePath="/case-studies/cajoo/";/*]]>*/</script><script id="gatsby-chunk-mapping">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</script><script src="/polyfill-42ae2a5525cb516808d9.js" nomodule=""></script><script src="/component---src-pages-case-studies-cajoo-js-923678cea8d38794b17d.js" async=""></script><script src="/0a1310c1dc5d572ceda91879a2dae8fa34cce823-5ac53bad26703e4f886b.js" async=""></script><script src="/3f56c6fd23336a4ca18a1dccbc974164d737940f-dc0d1e1d44a0b52eb42e.js" async=""></script><script src="/a1faa3cb5d3d2ce3b26593328f575172e162a29d-3cd470fb01629a9db6eb.js" async=""></script><script src="/227120c845cf2a80deb37a7a0aabac3b20d08350-6ee45d707eae4c160c26.js" async=""></script><script src="/commons-ac12621159ac0636a9f4.js" async=""></script><script src="/app-c734dcb178fc22c51047.js" async=""></script><script src="/framework-3bbebef96bf42a53ca88.js" async=""></script><script src="/webpack-runtime-e1a814076c1d3ae7fbb1.js" async=""></script></body></html>