<!DOCTYPE html><html lang="en"><head><meta charSet="utf-8" /><meta http-equiv="x-ua-compatible" content="ie=edge" /><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no" /><style data-href="/component---src-components-case-study-index-js.ebe29a1ca6ae30d9cc46.css" data-identity="gatsby-global-css">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</style><style data-href="/styles.2f7ca1ae5e5af181a708.css" data-identity="gatsby-global-css">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</style><meta name="generator" content="Gatsby 3.14.6" /><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src= 'https://www.googletagmanager.com/gtm.js?id='+i+dl+'';f.parentNode.insertBefore(j,f); })(window,document,'script','dataLayer', 'GTM-KPWB7RN');</script><script>
      
      !function(){var analytics=window.analytics=window.analytics||[];if(!analytics.initialize)if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["trackSubmit","trackClick","trackLink","trackForm","pageview","identify","reset","group","track","ready","alias","debug","page","once","off","on","addSourceMiddleware","addIntegrationMiddleware","setAnonymousId","addDestinationMiddleware"];analytics.factory=function(e){return function(){var t=Array.prototype.slice.call(arguments);t.unshift(e);analytics.push(t);return analytics}};for(var e=0;e<analytics.methods.length;e++){var key=analytics.methods[e];analytics[key]=analytics.factory(key)}analytics.load=function(key,e){var t=document.createElement("script");t.type="text/javascript";t.async=!0;t.src="https://cdn.segment.io/analytics.js/v1/" + key + "/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(t,n);analytics._loadOptions=e};analytics._writeKey="RQXoHRpNcmBKllUDihjDjupGv4AHn5TB";analytics.SNIPPET_VERSION="4.13.2";
analytics.load('RQXoHRpNcmBKllUDihjDjupGv4AHn5TB');analytics.page();
}}();
    </script><style data-styled="" data-styled-version="5.3.3">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</style><title data-react-helmet="true">Case Study: How Matternet Is Powering Autonomous Drone Delivery with Hasura</title><link data-react-helmet="true" rel="canonical" href="" /><meta data-react-helmet="true" name="title" content="Case Study: How Matternet Is Powering Autonomous Drone Delivery with Hasura" /><meta data-react-helmet="true" name="description" content="" /><meta data-react-helmet="true" property="og:title" content="Case Study: How Matternet Is Powering Autonomous Drone Delivery with Hasura" /><meta data-react-helmet="true" property="og:description" content="" /><meta data-react-helmet="true" property="og:image" content="https://graphql-engine-cdn.hasura.io/assets/main-site/hasura_matternet.png" /><meta data-react-helmet="true" property="og:type" content="website" /><meta data-react-helmet="true" name="twitter:card" content="summary_large_image" /><meta data-react-helmet="true" name="twitter:title" content="Case Study: How Matternet Is Powering Autonomous Drone Delivery with Hasura" /><meta data-react-helmet="true" name="twitter:description" content="" /><link rel="sitemap" type="application/xml" href="/sitemap.xml" /><link rel="icon" href="/favicon-32x32.png?v=6e6e57b4b98fec791dd9f3d077b80810" type="image/png" /><link rel="manifest" href="/manifest.webmanifest" crossorigin="anonymous" /><link rel="apple-touch-icon" sizes="48x48" href="/icons/icon-48x48.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="72x72" href="/icons/icon-72x72.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="96x96" href="/icons/icon-96x96.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="144x144" href="/icons/icon-144x144.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="192x192" href="/icons/icon-192x192.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="256x256" href="/icons/icon-256x256.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="384x384" href="/icons/icon-384x384.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="512x512" href="/icons/icon-512x512.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link crossorigin="" href="https://www.google.com" rel="preconnect" /><link crossorigin="" href="https://stats.g.doubleclick.net" rel="preconnect" /><link crossorigin="" href="https://page.hasura.io" rel="preconnect" /><link crossorigin="" href="https://connect.facebook.net" rel="preconnect" /><link rel="icon" href="/favicon-32x32.png?v=6e6e57b4b98fec791dd9f3d077b80810" type="image/png" /><link rel="manifest" href="/manifest.webmanifest" crossorigin="anonymous" /><meta name="theme-color" content="#663399" /><link rel="apple-touch-icon" sizes="48x48" href="/icons/icon-48x48.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="72x72" href="/icons/icon-72x72.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="96x96" href="/icons/icon-96x96.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="144x144" href="/icons/icon-144x144.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="192x192" href="/icons/icon-192x192.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="256x256" href="/icons/icon-256x256.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="384x384" href="/icons/icon-384x384.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="512x512" href="/icons/icon-512x512.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link as="script" rel="preload" href="/webpack-runtime-74276ac09f033b02da78.js" /><link as="script" rel="preload" href="/framework-070807bfa7d45403643d.js" /><link as="script" rel="preload" href="/app-3822a25cf818e250c86a.js" /><link as="script" rel="preload" href="/commons-ac12621159ac0636a9f4.js" /><link as="script" rel="preload" href="/ec586dc9bbfb2cc5dbd82cf470c94db08db1831f-8fe6832ed0799dc4678f.js" /><link as="script" rel="preload" href="/5f8f9cddecb59249a2614f362a25bd62ac1a5c08-8a040e544c4008463e2c.js" /><link as="script" rel="preload" href="/a8a840e6d82aa2727d67a80324db0839b3898d94-fee7af6d35c3fb048e5c.js" /><link as="script" rel="preload" href="/1722f91412bcb57bb36aedaad1ae33696fba0c0e-96638146d307305ab490.js" /><link as="script" rel="preload" href="/2711bc595453a3e566c609c18cf31d16e0f5d9d7-f88f66ba3e4cb288ec25.js" /><link as="script" rel="preload" href="/component---src-components-case-study-index-js-429f36f59fed2aa9c23e.js" /><link as="fetch" rel="preload" href="/page-data/case-studies/matternet/page-data.json" crossorigin="anonymous" /><link as="fetch" rel="preload" href="/page-data/sq/d/3000892485.json" crossorigin="anonymous" /><link as="fetch" rel="preload" href="/page-data/app-data.json" crossorigin="anonymous" /><link rel="preload" as="font" href="/fonts/IBM-Plex-Sans-600.woff2" type="font/woff2" crossorigin="anonymous" /><link rel="preload" as="font" href="/fonts/IBM-Plex-Sans-700.woff2" type="font/woff2" crossorigin="anonymous" /><link rel="preload" as="font" href="/fonts/IBM-Plex-Mono-300.woff2" type="font/woff2" crossorigin="anonymous" /><link rel="preload" as="font" href="/fonts/IBM-Plex-Mono-200.woff2" type="font/woff2" crossorigin="anonymous" /><link rel="preload" href="https://page.hasura.io/js/forms2/css/forms2.css" as="style" /><link rel="preload" href="https://page.hasura.io/js/forms2/css/forms2-theme-simple.css" as="style" /><script type="application/ld+json">{
              "@context": "http://schema.org/",
              "@type": "Organization",
              "name": "Hasura",
              "logo": "https://hasura.io/logo.svg",
              "url": "https://hasura.io",
              "foundingDate": "2015",
              "address": {
                "@type": "PostalAddress",
                "addressLocality": "Bangalore",
                "addressRegion": "Karnataka",
                "postalCode": "560034",
                "streetAddress": "2nd Floor, Building, No 37/38, 80 Feet Rd, 3rd Block, Koramangala 1A Block, SBI Colony, Koramangala"
              },
              "founders": [{"@type": "Person","name": "Tanmai Gopal"},{"@type": "Person","name": "Rajoshi Ghosh"}],
              "contactPoint": {
                 "@type": "ContactPoint",
                 "contactType": "Sales",
                 "email": "build@hasura.io",
                 "url": "https://hasura.io"
              },
              "sameAs": [
                "https://en.wikipedia.org/wiki/Hasura",
                "https://www.wikidata.org/wiki/Q56676515",
                "https://www.facebook.com/HasuraHQ",
                "https://www.twitter.com/hasurahq",
                "https://www.linkedin.com/company/hasura",
                "https://www.instagram.com/hasurahq",
                "https://www.youtube.com/hasurahq"
              ]
          }</script><script type="application/ld+json">{
              "@context": "http://schema.org",
              "@type": "WebSite",
              "name": "Hasura",
              "url": "https://hasura.io"
          }</script></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KPWB7RN" height="0" width="0" style="display: none; visibility: hidden" aria-hidden="true"></iframe></noscript><div id="___gatsby"><div style="outline:none" tabindex="-1" id="gatsby-focus-wrapper"><div id="layoutContentWrapper" class="viewport"><div class="StyledBanner-sc-1nwrdmh-0 ifxbgS"><div class="commonBannerStripWrapper"><a href="https://hasura.io/blog/seriesc-100m-graphql-for-everyone/" class="text-contnet mobileBannerHide"><span class="emoji" role="img" aria-label="emoji">👋</span>Announcing our $100M Series C funding<div class="arrow"> &gt;</div></a><a href="https://hasura.io/blog/seriesc-100m-graphql-for-everyone/" class="text-contnet hasura-font-bold mobileBannerShow"><div class="mWd">Announcing our $100M Series C funding<div class="arrow"> &gt;</div></div></a><svg xmlns="http://www.w3.org/2000/svg" width="16px" height="16px" viewBox="0 0 18 18" fill="none" class="StyledIcon__StyledSVG-sc-7ki3wc-0 eMyBuU close_icon"><path d="M3 15L15 3" stroke="hsla(0, 0%, 100%, 1)" stroke-width="1.5" stroke-linecap="round" stroke-linejoin="round"></path><path d="M15 15L3.00001 3" stroke="hsla(0, 0%, 100%, 1)" stroke-width="1.5" stroke-linecap="round" stroke-linejoin="round"></path></svg></div></div><div class="wd100"><header id="header" class="lightModeHeader stickyOnMobile"><div class="containerWrapper"><div class="headerWrapper"><div id="navBrand" class="navLeft"><div class="brand"><a href="/"><img src="data:image/svg+xml;base64,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" alt="Hasura Logo" title="Hasura Logo" /></a></div></div><div class="navCenter hideMobile"><ul class="navBarUL"><li class="github-btn-header"><span><a href="https://github.com/hasura/graphql-engine" data-size="large" data-show-count="true" aria-label="Star @hasura on GitHub">Star</a></span></li><li class="dropDownList" id="product-nav-dropdown"><a role="button" tabindex="0" class="dropdown-link-btn">Product</a><div id="product-nav" class="zIndex dropDownContent"><div class="navDrapdownWrapper"><div class="dropdown-column-section product-section"><a href="/products/"><div class="product-content-wrapper"><h4>PRODUCT</h4><img src="data:image/png;base64,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" alt="Product" id="product-illus" /><h2>Hasura Product Offerings</h2><p>Choose from our Open Source Community Edition, fully-managed Hasura Cloud or on-prem Hasura Enterprise Edition.</p><div class="nav-link">Go To Products<img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMTgiIGhlaWdodD0iMTkiIHZpZXdCb3g9IjAgMCAxOCAxOSIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPGcgY2xpcC1wYXRoPSJ1cmwoI2NsaXAwKSI+CjxwYXRoIGQ9Ik02Ljk2OTM4IDUuNzgzMTZDNi42NzY4NyA2LjA3NTY2IDYuNjc2ODcgNi41NDgxNiA2Ljk2OTM4IDYuODQwNjZMOS44NzkzOCA5Ljc1MDY3TDYuOTY5MzggMTIuNjYwN0M2LjY3Njg3IDEyLjk1MzIgNi42NzY4NyAxMy40MjU3IDYuOTY5MzggMTMuNzE4MkM3LjI2MTg4IDE0LjAxMDcgNy43MzQzOCAxNC4wMTA3IDguMDI2ODggMTMuNzE4MkwxMS40Njk0IDEwLjI3NTdDMTEuNzYxOSA5Ljk4MzE3IDExLjc2MTkgOS41MTA2NiAxMS40Njk0IDkuMjE4MTZMOC4wMjY4OCA1Ljc3NTY2QzcuNzQxODggNS40OTA2NiA3LjI2MTg4IDUuNDkwNjYgNi45NjkzOCA1Ljc4MzE2WiIgZmlsbD0iIzAwNzlCRCIvPgo8L2c+CjxkZWZzPgo8Y2xpcFBhdGggaWQ9ImNsaXAwIj4KPHJlY3Qgd2lkdGg9IjE4IiBoZWlnaHQ9IjE4IiBmaWxsPSJ3aGl0ZSIgdHJhbnNmb3JtPSJ0cmFuc2xhdGUoMCAwLjc0OTk4NSkiLz4KPC9jbGlwUGF0aD4KPC9kZWZzPgo8L3N2Zz4K" alt="Arrow" class="arrow-img" /></div></div></a></div><div class="center-content-section dropdown-column-section"><h4>GRAPHQL IN PRODUCTION</h4><a href="/graphql/caching/"><div class="dropdown-hover-effect-div"><h2>Caching</h2><p>Get faster response times</p></div></a><a href="/graphql/security/"><div class="dropdown-hover-effect-div"><h2>Security</h2><p>Declaratively protect your APIs</p></div></a><a href="/graphql/monitoring/"><div class="dropdown-hover-effect-div"><h2>Monitoring and Observability</h2><p>Get insights on your API performance</p></div></a><a href="/graphql/production-ready-existing-apis/"><div class="dropdown-hover-effect-div"><h2>Existing GraphQL APIs</h2><p>Add your GraphQL servers to Hasura </p></div></a></div><div class="navDrapdownListWrapper"><div class="content-div dropdown-column-section"><h4>SUPPORTED DATABASES</h4><a href="/graphql/database/postgresql/"><div class="dropdown-db-link dropdown-hover-effect-div"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iNDgiIGhlaWdodD0iNDgiIHZpZXdCb3g9IjAgMCA0OCA0OCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTcuMjUgOEM3LjI1IDYuNDgxMjIgOC40ODEyMiA1LjI1IDEwIDUuMjVIMzhDMzkuNTE4OCA1LjI1IDQwLjc1IDYuNDgxMjIgNDAuNzUgOFY0MEM0MC43NSA0MS41MTg4IDM5LjUxODggNDIuNzUgMzggNDIuNzVIMTBDOC40ODEyMiA0Mi43NSA3LjI1IDQxLjUxODggNy4yNSA0MFY4WiIgc3Ryb2tlPSIjMTY5OUUyIiBzdHJva2Utd2lkdGg9IjIuNSIgc3Ryb2tlLWxpbmVjYXA9InJvdW5kIiBzdHJva2UtbGluZWpvaW49InJvdW5kIi8+CjxwYXRoIGQ9Ik04IDE3LjVINDAiIHN0cm9rZT0iIzE2OTlFMiIgc3Ryb2tlLXdpZHRoPSIyLjUiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8cGF0aCBkPSJNOCAzMUg0MCIgc3Ryb2tlPSIjMTY5OUUyIiBzdHJva2Utd2lkdGg9IjIuNSIgc3Ryb2tlLWxpbmVjYXA9InJvdW5kIiBzdHJva2UtbGluZWpvaW49InJvdW5kIi8+Cjwvc3ZnPgo=" alt="hasura-database" class="db_icon" /><h2>Postgres</h2></div></a><a href="/graphql/database/sql-server/"><div class="dropdown-db-link dropdown-hover-effect-div"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iNDgiIGhlaWdodD0iNDgiIHZpZXdCb3g9IjAgMCA0OCA0OCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTcuMjUgOEM3LjI1IDYuNDgxMjIgOC40ODEyMiA1LjI1IDEwIDUuMjVIMzhDMzkuNTE4OCA1LjI1IDQwLjc1IDYuNDgxMjIgNDAuNzUgOFY0MEM0MC43NSA0MS41MTg4IDM5LjUxODggNDIuNzUgMzggNDIuNzVIMTBDOC40ODEyMiA0Mi43NSA3LjI1IDQxLjUxODggNy4yNSA0MFY4WiIgc3Ryb2tlPSIjMTY5OUUyIiBzdHJva2Utd2lkdGg9IjIuNSIgc3Ryb2tlLWxpbmVjYXA9InJvdW5kIiBzdHJva2UtbGluZWpvaW49InJvdW5kIi8+CjxwYXRoIGQ9Ik04IDE3LjVINDAiIHN0cm9rZT0iIzE2OTlFMiIgc3Ryb2tlLXdpZHRoPSIyLjUiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8cGF0aCBkPSJNOCAzMUg0MCIgc3Ryb2tlPSIjMTY5OUUyIiBzdHJva2Utd2lkdGg9IjIuNSIgc3Ryb2tlLWxpbmVjYXA9InJvdW5kIiBzdHJva2UtbGluZWpvaW49InJvdW5kIi8+Cjwvc3ZnPgo=" alt="hasura-database" class="db_icon" /><h2>SQL Server</h2></div></a><a href="https://hasura.io/docs/latest/graphql/core/databases/bigquery/getting-started.html"><div class="dropdown-db-link dropdown-hover-effect-div"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iNDgiIGhlaWdodD0iNDgiIHZpZXdCb3g9IjAgMCA0OCA0OCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTcuMjUgOEM3LjI1IDYuNDgxMjIgOC40ODEyMiA1LjI1IDEwIDUuMjVIMzhDMzkuNTE4OCA1LjI1IDQwLjc1IDYuNDgxMjIgNDAuNzUgOFY0MEM0MC43NSA0MS41MTg4IDM5LjUxODggNDIuNzUgMzggNDIuNzVIMTBDOC40ODEyMiA0Mi43NSA3LjI1IDQxLjUxODggNy4yNSA0MFY4WiIgc3Ryb2tlPSIjMTY5OUUyIiBzdHJva2Utd2lkdGg9IjIuNSIgc3Ryb2tlLWxpbmVjYXA9InJvdW5kIiBzdHJva2UtbGluZWpvaW49InJvdW5kIi8+CjxwYXRoIGQ9Ik04IDE3LjVINDAiIHN0cm9rZT0iIzE2OTlFMiIgc3Ryb2tlLXdpZHRoPSIyLjUiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8cGF0aCBkPSJNOCAzMUg0MCIgc3Ryb2tlPSIjMTY5OUUyIiBzdHJva2Utd2lkdGg9IjIuNSIgc3Ryb2tlLWxpbmVjYXA9InJvdW5kIiBzdHJva2UtbGluZWpvaW49InJvdW5kIi8+Cjwvc3ZnPgo=" alt="hasura-database" class="db_icon" /><h2>Big Query</h2></div></a><div class="coming-soon-div"><h4>COMING SOON</h4><div class="db-flex"><a href="/graphql/database/oracle/"><h2>Oracle</h2></a><a href="/graphql/database/mongodb/"><h2>MongoDb</h2></a><a href="/graphql/database/mysql/"><h2>MySQL</h2></a><a href="/graphql/database/elasticsearch/"><h2>Elastic</h2></a></div></div></div></div></div></div></li><li class="dropDownList"><a role="button" tabindex="0" class="dropdown-link-btn">Resources</a><div id="resource-nav" class="zIndex dropDownContent"><div class="navDrapdownWrapper resources-dropdown"><div class="dropdown-column-section developers-section"><h4>LEARNING RESOURCES</h4><a href="/learn/"><div class="navList dropdown-hover-effect-div"><div class="navListImg"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTIzIDEwVjE3TTIzIDEwTDEyIDRMMSAxMEw0LjUgMTJNMjMgMTBMMTIgMTZMNC41IDEyTTQuNSAxMlYxNy41TDEyIDIxLjVMMTkuNSAxNy41VjEyIiBzdHJva2U9IiMwMDc5QkQiIHN0cm9rZS13aWR0aD0iMS41IiBzdHJva2UtbGluZWNhcD0icm91bmQiIHN0cm9rZS1saW5lam9pbj0icm91bmQiLz4KPC9zdmc+Cg==" alt="icon" /></div><h2>Learn</h2></div></a><a href="https://hasura.io/blog/"><div class="navList dropdown-hover-effect-div"><div class="navListImg"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHJlY3QgeD0iNCIgeT0iMiIgd2lkdGg9IjE2IiBoZWlnaHQ9IjIwIiByeD0iMS43Nzc3OCIgc3Ryb2tlPSIjMDA3OUJEIiBzdHJva2Utd2lkdGg9IjEuNSIgc3Ryb2tlLWxpbmVjYXA9InJvdW5kIiBzdHJva2UtbGluZWpvaW49InJvdW5kIi8+CjxwYXRoIGQ9Ik0xMSAxMFYySDE3VjEwTDE0IDhMMTEgMTBaIiBzdHJva2U9IiMwMDc5QkQiIHN0cm9rZS13aWR0aD0iMS41IiBzdHJva2UtbGluZWNhcD0icm91bmQiIHN0cm9rZS1saW5lam9pbj0icm91bmQiLz4KPC9zdmc+Cg==" alt="icon" /></div><h2>Blog</h2></div></a><a href="/community/"><div class="navList dropdown-hover-effect-div"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><h2>Community</h2></div></a><a href="/events/"><div class="navList dropdown-hover-effect-div"><div class="navListImg"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTcuNSA0LjIwNjA1TDE2LjUgMTkuNzk0NSIgc3Ryb2tlPSIjMDA3OUJEIiBzdHJva2Utd2lkdGg9IjEuNSIgc3Ryb2tlLWxpbmVjYXA9InJvdW5kIiBzdHJva2UtbGluZWpvaW49InJvdW5kIi8+CjxwYXRoIGQ9Ik0xOS43OTMgNy41TDQuMjA0NTEgMTYuNSIgc3Ryb2tlPSIjMDA3OUJEIiBzdHJva2Utd2lkdGg9IjEuNSIgc3Ryb2tlLWxpbmVjYXA9InJvdW5kIiBzdHJva2UtbGluZWpvaW49InJvdW5kIi8+CjxwYXRoIGQ9Ik0xNC4zMjgxIDMuMzA2NjRMOS42NjkzOCAyMC42OTMzIiBzdHJva2U9IiMwMDc5QkQiIHN0cm9rZS13aWR0aD0iMS41IiBzdHJva2UtbGluZWNhcD0icm91bmQiIHN0cm9rZS1saW5lam9pbj0icm91bmQiLz4KPHBhdGggZD0iTTIwLjY5NTMgMTQuMzI5MUwzLjMwODY1IDkuNjcwMzYiIHN0cm9rZT0iIzAwNzlCRCIgc3Ryb2tlLXdpZHRoPSIxLjUiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8L3N2Zz4K" alt="icon" /></div><h2>Events</h2></div></a><a href="/help/"><div class="navList dropdown-hover-effect-div"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><h2>Help</h2></div></a></div><div class="developers-section dropdown-column-section"><h4 id="m-invisible" style="opacity:0">Resources</h4><a href="/case-studies/"><div class="navList dropdown-hover-effect-div"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><h2>Case Studies</h2></div></a><a href="/graphql/"><div class="navList dropdown-hover-effect-div"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><h2>GraphQL Hub</h2></div></a><a href="/why-hasura/"><div class="navList dropdown-hover-effect-div"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><h2>Why Hasura</h2></div></a><a href="/data-hub/"><div class="navList dropdown-hover-effect-div"><div class="navListImg"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHJlY3QgeD0iMTIuNDU5IiB5PSIyIiB3aWR0aD0iMTEuOTYxNiIgaGVpZ2h0PSIxMS45NjE2IiByeD0iMSIgdHJhbnNmb3JtPSJyb3RhdGUoNDUgMTIuNDU5IDIpIiBzdHJva2U9IiMwMDc5QkQiIHN0cm9rZS13aWR0aD0iMS41IiBzdHJva2UtbGluZWNhcD0icm91bmQiIHN0cm9rZS1saW5lam9pbj0icm91bmQiLz4KPHJlY3QgeD0iMTIuNDU5IiB5PSI2LjA4Mzk4IiB3aWR0aD0iMTEuOTYxNiIgaGVpZ2h0PSIxMS45NjE2IiByeD0iMSIgdHJhbnNmb3JtPSJyb3RhdGUoNDUgMTIuNDU5IDYuMDgzOTgpIiBzdHJva2U9IiMwMDc5QkQiIHN0cm9rZS13aWR0aD0iMS41IiBzdHJva2UtbGluZWNhcD0icm91bmQiIHN0cm9rZS1saW5lam9pbj0icm91bmQiLz4KPC9zdmc+Cg==" alt="icon" /></div><h2>Data Hub</h2></div></a></div><div class="navDrapdownListWrapper"><div class="news-div dropdown-column-section"><a href="https://hasura.io/blog/announcing-hasura-v2-2-0/" target="_blank" rel="noopener noreferrer"><div class="navListAnnouncement"><div class="flex-heading"><h4 class="mb-24">NEWS</h4><div class="nav-link">Read More <img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMTgiIGhlaWdodD0iMTkiIHZpZXdCb3g9IjAgMCAxOCAxOSIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPGcgY2xpcC1wYXRoPSJ1cmwoI2NsaXAwKSI+CjxwYXRoIGQ9Ik02Ljk2OTM4IDUuNzgzMTZDNi42NzY4NyA2LjA3NTY2IDYuNjc2ODcgNi41NDgxNiA2Ljk2OTM4IDYuODQwNjZMOS44NzkzOCA5Ljc1MDY3TDYuOTY5MzggMTIuNjYwN0M2LjY3Njg3IDEyLjk1MzIgNi42NzY4NyAxMy40MjU3IDYuOTY5MzggMTMuNzE4MkM3LjI2MTg4IDE0LjAxMDcgNy43MzQzOCAxNC4wMTA3IDguMDI2ODggMTMuNzE4MkwxMS40Njk0IDEwLjI3NTdDMTEuNzYxOSA5Ljk4MzE3IDExLjc2MTkgOS41MTA2NiAxMS40Njk0IDkuMjE4MTZMOC4wMjY4OCA1Ljc3NTY2QzcuNzQxODggNS40OTA2NiA3LjI2MTg4IDUuNDkwNjYgNi45NjkzOCA1Ljc4MzE2WiIgZmlsbD0iIzAwNzlCRCIvPgo8L2c+CjxkZWZzPgo8Y2xpcFBhdGggaWQ9ImNsaXAwIj4KPHJlY3Qgd2lkdGg9IjE4IiBoZWlnaHQ9IjE4IiBmaWxsPSJ3aGl0ZSIgdHJhbnNmb3JtPSJ0cmFuc2xhdGUoMCAwLjc0OTk4NSkiLz4KPC9jbGlwUGF0aD4KPC9kZWZzPgo8L3N2Zz4K" alt="Arrow" class="arrow-img" /></div></div><h2>Announcing Hasura GraphQL Engine v2.2.0</h2><h4 class="zero-m">Feb 2, 2022</h4></div></a><hr class="news-section-line-break" /><a href="https://hasura.io/blog/graphql-and-the-data-mesh-developer-productivity-in-an-age-of-exploding-data/" target="_blank" rel="noopener noreferrer"><div class="navListAnnouncement"><div class="flex-heading"><h4 class="mb-24">NEWS</h4><div class="nav-link">Read More <img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMTgiIGhlaWdodD0iMTkiIHZpZXdCb3g9IjAgMCAxOCAxOSIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPGcgY2xpcC1wYXRoPSJ1cmwoI2NsaXAwKSI+CjxwYXRoIGQ9Ik02Ljk2OTM4IDUuNzgzMTZDNi42NzY4NyA2LjA3NTY2IDYuNjc2ODcgNi41NDgxNiA2Ljk2OTM4IDYuODQwNjZMOS44NzkzOCA5Ljc1MDY3TDYuOTY5MzggMTIuNjYwN0M2LjY3Njg3IDEyLjk1MzIgNi42NzY4NyAxMy40MjU3IDYuOTY5MzggMTMuNzE4MkM3LjI2MTg4IDE0LjAxMDcgNy43MzQzOCAxNC4wMTA3IDguMDI2ODggMTMuNzE4MkwxMS40Njk0IDEwLjI3NTdDMTEuNzYxOSA5Ljk4MzE3IDExLjc2MTkgOS41MTA2NiAxMS40Njk0IDkuMjE4MTZMOC4wMjY4OCA1Ljc3NTY2QzcuNzQxODggNS40OTA2NiA3LjI2MTg4IDUuNDkwNjYgNi45NjkzOCA1Ljc4MzE2WiIgZmlsbD0iIzAwNzlCRCIvPgo8L2c+CjxkZWZzPgo8Y2xpcFBhdGggaWQ9ImNsaXAwIj4KPHJlY3Qgd2lkdGg9IjE4IiBoZWlnaHQ9IjE4IiBmaWxsPSJ3aGl0ZSIgdHJhbnNmb3JtPSJ0cmFuc2xhdGUoMCAwLjc0OTk4NSkiLz4KPC9jbGlwUGF0aD4KPC9kZWZzPgo8L3N2Zz4K" alt="Arrow" class="arrow-img" /></div></div><h2>GraphQL &amp; the Data Mesh - developer productivity in an age of exploding data</h2><h4 class="zero-m">Oct 13, 2021</h4></div></a></div></div></div></div></li><li><a href="https://hasura.io/docs/latest/graphql/core/index.html" target="_blank" rel="noopener noreferrer" style="text-decoration:none">Docs</a></li><li class=""><a href="/pricing/">Pricing</a></li></ul></div><div class="navRight hideMobile"><ul class="navBarUL"><li class="search-icon search-icon-web"><svg id="search-alt-icon" width="7" height="17" viewBox="0 0 7 17" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M1.5 16.5L5.96718 1.06173" stroke="#1b2738" stroke-width="1.5" stroke-linejoin="round"></path></svg><svg class="styled__StyledSVG-sc-1016hl4-0 jnzEFx" viewBox="0 0 24 24" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M15.5 14H14.71L14.43 13.73C15.41 12.59 16 11.11 16 9.5C16 5.91 13.09 3 9.5 3C5.91 3 3 5.91 3 9.5C3 13.09 5.91 16 9.5 16C11.11 16 12.59 15.41 13.73 14.43L14 14.71V15.5L18.2929 19.7843C18.6835 20.1742 19.3162 20.1738 19.7064 19.7836L19.7836 19.7064C20.1738 19.3162 20.1742 18.6835 19.7843 18.2929L15.5 14ZM9.5 14C7.01 14 5 11.99 5 9.5C5 7.01 7.01 5 9.5 5C11.99 5 14 7.01 14 9.5C14 11.99 11.99 14 9.5 14Z"></path></svg></li><li><a href="/contact-us/?type=hasuraenterprise">Contact Sales</a></li><li class="navLogIn"><a href="https://cloud.hasura.io/login?pg=case-studies_matternet&amp;plcmt=header&amp;cta=log-in&amp;tech=default">Login</a></li><li><a href="https://cloud.hasura.io/signup?pg=case-studies_matternet&amp;plcmt=header&amp;cta=try-hasura&amp;tech=default"><button class="hasura-btn hasura-btn-sm hasura-blue-btn">Get Started</button></a></li></ul></div></div></div><div id="navbar" class="topnav" style="height:0px"><div class="navBarToggleBg"><div class="navBarToggle search-icon"><svg class="styled__StyledSVG-sc-1016hl4-0 jnzEFx" viewBox="0 0 24 24" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M15.5 14H14.71L14.43 13.73C15.41 12.59 16 11.11 16 9.5C16 5.91 13.09 3 9.5 3C5.91 3 3 5.91 3 9.5C3 13.09 5.91 16 9.5 16C11.11 16 12.59 15.41 13.73 14.43L14 14.71V15.5L18.2929 19.7843C18.6835 20.1742 19.3162 20.1738 19.7064 19.7836L19.7836 19.7064C20.1738 19.3162 20.1742 18.6835 19.7843 18.2929L15.5 14ZM9.5 14C7.01 14 5 11.99 5 9.5C5 7.01 7.01 5 9.5 5C11.99 5 14 7.01 14 9.5C14 11.99 11.99 14 9.5 14Z"></path></svg></div><span class="navBarToggle" aria-label="button" role="button" tabindex="0" id="menuClick"><span class="iconBar"></span><span class="iconBar"></span><span class="iconBar"></span></span></div><div class="visibleMobile"><div class="mobileNavListWrapper"><div><button class="hasura-btn hasura-btn-md hasura-light-gray-btn grey-border">Product<!-- --> <img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjUiIHZpZXdCb3g9IjAgMCAyNCAyNSIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTkuMjg4NTkgNy4yMDk3OEM4Ljg5ODU5IDcuNTk5NzggOC44OTg1OSA4LjIyOTc4IDkuMjg4NTkgOC42MTk3OEwxMy4xNjg2IDEyLjQ5OThMOS4yODg1OSAxNi4zNzk4QzguODk4NTkgMTYuNzY5OCA4Ljg5ODU5IDE3LjM5OTggOS4yODg1OSAxNy43ODk4QzkuNjc4NTkgMTguMTc5OCAxMC4zMDg2IDE4LjE3OTggMTAuNjk4NiAxNy43ODk4TDE1LjI4ODYgMTMuMTk5OEMxNS42Nzg2IDEyLjgwOTggMTUuNjc4NiAxMi4xNzk4IDE1LjI4ODYgMTEuNzg5OEwxMC42OTg2IDcuMTk5NzhDMTAuMzE4NiA2LjgxOTc4IDkuNjc4NTkgNi44MTk3OCA5LjI4ODU5IDcuMjA5NzhaIiBmaWxsPSIjMDAzMTVGIi8+Cjwvc3ZnPgo=" alt="right-arrow" class="" /></button><button class="hasura-btn hasura-btn-md hasura-light-gray-btn grey-border">Resources<!-- --> <img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjUiIHZpZXdCb3g9IjAgMCAyNCAyNSIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTkuMjg4NTkgNy4yMDk3OEM4Ljg5ODU5IDcuNTk5NzggOC44OTg1OSA4LjIyOTc4IDkuMjg4NTkgOC42MTk3OEwxMy4xNjg2IDEyLjQ5OThMOS4yODg1OSAxNi4zNzk4QzguODk4NTkgMTYuNzY5OCA4Ljg5ODU5IDE3LjM5OTggOS4yODg1OSAxNy43ODk4QzkuNjc4NTkgMTguMTc5OCAxMC4zMDg2IDE4LjE3OTggMTAuNjk4NiAxNy43ODk4TDE1LjI4ODYgMTMuMTk5OEMxNS42Nzg2IDEyLjgwOTggMTUuNjc4NiAxMi4xNzk4IDE1LjI4ODYgMTEuNzg5OEwxMC42OTg2IDcuMTk5NzhDMTAuMzE4NiA2LjgxOTc4IDkuNjc4NTkgNi44MTk3OCA5LjI4ODU5IDcuMjA5NzhaIiBmaWxsPSIjMDAzMTVGIi8+Cjwvc3ZnPgo=" class="" alt="right-arrow" /></button><a href="https://hasura.io/docs/latest/graphql/core/index.html"><button class="hasura-btn hasura-btn-md hasura-light-gray-btn grey-border">Docs</button></a><a href="/pricing/"><button class="hasura-btn hasura-btn-md hasura-light-gray-btn grey-border">Pricing</button></a><button class="hasura-btn hasura-btn-md hasura-light-gray-btn grey-border"><a style="color:#00315f" href="/contact-us/?type=hasuraenterprise">Contact Sales</a><span class="mobile-github-btn-div"><span><a href="https://github.com/hasura/graphql-engine" data-size="large" data-show-count="true" aria-label="Star @hasura on GitHub">Star</a></span></span></button></div><div class="m-get-started" id="mobile-header-cta"><a href="https://cloud.hasura.io/signup?pg=case-studies_matternet&amp;plcmt=header&amp;cta=try-hasura&amp;tech=default"><button class="hasura-btn hasura-btn-md hasura-blue-btn">Get Started</button></a></div></div></div></div></header><div class="wd100"><div class="StyledCaseStudy-sc-b7y17j-0 bpRHNC"><div class="StyledCaseStudyHeader-sc-12v11yx-0 cdTaZF"><div class="case-study-header containerWrapper"><div><h2>The Matternet Casestudy</h2></div><div class="nav-points"><a href="https://hasura.io/case-studies/matternet/#big-hits">The Big Hits</a><a href="https://hasura.io/case-studies/matternet/#problem">Problem</a><a href="https://hasura.io/case-studies/matternet/#solution">Solution</a><a href="https://hasura.io/case-studies/matternet/#results">Results</a></div></div></div><div class="landing-banner"><div class="containerWrapper"><div class="pipe-info-div"><p class="case-study-info-desc">In conversation with David Tsai</p><h1>How Matternet Is Powering Autonomous Drone Delivery with Hasura</h1><p id="big-hits"><span><a href="https://mttr.net/" target="_blank" rel="noopener noreferrer">Matternet</a> is an end-to-end technology platform for autonomous aerial delivery that provides an integrated service for healthcare, e-commerce, and logistics organizations. Matternet is on a quest to make access to goods as frictionless and universal as access to information, starting with rapid, autonomous, on-demand medical deliveries that save lives and transform healthcare.</span></p></div><div class="StyledBigHits-sc-1tw3y9w-0 kJppts"><div class="timeline-card"><div class="number-div">1</div><p>50% improvement in transaction visibility</p></div><div class="timeline-card"><div class="number-div">2</div><p>Faster application performance</p></div><div class="timeline-card"><div class="number-div">3</div><p>Cleaner system architecture</p></div></div></div></div><div class="containerWrapper"><div class="case-study-section-spacer"><div class="case-study-content-div" id="problem"><div class="left-section"><div class="left-head-section"><p>The Problem</p><h3>Matternet&#x27;s Challenge</h3></div></div><div class="right-section"><p class="head-info"><span>Matternet needed to redesign their application architecture<br /><br />The integrated Matternet platform includes autonomous drones, landing stations, and a cloud-based logistics platform. The Matternet cloud is the brain of the entire system and is responsible for flight planning and real-time drone monitoring. Operators can log into the platform to field customer requests, generate routes, and monitor and control the drones.<br /><br />During flights, the drones and landing stations transmit protobuf (Protocol buffers) messages to the Matternet cloud platform (and clients) using an MQTT (Message Queue Telemetry Transport) broker — a lightweight publish/subscribe protocol designed for resource-constrained devices and slow network links. The MQTT broker passes the various messages to the clients that subscribe. However, the main problem with this approach was that it was difficult to onboard new clients because of the tight coupling between the clients and the protobuf message. Each client had to take on the arduous task of deserializing the protobuf messages, which caused performance bottlenecks.<br /><br />Some of the other issues they faced with this initial tech architecture included:</span></p><div class="content-data-row"><h4 class="info-headline">Inconsistent communication layer for client applications</h4><p class="info-desc">The Matternet team observed that managing the different protobuf integrations in addition to REST APIs became increasingly complex. Therefore, they needed a consistent data layer that was always up to date, reliable, and easy to integrate for their various clients.</p></div><div class="content-data-row"><h4 class="info-headline">Reduced transaction query visibility</h4><p class="info-desc">One of Matternet&#x27;s main concerns with their initial architecture was the lack of proper visibility into their transactions (telemetry data). Because of this, they could not debug system issues efficiently, which affected the reliability of their system. As a result, they needed a solution that gave them more visibility into their systems and transaction information.</p></div><div class="content-data-row"><h4 class="info-headline">Limited architecture flexibility</h4><p class="info-desc">The tight coupling between the clients and the protobuf messages made onboarding new clients and scaling difficult. Thus, Matternet needed to redesign their architecture to iterate on features quickly and stay flexible.</p></div></div></div></div><div class="StyledHighlightCard-sc-z4ly8x-0 cUYJDJ"><h2>“Hasura helped us build a consistent API for our growing client applications.”</h2><p>David Tsai</p><p>Lead Software Engineer, Matternet</p></div><div id="solution"><div class="case-study-content-div mb-50" id="why-matternet-chose-hasura"><div class="left-section"><div class="left-head-section"><p>The Solution</p><h3>Why Matternet chose Hasura</h3></div></div><div class="right-section"><p class="head-info">Hasura cloud-powered GraphQL APIs provided a simplified data layer<br /><br />Matternet discovered GraphQL as a solution to their problems and implemented a GraphQL layer in their architecture; however, the vendor they chose lacked the flexibility and performance capabilities they sought. So, they started exploring other options and discovered Hasura. They did initial experimentation with Hasura using the free tier version, which provided promising results.<br /><br />They decided to include Hasura as a core component of their tech stack for the following reasons:</p></div></div><div class="StyledImageHighlightCard-sc-2pn2vu-0 fIJnNJ"><div class="highlight-img-div"></div><p>Matternet architecture diagram</p></div><div class="case-study-content-div"><div class="left-section"><div class="left-head-section"></div></div><div class="right-section"><div class="content-data-row"><h4 class="info-headline">Client-focused GraphQL APIs</h4><p class="info-desc">Hasura provided an easy way to set up GraphQL APIs by connecting their Postgres databases. Each client could now connect to the same GraphQL API and request their needed data. Furthermore, they could decouple the processing of protobuf messages from their client applications, improving their performance.</p></div><div class="content-data-row"><h4 class="info-headline">REST API integration with Hasura Actions</h4><p class="info-desc">With Hasura Actions, Matternet had a straightforward way to connect their REST APIs and business logic to the centralized graph. In addition, Hasura Actions fit well with the &quot;command/query&quot; architecture Matternet wanted to implement. They could connect Hasura directly to their Postgres database for queries and map commands to Hasura Actions, which would then delegate them to the appropriate REST API handler, creating a neat separation of concerns.</p></div><div class="content-data-row"><h4 class="info-headline">Rate and Query depth limit</h4><p class="info-desc">Hasura’s Rate and Query depth limit features meant that Matternet had complete control of their GraphQL operations. For example, Rate limiting could restrict the number of GraphQL operations per minute, preventing their APIs from malicious overuse. Additionally, Matternet could prevent deeply nested queries that cause performance bottlenecks with the Query depth limit feature. Having these capabilities out of the box with Hasura made Matternet more confident in the reliability of their system.</p></div><div class="content-data-row"><h4 class="info-headline">Simplified authentication and authorization</h4><p class="info-desc">Matternet had to ensure security at every system level, and Hasura’s authentication and authorization features offered them that. For example, Hasura offered role-based access control on all GraphQL schemas down to the row and column level. This tight security made it easy for Matternet to configure permissions for different clients on the same GraphQL API.</p></div></div></div></div><div class="case-study-content-div" id="results"><div class="left-section"><div class="left-head-section"><p>The Results</p><h3>Matternet improved their application software architecture with Hasura Cloud</h3></div><div class="left-section-footer"><h4>“Hasura helped us streamline our business logic and leverage a cleaner architecture.”</h4><p>David Tsai</p><p class="pipe-info-text">Lead Software Engineer, Matternet</p></div></div><div class="right-section"><p class="head-info"><span>With the help of Hasura, Matternet has been able to simplify and improve their application architecture. For example, from the MQTT broker, the protobuf messages are now aggregated to a Kafka stream cluster and then normalized into a Postgres database connected to Hasura. Consequently, all clients (including the Matternet cloud) can now directly interface with Hasura-powered GraphQL APIs to obtain information.<br /><br />Some of the other benefits Matternet attributed to the use of Hasura include:</span></p><div class="content-data-row"><h4 class="info-headline">Consistent GraphQL API for all clients</h4><p class="info-desc">After migrating to Hasura, Matternet now has a consistent GraphQL API for all clients to consume. As a result, they can efficiently cater to many client devices with custom data requirements, dramatically improving the user experience.</p></div><div class="content-data-row"><h4 class="info-headline">Improved transaction visibility</h4><p class="info-desc">The Matternet team reported improved transaction visibility after moving to Hasura. Hasura provided complete transaction visibility with analytics integration, giving Matternet full observability into their system. As a result, the Matternet team can quickly debug issues and identify performance bottlenecks, significantly improving application performance and reliability.</p></div><div class="content-data-row"><h4 class="info-headline">Cleaner architecture</h4><p class="info-desc">Hasura enabled Matternet to leverage a “command/query” model for a cleaner and more reliable application architecture. Thus, they could decouple the business logic from the clients and implement a good separation of concerns. This new architecture has enabled them to stay light on their feet, iterate faster, scale easily, and improve their overall system.</p></div></div></div><div class="case-study-content-div"><div class="left-section"><div class="left-head-section"><p>Closing Note</p><h3>What’s Next for Matternet</h3></div></div><div class="right-section pipe-closing-notes-text"><p class="pipe-closing-notes-text"><span>Matternet has already demonstrated the potential for medical drone delivery networks in regions worldwide. In 2021, through a partnership with UPS, Matternet became the first drone company to <a href="https://twitter.com/matternet/status/1430259369124392960" target="_blank" rel="noopener noreferrer">transport Pfizer vaccine doses</a>  in the U.S. In addition, Matternet has partnered with UAE leaders in logistics and the Abu Dhabi Department of Health to provide  <a href="https://mttr.net/images/Matternet_Press_AbuDhabi_20210922.pdf" target="_blank" rel="noopener noreferrer">city-wide medical delivery by air</a>.  They continue to work closely with the Hasura team to expand their drone network to more cities and cater to more business use cases.</span></p></div></div><div class="StyledOtherStudies-sc-1vei6qz-0 bRUjfN"><p>Other Stories</p><h3>Learn more from of our<br /> users’ experience</h3><div class="other-stories-div"><a href="/case-studies/us-house-of-representatives/"><div class="story-link-card"><div class="img-div"><img alt="U.S. House of Representatives" loading="lazy" src="/static/ushor-fbe8b34769daf764a8e2a381b9bd0a31.png" id="U.S. House of Representatives-logo" class="StyledImage-sc-1oh50qk-0 iSsCzA" /></div><div><h2>U.S. House of Representatives</h2><p>Modernization of the 30-year-old Tech Stack</p></div></div></a><a href="/case-studies/pipe/"><div class="story-link-card"><div class="img-div"><img alt="Pipe" loading="lazy" src="data:image/svg+xml;base64,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" id="Pipe-logo" class="StyledImage-sc-1oh50qk-0 iugxsH" /></div><div><h2>Pipe</h2><p>How Pipe went from prototype to production in 11 days with Hasura</p></div></div></a><a href="/case-studies/athlane/"><div class="story-link-card"><div class="img-div"><img alt="Athlane" loading="lazy" src="data:image/svg+xml;base64,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" id="Athlane-logo" class="StyledImage-sc-1oh50qk-0 iugxsH" /></div><div><h2>Athlane</h2><p>How Athlane uses Hasura Cloud to increase their Developer Velocity 200%</p></div></div></a></div></div></div></div></div><section id="footer-newsletter" class="StyledSectionWrapper-sc-eunbva-0 footer___StyledStyledSectionWrapper-sc-1y9m3o4-1 isYyaZ cowna-D"><section class="StyledContainerWrapper-sc-731dqe-0 footer___StyledStyledContainerWrapper-sc-1y9m3o4-2 dCClbK"><div class="footer___StyledDiv-sc-1y9m3o4-3"><div class="footer__StyledNewsletterWrapper-sc-1y9m3o4-0 lfDzLy"><div class="p100"><div class="subscribeNewsletterWrapper removePaddBottom " id="subscribe-updates"><div class="hasura-ibm-plex-sub-title subscribeFooter">Monthly product updates in your inbox. No spam.</div> <div class="marketoFormWrapper subscribeNewsletterForm"><span class="Paperform__StyledLoadingText-sc-78770z-0 chuZoV">Loading...</span><div data-prefill-inherit="1" data-no-scroll="1" id="hf-1011" data-paperform-id="hf-1011" data-spinner="1"></div></div></div></div><div class="newsLetterImg"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="News letter" /></div></div></div></section></section><footer class="wd100"><div class="footer___StyledDiv2-sc-1y9m3o4-4 containerWrapper"><div class="footer___StyledDiv3-sc-1y9m3o4-5"><div class="footerImg"><img loading="lazy" src="/static/footer-img-79b3cfc0ceb3c7e466198ae09e1d4e6e.png" alt="footer illustration" /></div><div class="footerWrappper wd100"><div class="footerLinks hasura-ibm-plex-nav-btn"><div class="footerLinksHeader">Hasura</div><a class="links" href="/about/">About Us</a><a class="links" href="/press/">Press</a><a href="/careers/" class="links">Careers</a><a class="links" href="/contact-us/">Contact Us</a><a class="links" href="/legal/">Legal Stuff</a></div><div class="footerLinks hasura-ibm-plex-nav-btn"><div class="footerLinksHeader">Support</div><a href="https://hasura.io/docs/latest/graphql/core/index.html" class="links" target="_blank" rel="noopener noreferrer">Documentation</a><a href="https://discord.com/invite/hasura" class="links" target="_blank" rel="noopener noreferrer">Community Forum</a><a href="https://hasura.io/help/" class="links">Help</a><a href="https://github.com/hasura" class="links" target="_blank" rel="noopener noreferrer">Github</a><a href="https://status.hasura.io/" class="links" target="_blank" rel="noopener noreferrer">Hasura Cloud Status</a><a href="https://hasura.io/cloud-survey/?id=1101" class="links hide" target="_blank" rel="noopener noreferrer">Hasura Cloud Survey</a></div><div class="footerLinks hasura-ibm-plex-nav-btn"><div class="footerLinksHeader">Tools</div><a href="https://github.com/hasura/graphqurl" class="links" target="_blank" rel="noopener noreferrer">Graphqurl</a><a href="https://github.com/hasura/firebase2graphql" class="links" target="_blank" rel="noopener noreferrer">Firebase2GraphQL</a><a href="https://github.com/hasura/json2graphql" class="links" target="_blank" rel="noopener noreferrer">JSON2GraphQL</a><a href="https://github.com/hasura/graphql2chartjs" class="links" target="_blank" rel="noopener noreferrer">GraphQL2ChartJS</a></div><div class="footerLinks hasura-ibm-plex-nav-btn"><div class="footerLinksHeader">Product</div><a class="links" href="/opensource/">Hasura Open Source</a><a class="links" href="/cloud/">Hasura Cloud</a><a class="links" href="/enterprise/">Hasura Enterprise</a><a class="links" href="/pricing/">Pricing</a><a href="https://github.com/hasura/graphql-engine/releases" class="links" target="_blank" rel="noopener noreferrer">Changelog</a></div><div class="footerLinks hasura-ibm-plex-nav-btn"><div class="footerLinksHeader">Resources</div><a href="https://hasura.io/blog/" class="links" target="_blank" rel="noopener noreferrer">Blog</a><a class="links" href="/case-studies/">Case Studies</a><a href="https://3factor.app/" class="links" target="_blank" rel="noopener noreferrer">3Factor Apps</a><a class="links" href="/event-driven-programming/">Event Driven Programming</a><a class="links" href="/react-graphql/">React GraphQL</a><a class="links" href="/vue-graphql/">Vue GraphQL</a><a class="links" href="/diy-graphql-baas/">DIY GraphQL BaaS</a><a class="links" href="/graphql/">GraphQL &amp; Hasura</a><a class="links" href="/security/">Hasura Cloud Security</a></div><div class="footerLinks hasura-ibm-plex-nav-btn"><div class="footerLinksHeader">Community</div><a class="links" href="/community/">Community Resources</a><a href="https://hasura.io/learn/" class="links" target="_blank" rel="noopener noreferrer">GraphQL Tutorials</a><a href="https://github.com/hasura/graphql-engine/wiki" class="links" target="_blank" rel="noopener noreferrer">Community Wiki</a><a class="links" href="/sample-apps/">Sample Apps</a><a class="links" href="/partner-agencies/">Partnership Program</a><a class="links" href="/events/hasura-con-2021/">HasuraCon 2021</a><a href="https://graphql.asia/" class="links" target="_blank" rel="noopener noreferrer">GraphQL Asia</a></div></div><div class="footerImgMobile"><img src="/static/footer-img-79b3cfc0ceb3c7e466198ae09e1d4e6e.png" alt="footer illustration" /></div></div></div><div class="copyWriteWrapperBg wd100"><div class="CopyWriter___StyledDiv-sc-4k2j2k-0 containerWrapper"><div class="CopyWriter___StyledDiv2-sc-4k2j2k-1"><div class="copyWriteWrapper"><div class="brand"><img src="data:image/svg+xml;base64,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" alt="Brand logo" /></div><div class="hasura-ibm-plex-mono">© <!-- -->2022<!-- --> Hasura Inc. All rights reserved</div><div class="footerSocialIconsWrapper"><div class="socialBrands"><a href="https://github.com/hasura/graphql-engine" rel="noopener noreferrer" aria-label="Github"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Github" /></a></div><div class="socialBrands"><a href="https://twitter.com/hasurahq" rel="noopener noreferrer" aria-label="Twitter"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Titter" /></a></div><div class="socialBrands"><a href="https://discord.com/invite/hasura" rel="noopener noreferrer" aria-label="Discord"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Discord" /></a></div><div class="socialBrands"><a href="https://www.facebook.com/HasuraHQ" rel="noopener noreferrer" aria-label="Facebook"><img loading="lazy" src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTEyIDBDNS4zOTk5OSAwIDAgNS4zODc5OSAwIDEyLjAyNEMwIDE4LjAyNCA0LjM5MTk5IDIzLjAwNCAxMC4xMjggMjMuOTA0VjE1LjUwNEg3LjA3OTk5VjEyLjAyNEgxMC4xMjhWOS4zNzE5OUMxMC4xMjggNi4zNTk5OSAxMS45MTYgNC43MDM5OSAxNC42NjQgNC43MDM5OUMxNS45NzIgNC43MDM5OSAxNy4zNCA0LjkzMTk5IDE3LjM0IDQuOTMxOTlWNy44OTU5OUgxNS44MjhDMTQuMzQgNy44OTU5OSAxMy44NzIgOC44MTk5OSAxMy44NzIgOS43Njc5OVYxMi4wMjRIMTcuMjA4TDE2LjY2OCAxNS41MDRIMTMuODcyVjIzLjkwNEMxNi42OTk3IDIzLjQ1NzQgMTkuMjc0NiAyMi4wMTQ2IDIxLjEzMTkgMTkuODM2QzIyLjk4OTIgMTcuNjU3NSAyNC4wMDY0IDE0Ljg4NjggMjQgMTIuMDI0QzI0IDUuMzg3OTkgMTguNiAwIDEyIDBaIiBmaWxsPSIjNzE3NzgwIi8+Cjwvc3ZnPgo=" alt="Facebook" /></a></div><div class="socialBrands"><a href="https://www.instagram.com/hasurahq/?hl=en" rel="noopener noreferrer" aria-label="Instagram"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Instagram" /></a></div><div class="socialBrands"><a href="https://www.youtube.com/channel/UCZo1ciR8pZvdD3Wxp9aSNhQ" rel="noopener noreferrer" aria-label="Youtube"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Youtube" /></a></div><div class="socialBrands"><a href="https://www.linkedin.com/company/hasura" rel="noopener noreferrer" aria-label="Linkedin"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Linkedin" /></a></div></div></div></div></div></div></footer></div></div></div><div id="gatsby-announcer" style="position:absolute;top:0;width:1px;height:1px;padding:0;overflow:hidden;clip:rect(0, 0, 0, 0);white-space:nowrap;border:0" aria-live="assertive" aria-atomic="true"></div></div><script id="gatsby-script-loader">/*<![CDATA[*/window.pagePath="/case-studies/matternet/";/*]]>*/</script><script id="gatsby-chunk-mapping">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</script><script src="/polyfill-42ae2a5525cb516808d9.js" nomodule=""></script><script src="/component---src-components-case-study-index-js-429f36f59fed2aa9c23e.js" async=""></script><script src="/2711bc595453a3e566c609c18cf31d16e0f5d9d7-f88f66ba3e4cb288ec25.js" async=""></script><script src="/1722f91412bcb57bb36aedaad1ae33696fba0c0e-96638146d307305ab490.js" async=""></script><script src="/a8a840e6d82aa2727d67a80324db0839b3898d94-fee7af6d35c3fb048e5c.js" async=""></script><script src="/5f8f9cddecb59249a2614f362a25bd62ac1a5c08-8a040e544c4008463e2c.js" async=""></script><script src="/ec586dc9bbfb2cc5dbd82cf470c94db08db1831f-8fe6832ed0799dc4678f.js" async=""></script><script src="/commons-ac12621159ac0636a9f4.js" async=""></script><script src="/app-3822a25cf818e250c86a.js" async=""></script><script src="/framework-070807bfa7d45403643d.js" async=""></script><script src="/webpack-runtime-74276ac09f033b02da78.js" async=""></script></body></html>