<!DOCTYPE html><html lang="en"><head><meta charSet="utf-8" /><meta http-equiv="x-ua-compatible" content="ie=edge" /><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no" /><style data-href="/component---src-pages-reference-app-js.47e2cb5dbcd408d2802f.css" id="gatsby-global-css">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</style><style data-href="/styles.60d1d7660fa457938ca2.css" id="gatsby-global-css">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</style><meta name="generator" content="Gatsby 3.4.0" /><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src= 'https://www.googletagmanager.com/gtm.js?id='+i+dl+'';f.parentNode.insertBefore(j,f); })(window,document,'script','dataLayer', 'GTM-KPWB7RN');</script><style data-styled="" data-styled-version="5.2.3"></style><title data-react-helmet="true">Hasura Super App—An open source reference app built using Hasura</title><link data-react-helmet="true" rel="canonical" href="https://hasura.io/reference-app/" /><meta data-react-helmet="true" name="title" content="Hasura Super App—An open source reference app built using Hasura" /><meta data-react-helmet="true" name="description" content="The Hasura Super App is a reference app that showcases how to leverage Hasura superpowers to build modern apps with complex business logic." /><meta data-react-helmet="true" property="og:title" content="Hasura Super App—An open source reference app built using Hasura" /><meta data-react-helmet="true" property="og:description" content="The Hasura Super App is a reference app that showcases how to leverage Hasura superpowers to build modern apps with complex business logic." /><meta data-react-helmet="true" property="og:image" content="https://graphql-engine-cdn.hasura.io/assets/main-site/e-commerce.png" /><meta data-react-helmet="true" property="og:type" content="website" /><meta data-react-helmet="true" name="twitter:card" content="summary_large_image" /><meta data-react-helmet="true" name="twitter:title" content="Hasura Super App—An open source reference app built using Hasura" /><meta data-react-helmet="true" name="twitter:description" content="The Hasura Super App is a reference app that showcases how to leverage Hasura superpowers to build modern apps with complex business logic." /><script data-react-helmet="true" type="application/ld+json">{"@context":"http://schema.org/","@type":"FAQPage","mainEntity":[{"@type":"Question","name":"Can this be used as a \"Starter Kit\"?","acceptedAnswer":{"@type":"Answer","text":"While you technically could take the code given here as the basis for your new application, you probably wouldn't want to. This application wasn't built to be adaptable or generic, but rather to cater to one specific implementation for education purposes and to prove a point. We and several users in our community have much better-suited resources available for starter apps, if that's what you're looking for."}},{"@type":"Question","name":"What do I need to run this?","acceptedAnswer":{"@type":"Answer","text":"Running the application requires only Docker and Git installed. If you want the payments/billing feature to be functional, you need to insert a genuine Stripe test or production key (the rest of the application functions fine with a fake one). The Docker Compose file in the root of the repo starts Hasura, Next.js, Minio, and Postgres."}},{"@type":"Question","name":"Where is Feature X?","acceptedAnswer":{"@type":"Answer","text":"For the history and background context of this reference application being built, please see the notice in the repo here: https://github.com/hasura/hasura-ecommerce#hasura-e-commerce-demo You may find that certain features don't have examples in the codebase. At the time of writing, this application currently doesn't implement every possible Hasura feature. Our intent is to maintain and expand it over time as resources permit, until we achieve full feature-coverage and so that there exists a canonical reference for how to do this."}}]}</script><link rel="sitemap" type="application/xml" href="/sitemap.xml" /><link rel="icon" href="/favicon-32x32.png?v=6e6e57b4b98fec791dd9f3d077b80810" type="image/png" /><link rel="manifest" href="/manifest.webmanifest" crossorigin="anonymous" /><link rel="apple-touch-icon" sizes="48x48" href="/icons/icon-48x48.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="72x72" href="/icons/icon-72x72.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="96x96" href="/icons/icon-96x96.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="144x144" href="/icons/icon-144x144.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="192x192" href="/icons/icon-192x192.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="256x256" href="/icons/icon-256x256.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="384x384" href="/icons/icon-384x384.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="512x512" href="/icons/icon-512x512.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link crossorigin="" href="https://www.google.com" rel="preconnect" /><link crossorigin="" href="https://stats.g.doubleclick.net" rel="preconnect" /><link crossorigin="" href="https://page.hasura.io" rel="preconnect" /><link crossorigin="" href="https://connect.facebook.net" rel="preconnect" /><link rel="icon" href="/favicon-32x32.png?v=6e6e57b4b98fec791dd9f3d077b80810" type="image/png" /><link rel="manifest" href="/manifest.webmanifest" crossorigin="anonymous" /><meta name="theme-color" content="#663399" /><link rel="apple-touch-icon" sizes="48x48" href="/icons/icon-48x48.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="72x72" href="/icons/icon-72x72.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="96x96" href="/icons/icon-96x96.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="144x144" href="/icons/icon-144x144.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="192x192" href="/icons/icon-192x192.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="256x256" href="/icons/icon-256x256.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="384x384" href="/icons/icon-384x384.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link rel="apple-touch-icon" sizes="512x512" href="/icons/icon-512x512.png?v=6e6e57b4b98fec791dd9f3d077b80810" /><link as="script" rel="preload" href="/webpack-runtime-6518691937f0f34ed909.js" /><link as="script" rel="preload" href="/framework-660f14b4e2df4188b3f4.js" /><link as="script" rel="preload" href="/app-de7dcd78d99f48b74bbd.js" /><link as="script" rel="preload" href="/commons-cfc2e38a7939f12cc44c.js" /><link as="script" rel="preload" href="/432f36a8b75b6db2c3ad97ad9ebc4031ad6394aa-85224f10a7b410cc6926.js" /><link as="script" rel="preload" href="/56e53495d17a8009700a24dae53bb7a1c5e8c4fb-ff83c21b0c84c73f48b9.js" /><link as="script" rel="preload" href="/component---src-pages-reference-app-js-d1fb346a6268f3b79169.js" /><link as="fetch" rel="preload" href="/page-data/reference-app/page-data.json" crossorigin="anonymous" /><link as="fetch" rel="preload" href="/page-data/sq/d/3000892485.json" crossorigin="anonymous" /><link as="fetch" rel="preload" href="/page-data/app-data.json" crossorigin="anonymous" /><link rel="preload" as="font" href="/fonts/poppins-regular-latin.woff2" type="font/woff2" crossorigin="anonymous" /><link rel="preload" as="font" href="/fonts/poppins-600-latin.woff2" type="font/woff2" crossorigin="anonymous" /><link rel="preload" as="font" href="/fonts/poppins-bold-latin.woff2" type="font/woff2" crossorigin="anonymous" /><link rel="preload" href="https://page.hasura.io/js/forms2/css/forms2.css" as="style" /><link rel="preload" href="https://page.hasura.io/js/forms2/css/forms2-theme-simple.css" as="style" /><script type="application/ld+json">{
              "@context": "http://schema.org/",
              "@type": "Organization",
              "name": "Hasura",
              "logo": "https://hasura.io/logo.svg",
              "url": "https://hasura.io",
              "foundingDate": "2015",
              "address": {
                "@type": "PostalAddress",
                "addressLocality": "Bangalore",
                "addressRegion": "Karnataka",
                "postalCode": "560034",
                "streetAddress": "2nd Floor, Building, No 37/38, 80 Feet Rd, 3rd Block, Koramangala 1A Block, SBI Colony, Koramangala"
              },
              "founders": [{"@type": "Person","name": "Tanmai Gopal"},{"@type": "Person","name": "Rajoshi Ghosh"}],
              "contactPoint": {
                 "@type": "ContactPoint",
                 "contactType": "Sales",
                 "email": "build@hasura.io",
                 "url": "https://hasura.io"
              },
              "sameAs": [
                "https://en.wikipedia.org/wiki/Hasura",
                "https://www.wikidata.org/wiki/Q56676515",
                "https://www.facebook.com/HasuraHQ",
                "https://www.twitter.com/hasurahq",
                "https://www.linkedin.com/company/hasura",
                "https://www.instagram.com/hasurahq",
                "https://www.youtube.com/hasurahq"
              ]
          }</script><script type="application/ld+json">{
              "@context": "http://schema.org",
              "@type": "WebSite",
              "name": "Hasura",
              "url": "https://hasura.io"
          }</script></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KPWB7RN" height="0" width="0" style="display: none; visibility: hidden" aria-hidden="true"></iframe></noscript><div id="___gatsby"><div style="outline:none" tabindex="-1" id="gatsby-focus-wrapper"><div id="viewport" class="viewport"><div class="hasuraConBannerBg"><div class="containerWidth"><div class="commonBannerStripWrapper"><a href="/events/hasura-con-2021/?pg=home&amp;plcmt=banner&amp;cta=register-now&amp;tech=" class="articleDesc hasura-font-bold">HasuraCon&#x27;21 is over. Get the recordings <!-- --> <div class="arrow"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iNyIgaGVpZ2h0PSIxMCIgdmlld0JveD0iMCAwIDcgMTAiIGZpbGw9Im5vbmUiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyI+CjxwYXRoIGQ9Ik0xLjAwMDEzIDlMNiA0Ljk5OTEyTDEgMSIgc3Ryb2tlPSIjMjEyRTQwIiBzdHJva2Utd2lkdGg9IjEuNSIgc3Ryb2tlLWxpbmVjYXA9InJvdW5kIiBzdHJva2UtbGluZWpvaW49InJvdW5kIi8+Cjwvc3ZnPgo=" alt="Arrow" /></div></a><div class="closeBanner" role="button" tabindex="0"><img class="img-responsive" src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjUiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNSAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggb3BhY2l0eT0iMC41IiBkPSJNMTIuNDkyIDBDMTkuMTI4IDAgMjQuNDkyIDUuMzY0IDI0LjQ5MiAxMkMyNC40OTIgMTguNjM2IDE5LjEyOCAyNCAxMi40OTIgMjRDNS44NTYgMjQgMC40OTIwMDQgMTguNjM2IDAuNDkyMDA0IDEyQzAuNDkyMDA0IDUuMzY0IDUuODU2IDAgMTIuNDkyIDBaTTE2LjggNkwxMi40OTIgMTAuMzA4TDguMTg0IDZMNi40OTIgNy42OTJMMTAuOCAxMkw2LjQ5MiAxNi4zMDhMOC4xODQgMThMMTIuNDkyIDEzLjY5MkwxNi44IDE4TDE4LjQ5MiAxNi4zMDhMMTQuMTg0IDEyTDE4LjQ5MiA3LjY5MkwxNi44IDZaIiBmaWxsPSIjRDZFQkZGIi8+Cjwvc3ZnPgo=" alt="Close" /></div></div></div></div><div class="wd100"><header id="header" class="lightModeHeader"><div class="containerWrapper"><div class="headerWrapper"><div id="navBrand" class="navLeft"><div class="brand"><a href="/"><img src="data:image/svg+xml;base64,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" alt="Hasura Logo" title="Hasura Logo" /></a></div></div><div></div><div class="navCenter hideMobile"><ul class="navBarUL m-nav-t"><li class=""><a href="/products/">PRODUCTS</a></li><li><a href="https://hasura.io/docs/latest/graphql/core/index.html" target="_blank" rel="noopener noreferrer" style="text-decoration:none">DOCS</a></li><li class="dropDownList"><a role="button" tabindex="0">RESOURCES</a><div id="resource-nav" class="zIndex dropDownContent"><div class="navDrapdownWrapper"><div class="containerWrapper"><div class="hasura-ibm-plex-nav mobileNavShow mobileTitleResources">Resources</div><div class="navDrapdownListWrapper"><div class="navListWrapper"><a href="/learn/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">Tutorials</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Real-world GraphQL Tuts</div></div></div></a><a href="https://hasura.io/blog/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTE2LjUgMTcuNUMxNi44OTc4IDE3LjUgMTcuMjc5NCAxNy4zNDIgMTcuNTYwNyAxNy4wNjA3QzE3Ljg0MiAxNi43Nzk0IDE4IDE2LjM5NzggMTggMTZWNEMxOCAzLjE2NzUgMTcuMzI1IDIuNSAxNi41IDIuNUgxMlY3Ljc1TDEwLjEyNSA2LjYyNUw4LjI1IDcuNzVWMi41SDcuNUM3LjEwMjE4IDIuNSA2LjcyMDY0IDIuNjU4MDQgNi40MzkzNCAyLjkzOTM0QzYuMTU4MDQgMy4yMjA2NCA2IDMuNjAyMTggNiA0VjE2QzYgMTYuMzk3OCA2LjE1ODA0IDE2Ljc3OTQgNi40MzkzNCAxNy4wNjA3QzYuNzIwNjQgMTcuMzQyIDcuMTAyMTggMTcuNSA3LjUgMTcuNUgxNi41WiIgZmlsbD0iIzBCNTU5OSIvPgo8L3N2Zz4K" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">Blog</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Editorials and releases</div></div></div></a><a href="/user-stories/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">User stories</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Read user case-studies</div></div></div></a><a href="/events/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTE3LjI1IDE2SDYuNzVWNy43NUgxNy4yNVYxNlpNMTUgMi41VjRIOVYyLjVINy41VjRINi43NUM2LjM1MjE4IDQgNS45NzA2NCA0LjE1ODA0IDUuNjg5MzQgNC40MzkzNEM1LjQwODA0IDQuNzIwNjQgNS4yNSA1LjEwMjE4IDUuMjUgNS41VjE2QzUuMjUgMTYuMzk3OCA1LjQwODA0IDE2Ljc3OTQgNS42ODkzNCAxNy4wNjA3QzUuOTcwNjQgMTcuMzQyIDYuMzUyMTggMTcuNSA2Ljc1IDE3LjVIMTcuMjVDMTcuNjQ3OCAxNy41IDE4LjAyOTQgMTcuMzQyIDE4LjMxMDcgMTcuMDYwN0MxOC41OTIgMTYuNzc5NCAxOC43NSAxNi4zOTc4IDE4Ljc1IDE2VjUuNUMxOC43NSA1LjEwMjE4IDE4LjU5MiA0LjcyMDY0IDE4LjMxMDcgNC40MzkzNEMxOC4wMjk0IDQuMTU4MDQgMTcuNjQ3OCA0IDE3LjI1IDRIMTYuNVYyLjVIMTVaTTExLjE2IDEwLjc1SDguNDUyNUwxMC42NDI1IDEyLjMzMjVMOS44MSAxNC45MkwxMiAxMy4zMjI1TDE0LjE5IDE0LjkyTDEzLjM1IDEyLjM0TDE1LjU0IDEwLjc1SDEyLjg0TDEyIDguMTdMMTEuMTYgMTAuNzVaIiBmaWxsPSIjMEI1NTk5Ii8+Cjwvc3ZnPgo=" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">Events</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Workshops, confs and more</div></div></div></a><a href="/community/contributor-program/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">Contributor Program</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Community and more</div></div></div></a><a href="/graphql/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">graphql</div><div class="hasura-ibm-plex-mono-small mobileNavHide">The GraphQL hub</div></div></div></a><a href="/help/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">help</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Chat with the experts</div></div></div></a></div><div><a href="/learn/"><div class="navListAnnouncement navLearnBg mb-32"><div class="hasura-ibm-plex-article-desc">Learn with Hasura<div class="arrow"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iOCIgaGVpZ2h0PSIxMCIgdmlld0JveD0iMCAwIDggMTAiIGZpbGw9Im5vbmUiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyI+CjxwYXRoIGQ9Ik0xLjUwMDEzIDlMNi41IDQuOTk5MTJMMS41IDEiIHN0cm9rZT0iI0YzRkZGQSIgc3Ryb2tlLXdpZHRoPSIxLjUiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8L3N2Zz4K" alt="Arrow" /></div></div><div class="hasura-ibm-plex-mono">Get started with GraphQL and Hasura from our selection of over 15 courses</div></div></a><a href="/graphql/database/"><div class="navListAnnouncement navDataBaseBg"><div class="hasura-ibm-plex-article-desc">Supported Databases<div class="arrow"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iOCIgaGVpZ2h0PSIxMCIgdmlld0JveD0iMCAwIDggMTAiIGZpbGw9Im5vbmUiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyI+CjxwYXRoIGQ9Ik0xLjUwMDEzIDlMNi41IDQuOTk5MTJMMS41IDEiIHN0cm9rZT0iI0YzRkZGQSIgc3Ryb2tlLXdpZHRoPSIxLjUiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8L3N2Zz4K" alt="Arrow" /></div></div><div class="hasura-ibm-plex-mono">Auto-generate GraphQL &amp; REST APIs for your data from any of our supported dbs</div></div></a></div></div></div></div></div></li><li class=""><a href="/pricing/">PRICING</a></li></ul></div><div class="navRight hideMobile"><ul class="navBarUL"><li class="m-nav-t navLogIn"><a href="https://cloud.hasura.io/?pg=home&amp;plcmt=header&amp;cta=log-in&amp;tech=default">LOG IN</a></li><li><a href="https://github.com/hasura/graphql-engine"><button class="hasura-btn hasura-btn-sm hasura-gray-github-btn"><img src="data:image/svg+xml;base64,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" alt="Github" /></button></a></li><li><a href="/contact-us/?type=hasuraenterprise"><button class="hasura-btn hasura-btn-sm hasura-gray-btn">CONTACT SALES</button></a></li><li><a href="https://cloud.hasura.io/signup?pg=home&amp;plcmt=header&amp;cta=try-hasura&amp;tech=default"><button class="hasura-btn hasura-btn-sm hasura-green-btn">GET STARTED NOW</button></a></li></ul></div><div id="navbar" class="topnav"><div class="githubMobile"><a href="https://github.com/hasura/graphql-engine"><button class="hasura-btn hasura-btn-sm hasura-gray-github-btn"><img src="data:image/svg+xml;base64,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" alt="Github" /></button></a></div><div class="navBarToggleBg"><span class="navBarToggle" aria-label="button" role="button" tabindex="0" id="menuClick"><span class="iconBar"></span><span class="iconBar"></span><span class="iconBar"></span></span></div><div class="visibleMobile"><div class="brand"><a href="/"><img src="data:image/svg+xml;base64,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" alt="Hasura Logo" title="Hasura Logo" /></a></div><div class="mobileNavListWrapper"><a href="/products/"><button class="hasura-btn hasura-btn-md hasura-light-gray-btn">Products</button></a><a href="/pricing/"><button class="hasura-btn hasura-btn-md hasura-light-gray-btn">Pricing</button></a><a href="https://hasura.io/docs/latest/graphql/core/index.html"><button class="hasura-btn hasura-btn-md hasura-light-gray-btn">Docs</button></a><a href="https://cloud.hasura.io/?pg=home&amp;plcmt=header&amp;cta=log-in&amp;tech=default"><button class="hasura-btn hasura-btn-md hasura-light-gray-btn">LOG IN</button></a></div><div class="navDrapdownWrapper"><div class="containerWrapper"><div class="hasura-ibm-plex-nav mobileNavShow mobileTitleResources">Resources</div><div class="navDrapdownListWrapper"><div class="navListWrapper"><a href="/learn/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">Tutorials</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Real-world GraphQL Tuts</div></div></div></a><a href="https://hasura.io/blog/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTE2LjUgMTcuNUMxNi44OTc4IDE3LjUgMTcuMjc5NCAxNy4zNDIgMTcuNTYwNyAxNy4wNjA3QzE3Ljg0MiAxNi43Nzk0IDE4IDE2LjM5NzggMTggMTZWNEMxOCAzLjE2NzUgMTcuMzI1IDIuNSAxNi41IDIuNUgxMlY3Ljc1TDEwLjEyNSA2LjYyNUw4LjI1IDcuNzVWMi41SDcuNUM3LjEwMjE4IDIuNSA2LjcyMDY0IDIuNjU4MDQgNi40MzkzNCAyLjkzOTM0QzYuMTU4MDQgMy4yMjA2NCA2IDMuNjAyMTggNiA0VjE2QzYgMTYuMzk3OCA2LjE1ODA0IDE2Ljc3OTQgNi40MzkzNCAxNy4wNjA3QzYuNzIwNjQgMTcuMzQyIDcuMTAyMTggMTcuNSA3LjUgMTcuNUgxNi41WiIgZmlsbD0iIzBCNTU5OSIvPgo8L3N2Zz4K" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">Blog</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Editorials and releases</div></div></div></a><a href="/user-stories/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">User stories</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Read user case-studies</div></div></div></a><a href="/events/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTE3LjI1IDE2SDYuNzVWNy43NUgxNy4yNVYxNlpNMTUgMi41VjRIOVYyLjVINy41VjRINi43NUM2LjM1MjE4IDQgNS45NzA2NCA0LjE1ODA0IDUuNjg5MzQgNC40MzkzNEM1LjQwODA0IDQuNzIwNjQgNS4yNSA1LjEwMjE4IDUuMjUgNS41VjE2QzUuMjUgMTYuMzk3OCA1LjQwODA0IDE2Ljc3OTQgNS42ODkzNCAxNy4wNjA3QzUuOTcwNjQgMTcuMzQyIDYuMzUyMTggMTcuNSA2Ljc1IDE3LjVIMTcuMjVDMTcuNjQ3OCAxNy41IDE4LjAyOTQgMTcuMzQyIDE4LjMxMDcgMTcuMDYwN0MxOC41OTIgMTYuNzc5NCAxOC43NSAxNi4zOTc4IDE4Ljc1IDE2VjUuNUMxOC43NSA1LjEwMjE4IDE4LjU5MiA0LjcyMDY0IDE4LjMxMDcgNC40MzkzNEMxOC4wMjk0IDQuMTU4MDQgMTcuNjQ3OCA0IDE3LjI1IDRIMTYuNVYyLjVIMTVaTTExLjE2IDEwLjc1SDguNDUyNUwxMC42NDI1IDEyLjMzMjVMOS44MSAxNC45MkwxMiAxMy4zMjI1TDE0LjE5IDE0LjkyTDEzLjM1IDEyLjM0TDE1LjU0IDEwLjc1SDEyLjg0TDEyIDguMTdMMTEuMTYgMTAuNzVaIiBmaWxsPSIjMEI1NTk5Ii8+Cjwvc3ZnPgo=" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">Events</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Workshops, confs and more</div></div></div></a><a href="/community/contributor-program/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">Contributor Program</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Community and more</div></div></div></a><a href="/graphql/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">graphql</div><div class="hasura-ibm-plex-mono-small mobileNavHide">The GraphQL hub</div></div></div></a><a href="/help/"><div class="navList"><div class="navListImg"><img src="data:image/svg+xml;base64,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" alt="icon" /></div><div><div class="hasura-ibm-plex-nav">help</div><div class="hasura-ibm-plex-mono-small mobileNavHide">Chat with the experts</div></div></div></a></div><div><a href="/learn/"><div class="navListAnnouncement navLearnBg mb-32"><div class="hasura-ibm-plex-article-desc">Learn with Hasura<div class="arrow"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iOCIgaGVpZ2h0PSIxMCIgdmlld0JveD0iMCAwIDggMTAiIGZpbGw9Im5vbmUiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyI+CjxwYXRoIGQ9Ik0xLjUwMDEzIDlMNi41IDQuOTk5MTJMMS41IDEiIHN0cm9rZT0iI0YzRkZGQSIgc3Ryb2tlLXdpZHRoPSIxLjUiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8L3N2Zz4K" alt="Arrow" /></div></div><div class="hasura-ibm-plex-mono">Get started with GraphQL and Hasura from our selection of over 15 courses</div></div></a><a href="/graphql/database/"><div class="navListAnnouncement navDataBaseBg"><div class="hasura-ibm-plex-article-desc">Supported Databases<div class="arrow"><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iOCIgaGVpZ2h0PSIxMCIgdmlld0JveD0iMCAwIDggMTAiIGZpbGw9Im5vbmUiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyI+CjxwYXRoIGQ9Ik0xLjUwMDEzIDlMNi41IDQuOTk5MTJMMS41IDEiIHN0cm9rZT0iI0YzRkZGQSIgc3Ryb2tlLXdpZHRoPSIxLjUiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8L3N2Zz4K" alt="Arrow" /></div></div><div class="hasura-ibm-plex-mono">Auto-generate GraphQL &amp; REST APIs for your data from any of our supported dbs</div></div></a></div></div></div></div><div class="mobileNavButtonWrapper"><a href="https://cloud.hasura.io/signup?pg=home&amp;plcmt=header&amp;cta=try-hasura&amp;tech=default"><button class="hasura-btn hasura-btn-sm hasura-green-btn">GET STARTED NOW</button></a><a href="/contact-us/?type=hasuraenterprise"><button class="hasura-btn hasura-btn-sm hasura-gray-btn">CONTACT SALES</button></a></div></div></div></div></div></header><div class="wd100"><section class="commonSectionWrapper commonWhiteBgColor wd100 patternWrapper"><img class="eventsDetailsLeft" src="/static/left-pattern-7757d624da3f124a5eef040ec3a1a377.png" alt="Left pattern" /><img class="eventsDetailsRight" src="/static/right-pattern-374b4f0db775e120a065059a0e5bc151.png" alt="Right pattern" /><div class="containerWrapper"><div class="topBannerWrapperEcommerce"><h1 class="title">The Hasura Super App</h1><div class="hasura-ibm-plex-article-desc">A fully-featured, free, &amp; open source reference app that showcases how to leverage Hasura&#x27;s superpowers to build scalable, secure, and high-performance business applications.</div><ul class="hasura-ibm-plex-article-desc-Small"><li><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMzIiIGhlaWdodD0iMzIiIHZpZXdCb3g9IjAgMCAzMiAzMiIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPGNpcmNsZSBjeD0iMTYiIGN5PSIxNiIgcj0iMTMiIGZpbGw9IiNFM0YyRkYiIHN0cm9rZT0iI0UzRjJGRiIgc3Ryb2tlLXdpZHRoPSIyIiBzdHJva2UtbGluZWNhcD0icm91bmQiIHN0cm9rZS1saW5lam9pbj0icm91bmQiLz4KPHBhdGggZD0iTTEwIDE3LjY4MjFMMTMuNDExIDIxLjA5MTJMMjIuNTAxOSAxMiIgc3Ryb2tlPSIjMEI1NTk5IiBzdHJva2Utd2lkdGg9IjIiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8L3N2Zz4K" alt="Tick" />Fully featured</li><li><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMzIiIGhlaWdodD0iMzIiIHZpZXdCb3g9IjAgMCAzMiAzMiIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPGNpcmNsZSBjeD0iMTYiIGN5PSIxNiIgcj0iMTMiIGZpbGw9IiNFM0YyRkYiIHN0cm9rZT0iI0UzRjJGRiIgc3Ryb2tlLXdpZHRoPSIyIiBzdHJva2UtbGluZWNhcD0icm91bmQiIHN0cm9rZS1saW5lam9pbj0icm91bmQiLz4KPHBhdGggZD0iTTEwIDE3LjY4MjFMMTMuNDExIDIxLjA5MTJMMjIuNTAxOSAxMiIgc3Ryb2tlPSIjMEI1NTk5IiBzdHJva2Utd2lkdGg9IjIiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8L3N2Zz4K" alt="Tick" />Open source</li><li><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMzIiIGhlaWdodD0iMzIiIHZpZXdCb3g9IjAgMCAzMiAzMiIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPGNpcmNsZSBjeD0iMTYiIGN5PSIxNiIgcj0iMTMiIGZpbGw9IiNFM0YyRkYiIHN0cm9rZT0iI0UzRjJGRiIgc3Ryb2tlLXdpZHRoPSIyIiBzdHJva2UtbGluZWNhcD0icm91bmQiIHN0cm9rZS1saW5lam9pbj0icm91bmQiLz4KPHBhdGggZD0iTTEwIDE3LjY4MjFMMTMuNDExIDIxLjA5MTJMMjIuNTAxOSAxMiIgc3Ryb2tlPSIjMEI1NTk5IiBzdHJva2Utd2lkdGg9IjIiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8L3N2Zz4K" alt="Tick" />Modern Stack (Next.js, Typescript, Apollo Client)</li></ul><div class="buttonWrapper"><a href="https://github.com/hasura/hasura-ecommerce" target="_blank" rel="noopener noreferrer"><button class="hasura-btn hasura-btn-lg hasura-green-btn"><img class="leftBtnIcon" src="data:image/svg+xml;base64,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" alt="Github" /> Git the code!</button></a></div><div class="videoWrapper"><div class="videoAspectRatio"><iframe loading="lazy" title="Add to an existing, live postgres database" src="https://player.vimeo.com/video/575383663" frameBorder="0" allowfullscreen=""></iframe></div></div></div></div></section><section class="commonSectionWrapper removePaddTop hasura-light-blue-bg-color wd100"><div class="containerWrapper"><div class="featureCourseWrapper"><h1 class="articleTitle">How we built it</h1><div class="hasura-ibm-plex-article-desc">The Hasura Super App is a reactive event-driven <a href="https://3factor.app/" target="_blank" rel="noopener noreferrer">3factor application</a>. Dig into the code to understand how to approach complex real-world scenarios using Hasura.</div><div class="architectureImg"><img src="/static/architecture-diagram-13657b656620889d79dcdf28841513d4.svg" alt="Architecture diagram" /></div><div class="featureCourseListWrapper"><a href="https://github.com/hasura/hasura-ecommerce/blob/e674875e16e00ade05d905a53c9c8c89f33d5554/www/pages/api/actions/login/index.ts" target="_blank" rel="noopener noreferrer" class="featureCourseList"><img class="featureCourseListImg" src="data:image/svg+xml;base64,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" alt="Icon" /><div><div class="hasura-ibm-plex-article-desc">JWT Auth (Custom)<img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTkuMjg4NTkgNi43MDk3OEM4Ljg5ODU5IDcuMDk5NzggOC44OTg1OSA3LjcyOTc4IDkuMjg4NTkgOC4xMTk3OEwxMy4xNjg2IDExLjk5OThMOS4yODg1OSAxNS44Nzk4QzguODk4NTkgMTYuMjY5OCA4Ljg5ODU5IDE2Ljg5OTggOS4yODg1OSAxNy4yODk4QzkuNjc4NTkgMTcuNjc5OCAxMC4zMDg2IDE3LjY3OTggMTAuNjk4NiAxNy4yODk4TDE1LjI4ODYgMTIuNjk5OEMxNS42Nzg2IDEyLjMwOTggMTUuNjc4NiAxMS42Nzk4IDE1LjI4ODYgMTEuMjg5OEwxMC42OTg2IDYuNjk5NzhDMTAuMzE4NiA2LjMxOTc4IDkuNjc4NTkgNi4zMTk3OCA5LjI4ODU5IDYuNzA5NzhaIiBmaWxsPSIjMUIyNzM4Ii8+Cjwvc3ZnPgo=" alt="Arrow" /></div><div class="hasura-ibm-plex-article-desc-Small">Learn and understand Hasura&#x27;s authentication system by seeing how to write auth endpoints to handle signing JWT claims via authenticating your users with bcrypt.</div></div></a><a href="https://github.com/hasura/hasura-ecommerce/blob/master/www/package.json" target="_blank" rel="noopener noreferrer" class="featureCourseList"><img class="featureCourseListImg" src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMzYiIGhlaWdodD0iMzYiIHZpZXdCb3g9IjAgMCAzNiAzNiIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTE4IDNDMjIuMTI1IDMgMjUuNjUgNC41IDI4LjU3NSA3LjQyNUMzMS41IDEwLjM1IDMzIDEzLjg3NSAzMyAxOEMzMyAyMi4xMjUgMzEuNSAyNS42NSAyOC41NzUgMjguNTc1QzI1LjY1IDMxLjUgMjIuMTI1IDMzIDE4IDMzQzEzLjg3NSAzMyAxMC4zNSAzMS41IDcuNDI1IDI4LjU3NUM0LjUgMjUuNjUgMyAyMi4xMjUgMyAxOEMzIDEzLjg3NSA0LjUgMTAuMzUgNy40MjUgNy40MjVDMTAuMzUgNC41IDEzLjg3NSAzIDE4IDNaIiBmaWxsPSIjMEI5REJDIi8+CjxyZWN0IHg9IjEwIiB5PSIxMCIgd2lkdGg9IjE2IiBoZWlnaHQ9IjQiIGZpbGw9IndoaXRlIi8+CjxyZWN0IHg9IjEwIiB5PSIxNiIgd2lkdGg9IjE2IiBoZWlnaHQ9IjQiIGZpbGw9IndoaXRlIi8+CjxyZWN0IHg9IjEwIiB5PSIyMiIgd2lkdGg9IjE2IiBoZWlnaHQ9IjQiIGZpbGw9IndoaXRlIi8+Cjwvc3ZnPgo=" alt="Icon" /><div><div class="hasura-ibm-plex-article-desc">Modern Stack (Next.js, Typescript, Apollo Client)<img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTkuMjg4NTkgNi43MDk3OEM4Ljg5ODU5IDcuMDk5NzggOC44OTg1OSA3LjcyOTc4IDkuMjg4NTkgOC4xMTk3OEwxMy4xNjg2IDExLjk5OThMOS4yODg1OSAxNS44Nzk4QzguODk4NTkgMTYuMjY5OCA4Ljg5ODU5IDE2Ljg5OTggOS4yODg1OSAxNy4yODk4QzkuNjc4NTkgMTcuNjc5OCAxMC4zMDg2IDE3LjY3OTggMTAuNjk4NiAxNy4yODk4TDE1LjI4ODYgMTIuNjk5OEMxNS42Nzg2IDEyLjMwOTggMTUuNjc4NiAxMS42Nzk4IDE1LjI4ODYgMTEuMjg5OEwxMC42OTg2IDYuNjk5NzhDMTAuMzE4NiA2LjMxOTc4IDkuNjc4NTkgNi4zMTk3OCA5LjI4ODU5IDYuNzA5NzhaIiBmaWxsPSIjMUIyNzM4Ii8+Cjwvc3ZnPgo=" alt="Arrow" /></div><div class="hasura-ibm-plex-article-desc-Small">Built on a set of technologies that you&#x27;re likely to encounter or choose yourself for day-to-day development activities.</div></div></a><a href="https://github.com/hasura/hasura-ecommerce/blob/e674875e16e00ade05d905a53c9c8c89f33d5554/www/utils/generated/graphql-client-sdk.ts" target="_blank" rel="noopener noreferrer" class="featureCourseList"><img class="featureCourseListImg" src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMzYiIGhlaWdodD0iMzYiIHZpZXdCb3g9IjAgMCAzNiAzNiIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTE4IDNDMjIuMTI1IDMgMjUuNjUgNC41IDI4LjU3NSA3LjQyNUMzMS41IDEwLjM1IDMzIDEzLjg3NSAzMyAxOEMzMyAyMi4xMjUgMzEuNSAyNS42NSAyOC41NzUgMjguNTc1QzI1LjY1IDMxLjUgMjIuMTI1IDMzIDE4IDMzQzEzLjg3NSAzMyAxMC4zNSAzMS41IDcuNDI1IDI4LjU3NUM0LjUgMjUuNjUgMyAyMi4xMjUgMyAxOEMzIDEzLjg3NSA0LjUgMTAuMzUgNy40MjUgNy40MjVDMTAuMzUgNC41IDEzLjg3NSAzIDE4IDNaIiBmaWxsPSIjMEI5REJDIi8+CjxwYXRoIGZpbGwtcnVsZT0iZXZlbm9kZCIgY2xpcC1ydWxlPSJldmVub2RkIiBkPSJNMTEuNiAxMEgyNC40QzI1LjI4IDEwIDI2IDEwLjkgMjYgMTJWMjRDMjYgMjUuMSAyNS4yOCAyNiAyNC40IDI2SDExLjZDMTAuNzIgMjYgMTAgMjUuMSAxMCAyNFYxMkMxMCAxMC45IDEwLjcyIDEwIDExLjYgMTBaTTE4LjE1MzIgMTMuNzA3OUwxMy43MDgzIDE4LjE1MjhMMTguMTUzMiAyMi41OTc3TDIyLjU5ODEgMTguMTUyOEwxOC4xNTMyIDEzLjcwNzlaIiBmaWxsPSJ3aGl0ZSIvPgo8L3N2Zz4K" alt="Icon" /><div><div class="hasura-ibm-plex-article-desc">Autogenerated Typescript GraphQL Client SDK<img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTkuMjg4NTkgNi43MDk3OEM4Ljg5ODU5IDcuMDk5NzggOC44OTg1OSA3LjcyOTc4IDkuMjg4NTkgOC4xMTk3OEwxMy4xNjg2IDExLjk5OThMOS4yODg1OSAxNS44Nzk4QzguODk4NTkgMTYuMjY5OCA4Ljg5ODU5IDE2Ljg5OTggOS4yODg1OSAxNy4yODk4QzkuNjc4NTkgMTcuNjc5OCAxMC4zMDg2IDE3LjY3OTggMTAuNjk4NiAxNy4yODk4TDE1LjI4ODYgMTIuNjk5OEMxNS42Nzg2IDEyLjMwOTggMTUuNjc4NiAxMS42Nzk4IDE1LjI4ODYgMTEuMjg5OEwxMC42OTg2IDYuNjk5NzhDMTAuMzE4NiA2LjMxOTc4IDkuNjc4NTkgNi4zMTk3OCA5LjI4ODU5IDYuNzA5NzhaIiBmaWxsPSIjMUIyNzM4Ii8+Cjwvc3ZnPgo=" alt="Arrow" /></div><div class="hasura-ibm-plex-article-desc-Small">Both the frontend and the backend of the application make extensive use of typesafe client SDK&#x27;s which are autogenerated from Hasura&#x27;s schema definition. This provides database/schema-driven end-to-end typesafe workflows and markedly increases productivity and developer ergonomics.</div></div></a><a href="https://github.com/hasura/hasura-ecommerce/blob/e674875e16e00ade05d905a53c9c8c89f33d5554/www/pages/api/actions/image-upload/index.ts" target="_blank" rel="noopener noreferrer" class="featureCourseList"><img class="featureCourseListImg" src="data:image/svg+xml;base64,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" alt="Icon" /><div><div class="hasura-ibm-plex-article-desc">File/Image Upload, Self-Hosted S3 Service<img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTkuMjg4NTkgNi43MDk3OEM4Ljg5ODU5IDcuMDk5NzggOC44OTg1OSA3LjcyOTc4IDkuMjg4NTkgOC4xMTk3OEwxMy4xNjg2IDExLjk5OThMOS4yODg1OSAxNS44Nzk4QzguODk4NTkgMTYuMjY5OCA4Ljg5ODU5IDE2Ljg5OTggOS4yODg1OSAxNy4yODk4QzkuNjc4NTkgMTcuNjc5OCAxMC4zMDg2IDE3LjY3OTggMTAuNjk4NiAxNy4yODk4TDE1LjI4ODYgMTIuNjk5OEMxNS42Nzg2IDEyLjMwOTggMTUuNjc4NiAxMS42Nzk4IDE1LjI4ODYgMTEuMjg5OEwxMC42OTg2IDYuNjk5NzhDMTAuMzE4NiA2LjMxOTc4IDkuNjc4NTkgNi4zMTk3OCA5LjI4ODU5IDYuNzA5NzhaIiBmaWxsPSIjMUIyNzM4Ii8+Cjwvc3ZnPgo=" alt="Arrow" /></div><div class="hasura-ibm-plex-article-desc-Small">Many applications require object storage, for hosting and storing media objects. This is most commonly used for things like images or attachment-like file content. Minio is an OSS self-hosted S3 compatible media storage service, used via Hasura Actions to provide this functionality in the app.</div></div></a><a href="https://github.com/hasura/hasura-ecommerce/blob/e674875e16e00ade05d905a53c9c8c89f33d5554/www/pages/api/actions/admin-login/index.ts" target="_blank" rel="noopener noreferrer" class="featureCourseList"><img class="featureCourseListImg" src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMzYiIGhlaWdodD0iMzYiIHZpZXdCb3g9IjAgMCAzNiAzNiIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTE4IDNDMjIuMTI1IDMgMjUuNjUgNC41IDI4LjU3NSA3LjQyNUMzMS41IDEwLjM1IDMzIDEzLjg3NSAzMyAxOEMzMyAyMi4xMjUgMzEuNSAyNS42NSAyOC41NzUgMjguNTc1QzI1LjY1IDMxLjUgMjIuMTI1IDMzIDE4IDMzQzEzLjg3NSAzMyAxMC4zNSAzMS41IDcuNDI1IDI4LjU3NUM0LjUgMjUuNjUgMyAyMi4xMjUgMyAxOEMzIDEzLjg3NSA0LjUgMTAuMzUgNy40MjUgNy40MjVDMTAuMzUgNC41IDEzLjg3NSAzIDE4IDNaIiBmaWxsPSIjMEI5REJDIi8+CjxwYXRoIGQ9Ik0xOCAxMUMxMyAxMSA4LjczIDE0LjExIDcgMTguNUM4LjczIDIyLjg5IDEzIDI2IDE4IDI2QzIzIDI2IDI3LjI3IDIyLjg5IDI5IDE4LjVDMjcuMjcgMTQuMTEgMjMgMTEgMTggMTFaTTE4IDIzLjVDMTUuMjQgMjMuNSAxMyAyMS4yNiAxMyAxOC41QzEzIDE1Ljc0IDE1LjI0IDEzLjUgMTggMTMuNUMyMC43NiAxMy41IDIzIDE1Ljc0IDIzIDE4LjVDMjMgMjEuMjYgMjAuNzYgMjMuNSAxOCAyMy41Wk0xOCAxNS41QzE2LjM0IDE1LjUgMTUgMTYuODQgMTUgMTguNUMxNSAyMC4xNiAxNi4zNCAyMS41IDE4IDIxLjVDMTkuNjYgMjEuNSAyMSAyMC4xNiAyMSAxOC41QzIxIDE2Ljg0IDE5LjY2IDE1LjUgMTggMTUuNVoiIGZpbGw9IndoaXRlIi8+Cjwvc3ZnPgo=" alt="Icon" /><div><div class="hasura-ibm-plex-article-desc">Multiple Auth Types<img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTkuMjg4NTkgNi43MDk3OEM4Ljg5ODU5IDcuMDk5NzggOC44OTg1OSA3LjcyOTc4IDkuMjg4NTkgOC4xMTk3OEwxMy4xNjg2IDExLjk5OThMOS4yODg1OSAxNS44Nzk4QzguODk4NTkgMTYuMjY5OCA4Ljg5ODU5IDE2Ljg5OTggOS4yODg1OSAxNy4yODk4QzkuNjc4NTkgMTcuNjc5OCAxMC4zMDg2IDE3LjY3OTggMTAuNjk4NiAxNy4yODk4TDE1LjI4ODYgMTIuNjk5OEMxNS42Nzg2IDEyLjMwOTggMTUuNjc4NiAxMS42Nzk4IDE1LjI4ODYgMTEuMjg5OEwxMC42OTg2IDYuNjk5NzhDMTAuMzE4NiA2LjMxOTc4IDkuNjc4NTkgNi4zMTk3OCA5LjI4ODU5IDYuNzA5NzhaIiBmaWxsPSIjMUIyNzM4Ii8+Cjwvc3ZnPgo=" alt="Arrow" /></div><div class="hasura-ibm-plex-article-desc-Small">Not every application follows a cookie-cutter auth model where only a single &quot;user&quot; type exists. Many times you have more than one authenticatable entity, and sometimes more than one auth mechanism. This app uses two separate auth entities -- one for regular users, and one for platform admins.</div></div></a><a href="https://github.com/hasura/hasura-ecommerce/tree/master/hasura/models" target="_blank" rel="noopener noreferrer" class="featureCourseList"><img class="featureCourseListImg" src="data:image/svg+xml;base64,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" alt="Icon" /><div><div class="hasura-ibm-plex-article-desc">Real-world Data Model<img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTkuMjg4NTkgNi43MDk3OEM4Ljg5ODU5IDcuMDk5NzggOC44OTg1OSA3LjcyOTc4IDkuMjg4NTkgOC4xMTk3OEwxMy4xNjg2IDExLjk5OThMOS4yODg1OSAxNS44Nzk4QzguODk4NTkgMTYuMjY5OCA4Ljg5ODU5IDE2Ljg5OTggOS4yODg1OSAxNy4yODk4QzkuNjc4NTkgMTcuNjc5OCAxMC4zMDg2IDE3LjY3OTggMTAuNjk4NiAxNy4yODk4TDE1LjI4ODYgMTIuNjk5OEMxNS42Nzg2IDEyLjMwOTggMTUuNjc4NiAxMS42Nzk4IDE1LjI4ODYgMTEuMjg5OEwxMC42OTg2IDYuNjk5NzhDMTAuMzE4NiA2LjMxOTc4IDkuNjc4NTkgNi4zMTk3OCA5LjI4ODU5IDYuNzA5NzhaIiBmaWxsPSIjMUIyNzM4Ii8+Cjwvc3ZnPgo=" alt="Arrow" /></div><div class="hasura-ibm-plex-article-desc-Small">The data model used in this application was taken from a real-world public domain dataset used for machine learning models. It was cleaned and normalized, and the existing authentic data supplemented with artificial data where we modeled new tables that didn&#x27;t exist originally.</div></div></a><a href="https://github.com/hasura/hasura-ecommerce/tree/master/www/pages/api/actions" target="_blank" rel="noopener noreferrer" class="featureCourseList"><img class="featureCourseListImg" src="data:image/svg+xml;base64,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" alt="Icon" /><div><div class="hasura-ibm-plex-article-desc">Hasura Actions<img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTkuMjg4NTkgNi43MDk3OEM4Ljg5ODU5IDcuMDk5NzggOC44OTg1OSA3LjcyOTc4IDkuMjg4NTkgOC4xMTk3OEwxMy4xNjg2IDExLjk5OThMOS4yODg1OSAxNS44Nzk4QzguODk4NTkgMTYuMjY5OCA4Ljg5ODU5IDE2Ljg5OTggOS4yODg1OSAxNy4yODk4QzkuNjc4NTkgMTcuNjc5OCAxMC4zMDg2IDE3LjY3OTggMTAuNjk4NiAxNy4yODk4TDE1LjI4ODYgMTIuNjk5OEMxNS42Nzg2IDEyLjMwOTggMTUuNjc4NiAxMS42Nzk4IDE1LjI4ODYgMTEuMjg5OEwxMC42OTg2IDYuNjk5NzhDMTAuMzE4NiA2LjMxOTc4IDkuNjc4NTkgNi4zMTk3OCA5LjI4ODU5IDYuNzA5NzhaIiBmaWxsPSIjMUIyNzM4Ii8+Cjwvc3ZnPgo=" alt="Arrow" /></div><div class="hasura-ibm-plex-article-desc-Small">You can&#x27;t build an app on CRUD alone. Every app needs business logic, and in Hasura these are integrated via either Actions (REST APIs) or Remote Schemas (GraphQL APIs). This app showcases use of Actions for integrating business logic.</div></div></a><a href="https://github.com/hasura/hasura-ecommerce/blob/e674875e16e00ade05d905a53c9c8c89f33d5554/hasura/models/product_review/table.yaml#L30-L59" target="_blank" rel="noopener noreferrer" class="featureCourseList"><img class="featureCourseListImg" src="data:image/svg+xml;base64,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" alt="Icon" /><div><div class="hasura-ibm-plex-article-desc">Non-trivial Permissions<img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTkuMjg4NTkgNi43MDk3OEM4Ljg5ODU5IDcuMDk5NzggOC44OTg1OSA3LjcyOTc4IDkuMjg4NTkgOC4xMTk3OEwxMy4xNjg2IDExLjk5OThMOS4yODg1OSAxNS44Nzk4QzguODk4NTkgMTYuMjY5OCA4Ljg5ODU5IDE2Ljg5OTggOS4yODg1OSAxNy4yODk4QzkuNjc4NTkgMTcuNjc5OCAxMC4zMDg2IDE3LjY3OTggMTAuNjk4NiAxNy4yODk4TDE1LjI4ODYgMTIuNjk5OEMxNS42Nzg2IDEyLjMwOTggMTUuNjc4NiAxMS42Nzk4IDE1LjI4ODYgMTEuMjg5OEwxMC42OTg2IDYuNjk5NzhDMTAuMzE4NiA2LjMxOTc4IDkuNjc4NTkgNi4zMTk3OCA5LjI4ODU5IDYuNzA5NzhaIiBmaWxsPSIjMUIyNzM4Ii8+Cjwvc3ZnPgo=" alt="Arrow" /></div><div class="hasura-ibm-plex-article-desc-Small">Several of the column/table permissions in the app contain permissions which are non-trivial. One such example: &quot;A user may only submit, update, or delete a review for a product, if that user has previously purchased that product and it exists in their order history.&quot;</div></div></a><a href="https://github.com/hasura/hasura-ecommerce/tree/master/hasura" target="_blank" rel="noopener noreferrer" class="featureCourseList"><img class="featureCourseListImg" src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMzYiIGhlaWdodD0iMzYiIHZpZXdCb3g9IjAgMCAzNiAzNiIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTE4IDNDMjIuMTI1IDMgMjUuNjUgNC41IDI4LjU3NSA3LjQyNUMzMS41IDEwLjM1IDMzIDEzLjg3NSAzMyAxOEMzMyAyMi4xMjUgMzEuNSAyNS42NSAyOC41NzUgMjguNTc1QzI1LjY1IDMxLjUgMjIuMTI1IDMzIDE4IDMzQzEzLjg3NSAzMyAxMC4zNSAzMS41IDcuNDI1IDI4LjU3NUM0LjUgMjUuNjUgMyAyMi4xMjUgMyAxOEMzIDEzLjg3NSA0LjUgMTAuMzUgNy40MjUgNy40MjVDMTAuMzUgNC41IDEzLjg3NSAzIDE4IDNaIiBmaWxsPSIjMEI5REJDIi8+CjxyZWN0IHg9IjE1IiB5PSIxMSIgd2lkdGg9IjEwIiBoZWlnaHQ9IjQiIGZpbGw9IndoaXRlIi8+CjxyZWN0IHg9IjExIiB5PSIyMSIgd2lkdGg9IjEwIiBoZWlnaHQ9IjQiIGZpbGw9IndoaXRlIi8+CjxwYXRoIGQ9Ik0yNyAyM0wyMCAyOEwyMCAxOEwyNyAyM1oiIGZpbGw9IndoaXRlIi8+CjxwYXRoIGQ9Ik05IDEzTDE2IDhMMTYgMThMOSAxM1oiIGZpbGw9IndoaXRlIi8+Cjwvc3ZnPgo=" alt="Icon" /><div><div class="hasura-ibm-plex-article-desc">Migrations Workflow<img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTkuMjg4NTkgNi43MDk3OEM4Ljg5ODU5IDcuMDk5NzggOC44OTg1OSA3LjcyOTc4IDkuMjg4NTkgOC4xMTk3OEwxMy4xNjg2IDExLjk5OThMOS4yODg1OSAxNS44Nzk4QzguODk4NTkgMTYuMjY5OCA4Ljg5ODU5IDE2Ljg5OTggOS4yODg1OSAxNy4yODk4QzkuNjc4NTkgMTcuNjc5OCAxMC4zMDg2IDE3LjY3OTggMTAuNjk4NiAxNy4yODk4TDE1LjI4ODYgMTIuNjk5OEMxNS42Nzg2IDEyLjMwOTggMTUuNjc4NiAxMS42Nzk4IDE1LjI4ODYgMTEuMjg5OEwxMC42OTg2IDYuNjk5NzhDMTAuMzE4NiA2LjMxOTc4IDkuNjc4NTkgNi4zMTk3OCA5LjI4ODU5IDYuNzA5NzhaIiBmaWxsPSIjMUIyNzM4Ii8+Cjwvc3ZnPgo=" alt="Arrow" /></div><div class="hasura-ibm-plex-article-desc-Small">The application source demonstrates how to use Hasura&#x27;s migrations and metadata workflow to declaratively &amp; reproducibly model your application&#x27;s schema and metadata state.</div></div></a><a href="https://github.com/hasura/hasura-ecommerce/blob/e674875e16e00ade05d905a53c9c8c89f33d5554/www/pages/api/actions/create-payment-intent/index.ts" target="_blank" rel="noopener noreferrer" class="featureCourseList"><img class="featureCourseListImg" src="data:image/svg+xml;base64,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" alt="Icon" /><div><div class="hasura-ibm-plex-article-desc">Stripe Integration<img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTkuMjg4NTkgNi43MDk3OEM4Ljg5ODU5IDcuMDk5NzggOC44OTg1OSA3LjcyOTc4IDkuMjg4NTkgOC4xMTk3OEwxMy4xNjg2IDExLjk5OThMOS4yODg1OSAxNS44Nzk4QzguODk4NTkgMTYuMjY5OCA4Ljg5ODU5IDE2Ljg5OTggOS4yODg1OSAxNy4yODk4QzkuNjc4NTkgMTcuNjc5OCAxMC4zMDg2IDE3LjY3OTggMTAuNjk4NiAxNy4yODk4TDE1LjI4ODYgMTIuNjk5OEMxNS42Nzg2IDEyLjMwOTggMTUuNjc4NiAxMS42Nzk4IDE1LjI4ODYgMTEuMjg5OEwxMC42OTg2IDYuNjk5NzhDMTAuMzE4NiA2LjMxOTc4IDkuNjc4NTkgNi4zMTk3OCA5LjI4ODU5IDYuNzA5NzhaIiBmaWxsPSIjMUIyNzM4Ii8+Cjwvc3ZnPgo=" alt="Arrow" /></div><div class="hasura-ibm-plex-article-desc-Small">Payment processing is the backbone of revenue generation. View an example of creating and handling payments via Hasura Actions and Stripe&#x27;s API (PaymentIntents) using a custom payment UI.</div></div></a></div></div></div></section><section class="commonSectionWrapper removePaddTop hasura-light-blue-bg-color"><div class="containerWrapper"><div class="buildFaqWrapper"><div><h2 class="articleTitle">Why we built this app</h2><div class="hasura-ibm-plex-article-desc">We get asked a lot whether our users can build modern apps with complex business logic using Hasura. So we built a reference app to showcase an awesome lineup of Hasura features that enable you to build complex modern apps and move to the market faster with them!<br /><br />You can also browse our <a href="/user-stories/">user stories &amp; case studies</a> to see how Hasura is being used in production by companies of all sizes.</div></div><div><h2 class="articleTitle">Frequently Asked Questions</h2><div class="buildFaqListWrapper"><div class="buildFaqList"><div class="faqDisplay"><div class="hasura-ibm-plex-article-desc-Small question curserPointer fontBold" role="button" tabindex="0">Can this be used as a &quot;Starter Kit&quot;?</div><img class="" src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTkuMjg4NTkgNi43MDk3OEM4Ljg5ODU5IDcuMDk5NzggOC44OTg1OSA3LjcyOTc4IDkuMjg4NTkgOC4xMTk3OEwxMy4xNjg2IDExLjk5OThMOS4yODg1OSAxNS44Nzk4QzguODk4NTkgMTYuMjY5OCA4Ljg5ODU5IDE2Ljg5OTggOS4yODg1OSAxNy4yODk4QzkuNjc4NTkgMTcuNjc5OCAxMC4zMDg2IDE3LjY3OTggMTAuNjk4NiAxNy4yODk4TDE1LjI4ODYgMTIuNjk5OEMxNS42Nzg2IDEyLjMwOTggMTUuNjc4NiAxMS42Nzk4IDE1LjI4ODYgMTEuMjg5OEwxMC42OTg2IDYuNjk5NzhDMTAuMzE4NiA2LjMxOTc4IDkuNjc4NTkgNi4zMTk3OCA5LjI4ODU5IDYuNzA5NzhaIiBmaWxsPSIjMUIyNzM4Ii8+Cjwvc3ZnPgo=" alt="Arrow" role="presentation" /></div><div class="faqAnswer displayNone"><div class="hasura-ibm-plex-article-desc-Small">While you technically could take the code given here as the basis for your new application, you probably wouldn&#x27;t want to.<br /><br />This application wasn&#x27;t built to be adaptable or generic, but rather to cater to one specific implementation for education purposes and to prove a point.<br /><br />We and several users in our community have much better-suited resources available for starter apps, if that&#x27;s what you&#x27;re looking for.</div></div></div><div class="buildFaqList"><div class="faqDisplay"><div class="hasura-ibm-plex-article-desc-Small question curserPointer fontBold" role="button" tabindex="0">What do I need to run this?</div><img class="" src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTkuMjg4NTkgNi43MDk3OEM4Ljg5ODU5IDcuMDk5NzggOC44OTg1OSA3LjcyOTc4IDkuMjg4NTkgOC4xMTk3OEwxMy4xNjg2IDExLjk5OThMOS4yODg1OSAxNS44Nzk4QzguODk4NTkgMTYuMjY5OCA4Ljg5ODU5IDE2Ljg5OTggOS4yODg1OSAxNy4yODk4QzkuNjc4NTkgMTcuNjc5OCAxMC4zMDg2IDE3LjY3OTggMTAuNjk4NiAxNy4yODk4TDE1LjI4ODYgMTIuNjk5OEMxNS42Nzg2IDEyLjMwOTggMTUuNjc4NiAxMS42Nzk4IDE1LjI4ODYgMTEuMjg5OEwxMC42OTg2IDYuNjk5NzhDMTAuMzE4NiA2LjMxOTc4IDkuNjc4NTkgNi4zMTk3OCA5LjI4ODU5IDYuNzA5NzhaIiBmaWxsPSIjMUIyNzM4Ii8+Cjwvc3ZnPgo=" alt="Arrow" role="presentation" /></div><div class="faqAnswer displayNone"><div class="hasura-ibm-plex-article-desc-Small">Running the application requires only Docker and Git installed.<br /><br />If you want the payments/billing feature to be functional, you need to insert a genuine Stripe test or production key (the rest of the application functions fine with a fake one).<br /><br />The Docker Compose file in the root of the repo starts Hasura, Next.js, Minio, and Postgres.</div></div></div><div class="buildFaqList"><div class="faqDisplay"><div class="hasura-ibm-plex-article-desc-Small question curserPointer fontBold" role="button" tabindex="0">Where is Feature X?</div><img class="" src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTkuMjg4NTkgNi43MDk3OEM4Ljg5ODU5IDcuMDk5NzggOC44OTg1OSA3LjcyOTc4IDkuMjg4NTkgOC4xMTk3OEwxMy4xNjg2IDExLjk5OThMOS4yODg1OSAxNS44Nzk4QzguODk4NTkgMTYuMjY5OCA4Ljg5ODU5IDE2Ljg5OTggOS4yODg1OSAxNy4yODk4QzkuNjc4NTkgMTcuNjc5OCAxMC4zMDg2IDE3LjY3OTggMTAuNjk4NiAxNy4yODk4TDE1LjI4ODYgMTIuNjk5OEMxNS42Nzg2IDEyLjMwOTggMTUuNjc4NiAxMS42Nzk4IDE1LjI4ODYgMTEuMjg5OEwxMC42OTg2IDYuNjk5NzhDMTAuMzE4NiA2LjMxOTc4IDkuNjc4NTkgNi4zMTk3OCA5LjI4ODU5IDYuNzA5NzhaIiBmaWxsPSIjMUIyNzM4Ii8+Cjwvc3ZnPgo=" alt="Arrow" role="presentation" /></div><div class="faqAnswer displayNone"><div class="hasura-ibm-plex-article-desc-Small">For the history and background context of this reference application being built, please see the notice in the repo <a href="https://github.com/hasura/hasura-ecommerce#hasura-e-commerce-demo" target="_blank" rel="noopener noreferrer">here</a>.<br /><br />You may find that certain features don&#x27;t have examples in the codebase. At the time of writing, this application currently doesn&#x27;t implement every possible Hasura feature.<br /><br />Our intent is to maintain and expand it over time as resources permit, until we achieve full feature-coverage and so that there exists a canonical reference for how to do this.</div></div></div></div></div></div></div></section><section class="commonSectionWrapper removePaddTop"><div class="containerWrapper"><div class="getStartedHasuraWrapper"><div class="getStartedHasuraImg"><img loading="lazy" src="/static/orm-5b7d37641d7d7c7efb3c9c48aea4df20.png" alt="ORM" /></div><div><div class="articleTitle">Get started with Hasura in 30 Seconds</div><ul class="hasura-ibm-plex-article-desc-Small"><li><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMzIiIGhlaWdodD0iMzIiIHZpZXdCb3g9IjAgMCAzMiAzMiIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPGNpcmNsZSBjeD0iMTYiIGN5PSIxNiIgcj0iMTMiIGZpbGw9IiNFM0YyRkYiIHN0cm9rZT0iI0UzRjJGRiIgc3Ryb2tlLXdpZHRoPSIyIiBzdHJva2UtbGluZWNhcD0icm91bmQiIHN0cm9rZS1saW5lam9pbj0icm91bmQiLz4KPHBhdGggZD0iTTEwIDE3LjY4MjFMMTMuNDExIDIxLjA5MTJMMjIuNTAxOSAxMiIgc3Ryb2tlPSIjMEI1NTk5IiBzdHJva2Utd2lkdGg9IjIiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8L3N2Zz4K" alt="Tick" />Build apps and APIs 10x faster</li><li><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMzIiIGhlaWdodD0iMzIiIHZpZXdCb3g9IjAgMCAzMiAzMiIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPGNpcmNsZSBjeD0iMTYiIGN5PSIxNiIgcj0iMTMiIGZpbGw9IiNFM0YyRkYiIHN0cm9rZT0iI0UzRjJGRiIgc3Ryb2tlLXdpZHRoPSIyIiBzdHJva2UtbGluZWNhcD0icm91bmQiIHN0cm9rZS1saW5lam9pbj0icm91bmQiLz4KPHBhdGggZD0iTTEwIDE3LjY4MjFMMTMuNDExIDIxLjA5MTJMMjIuNTAxOSAxMiIgc3Ryb2tlPSIjMEI1NTk5IiBzdHJva2Utd2lkdGg9IjIiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8L3N2Zz4K" alt="Tick" />Built-in authorization and caching</li><li><img src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMzIiIGhlaWdodD0iMzIiIHZpZXdCb3g9IjAgMCAzMiAzMiIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPGNpcmNsZSBjeD0iMTYiIGN5PSIxNiIgcj0iMTMiIGZpbGw9IiNFM0YyRkYiIHN0cm9rZT0iI0UzRjJGRiIgc3Ryb2tlLXdpZHRoPSIyIiBzdHJva2UtbGluZWNhcD0icm91bmQiIHN0cm9rZS1saW5lam9pbj0icm91bmQiLz4KPHBhdGggZD0iTTEwIDE3LjY4MjFMMTMuNDExIDIxLjA5MTJMMjIuNTAxOSAxMiIgc3Ryb2tlPSIjMEI1NTk5IiBzdHJva2Utd2lkdGg9IjIiIHN0cm9rZS1saW5lY2FwPSJyb3VuZCIgc3Ryb2tlLWxpbmVqb2luPSJyb3VuZCIvPgo8L3N2Zz4K" alt="Tick" />5x-50x more performant than hand-rolled APIs</li></ul><div class="buttonWrapper"><a href="https://cloud.hasura.io/signup?pg=ecommerce&amp;plcmt=body&amp;cta=get-started-now&amp;tech=default"><button class="hasura-btn hasura-btn-md hasura-blue-btn">GET STARTED NOW</button></a></div></div></div></div></section><div class="showMobileFixBtn"><div class="buttonWrapper"><a href="https://github.com/hasura/hasura-ecommerce" target="_blank" rel="noopener noreferrer"><button class="hasura-btn hasura-btn-lg hasura-green-btn"><img class="leftBtnIcon" src="data:image/svg+xml;base64,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" alt="Github" /> Git the code!</button></a></div></div></div><section id="events" class="commonSectionWrapper wd100 removePaddBottom"><div class="containerWrapper"><div class="eventsAnnounceWrapper"><div class="eventsAnnounceHeader hasuraGridWrapper twoGridColumnWrapper eventsAnnounceHeaderPos"><h2 class="articleTitle">We’d love to connect with you at one of our many global events.</h2><div class="buttonWrapper alignSelfEnd"><a href="/events/"><button class="hasura-btn hasura-btn-md hasura-blue-btn">See all Events</button></a></div></div><div class="eventsAnnounceImg"><img src="/static/event-img-f3c0ef1db616c7833b7b9e2ec7c4b2e4.png" alt="Event" /></div><div class="commonSectionWrapper removePaddTop eventsAnnounceHeader hasuraGridWrapper twoGridColumnWrapper mpMinus300"><a href="/events/hasura-con-2021/"><img class="mobileHide" src="/static/hasura-con-featured-3bb5b42eb9fe244a25222bc14216a961.png" alt="HasuraCon 2021" /><img class="mobileShow" src="/static/hasura-con-featured-mobile-fe83822181e9ad1fe99b94bc6e8e676d.png" alt="HasuraCon 2021" /></a><a href="/community/community-call/" class="textRight"><img class="smallImg" src="/static/community-call-featured-bf8cb59d588376ff2fb7e1b158686700.svg" alt="Community call" /></a></div></div></div></section><div class="commonSectionWrapper hasura-light-blue-bg-color removePaddTop"><div class="containerWrapper"><div class="newsletterWrapper mtPlus300"><div><div class="hasura-ibm-plex-sub-title">Ready to get started?</div><div class="articleDesc">Start for free on Hasura Cloud or you could contact our sales team for a detailed walk-through on how Hasura may benefit your business.</div><div class="buttonWrapper"><a href="https://cloud.hasura.io/?pg=home&amp;plcmt=footer&amp;cta=try-hasura&amp;tech=default"><button class="hasura-btn hasura-btn-md hasura-blue-btn">Get started now</button></a><a href="/contact-us/?type=hasuraenterprise"><button class="hasura-btn hasura-btn-md hasura-white-btn">CONTACT SALES</button></a></div></div><div class="subscribeNewsletterWrapper removePaddBottom" id="subscribe-updates"><div class="hasura-ibm-plex-sub-title">Get monthly product updates</div><div class="articleDesc">Sign up for full access to our product and community highlights, new features, and occasional baby animal gifs! Oh, and we have a strict no-spam rule.<!-- --> <span role="img" aria-label="Enoji">✌️</span></div> <div><form class="marketoFormWrapper subscribeNewsletterForm" id="mktoForm_1011"></form></div></div></div></div></div><footer class="wd100 hasura-light-blue-bg-color"><div class="containerWrapper"><div></div><div class="footerWrappper wd100"><div class="footerLinks hasura-ibm-plex-nav"><div class="footerLinksHeader">Hasura</div><a class="links" href="/about/">About Us</a><a class="links" href="/press/">Press</a><a href="/careers/" class="links">Careers</a><a class="links" href="/contact-us/">Contact Us</a><a class="links" href="/legal/">Legal Stuff</a></div><div class="footerLinks hasura-ibm-plex-nav"><div class="footerLinksHeader">Support</div><a href="https://hasura.io/docs/latest/graphql/core/index.html" class="links" target="_blank" rel="noopener noreferrer">Documentation</a><a href="https://discord.com/invite/hasura" class="links" target="_blank" rel="noopener noreferrer">Community Forum</a><button class="links anchorBtn">Website chat</button><a href="https://github.com/hasura" class="links" target="_blank" rel="noopener noreferrer">Github</a><a href="https://status.hasura.io/" class="links" target="_blank" rel="noopener noreferrer">Hasura Cloud Status</a><a href="https://hasura.io/cloud-survey/" class="links hide" target="_blank" rel="noopener noreferrer">Hasura Cloud Survey</a></div><div class="footerLinks hasura-ibm-plex-nav"><div class="footerLinksHeader">Tools</div><a href="https://github.com/hasura/graphqurl" class="links" target="_blank" rel="noopener noreferrer">Graphqurl</a><a href="https://github.com/hasura/firebase2graphql" class="links" target="_blank" rel="noopener noreferrer">Firebase2GraphQL</a><a href="https://github.com/hasura/json2graphql" class="links" target="_blank" rel="noopener noreferrer">JSON2GraphQL</a><a href="https://github.com/hasura/graphql2chartjs" class="links" target="_blank" rel="noopener noreferrer">GraphQL2ChartJS</a></div><div class="footerLinks hasura-ibm-plex-nav"><div class="footerLinksHeader">Product</div><a class="links" href="/opensource/">Hasura Open Source</a><a class="links" href="/cloud/">Hasura Cloud</a><a class="links" href="/enterprise/">Hasura Enterprise</a><a class="links" href="/pricing/">Pricing</a><a href="https://github.com/hasura/graphql-engine/releases" class="links" target="_blank" rel="noopener noreferrer">Changelog</a></div><div class="footerLinks hasura-ibm-plex-nav"><div class="footerLinksHeader">Resources</div><a href="https://hasura.io/blog/" class="links" target="_blank" rel="noopener noreferrer">Blog</a><a class="links" href="/user-stories/">User Stories</a><a href="https://3factor.app/" class="links" target="_blank" rel="noopener noreferrer">3Factor Apps</a><a class="links" href="/event-driven-programming/">Event Driven Programming</a><a class="links" href="/react-graphql/">React GraphQL</a><a class="links" href="/vue-graphql/">Vue GraphQL</a><a class="links" href="/diy-graphql-baas/">DIY GraphQL BaaS</a><a class="links" href="/graphql/">GraphQL &amp; Hasura</a><a class="links" href="/security/">Hasura Cloud Security</a></div><div class="footerLinks hasura-ibm-plex-nav"><div class="footerLinksHeader">Community</div><a class="links" href="/community/">Community Resources</a><a href="https://hasura.io/learn/" class="links" target="_blank" rel="noopener noreferrer">GraphQL Tutorials</a><a href="https://github.com/hasura/graphql-engine/wiki" class="links" target="_blank" rel="noopener noreferrer">Community Wiki</a><a class="links" href="/sample-apps/">Sample Apps</a><a class="links" href="/partner-agencies/">Partnership Program</a><a class="links" href="/events/hasura-con-2021/">HasuraCon 2021</a><a href="https://graphql.asia/" class="links" target="_blank" rel="noopener noreferrer">GraphQL Asia</a></div></div></div><div class="copyWriteWrapperBg wd100"><div class="containerWrapper"><div class="copyWriteWrapper"><div class="brand"><img src="data:image/svg+xml;base64,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" alt="Brand logo" /></div><div class="hasura-ibm-plex-mono">© <!-- -->2021<!-- --> Hasura Inc. All rights reserved</div><div class="footerSocialIconsWrapper"><div class="socialBrands"><a href="https://github.com/hasura/graphql-engine" rel="noopener noreferrer" aria-label="Github"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Github" /></a></div><div class="socialBrands"><a href="https://twitter.com/hasurahq" rel="noopener noreferrer" aria-label="Titter"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Titter" /></a></div><div class="socialBrands"><a href="https://discord.com/invite/hasura" rel="noopener noreferrer" aria-label="Discord"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Discord" /></a></div><div class="socialBrands"><a href="https://www.facebook.com/HasuraHQ" rel="noopener noreferrer" aria-label="Facebook"><img loading="lazy" src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjQiIGhlaWdodD0iMjQiIHZpZXdCb3g9IjAgMCAyNCAyNCIgZmlsbD0ibm9uZSIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4KPHBhdGggZD0iTTEyIDBDNS4zOTk5OSAwIDAgNS4zODc5OSAwIDEyLjAyNEMwIDE4LjAyNCA0LjM5MTk5IDIzLjAwNCAxMC4xMjggMjMuOTA0VjE1LjUwNEg3LjA3OTk5VjEyLjAyNEgxMC4xMjhWOS4zNzE5OUMxMC4xMjggNi4zNTk5OSAxMS45MTYgNC43MDM5OSAxNC42NjQgNC43MDM5OUMxNS45NzIgNC43MDM5OSAxNy4zNCA0LjkzMTk5IDE3LjM0IDQuOTMxOTlWNy44OTU5OUgxNS44MjhDMTQuMzQgNy44OTU5OSAxMy44NzIgOC44MTk5OSAxMy44NzIgOS43Njc5OVYxMi4wMjRIMTcuMjA4TDE2LjY2OCAxNS41MDRIMTMuODcyVjIzLjkwNEMxNi42OTk3IDIzLjQ1NzQgMTkuMjc0NiAyMi4wMTQ2IDIxLjEzMTkgMTkuODM2QzIyLjk4OTIgMTcuNjU3NSAyNC4wMDY0IDE0Ljg4NjggMjQgMTIuMDI0QzI0IDUuMzg3OTkgMTguNiAwIDEyIDBaIiBmaWxsPSIjNzE3NzgwIi8+Cjwvc3ZnPgo=" alt="Facebook" /></a></div><div class="socialBrands"><a href="https://www.instagram.com/hasurahq/?hl=en" rel="noopener noreferrer" aria-label="Instagram"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Instagram" /></a></div><div class="socialBrands"><a href="https://www.youtube.com/channel/UCZo1ciR8pZvdD3Wxp9aSNhQ" rel="noopener noreferrer" aria-label="Youtube"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Youtube" /></a></div><div class="socialBrands"><a href="https://www.linkedin.com/company/hasura" rel="noopener noreferrer" aria-label="Linkedin"><img loading="lazy" src="data:image/svg+xml;base64,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" alt="Linkedin" /></a></div></div></div></div></div></footer></div></div></div><div id="gatsby-announcer" style="position:absolute;top:0;width:1px;height:1px;padding:0;overflow:hidden;clip:rect(0, 0, 0, 0);white-space:nowrap;border:0" aria-live="assertive" aria-atomic="true"></div></div><script>
          window.IntercomAppId = 'rucirpb3';
          window.IntercomIncludeInDevelopment = false;
          (function(){var w=window;var ic=w.Intercom;if(typeof ic==="function"){ic('reattach_activator');ic('update',intercomSettings);}else{var d=document;var i=function(){i.c(arguments)};i.q=[];i.c=function(args){i.q.push(args)};w.Intercom=i;function l(){var s=d.createElement('script');s.type='text/javascript';s.async=true;s.src='https://widget.intercom.io/widget/rucirpb3';var x=d.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);}function ld(){setTimeout(l, 2000);}if(w.attachEvent){w.attachEvent('onload',ld);}else{w.addEventListener('load',ld,false);}}})();
          </script><script id="gatsby-script-loader">/*<![CDATA[*/window.pagePath="/reference-app/";/*]]>*/</script><script id="gatsby-chunk-mapping">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</script><script src="/polyfill-3a49c548e242de176d38.js" nomodule=""></script><script src="/component---src-pages-reference-app-js-d1fb346a6268f3b79169.js" async=""></script><script src="/56e53495d17a8009700a24dae53bb7a1c5e8c4fb-ff83c21b0c84c73f48b9.js" async=""></script><script src="/432f36a8b75b6db2c3ad97ad9ebc4031ad6394aa-85224f10a7b410cc6926.js" async=""></script><script src="/commons-cfc2e38a7939f12cc44c.js" async=""></script><script src="/app-de7dcd78d99f48b74bbd.js" async=""></script><script src="/framework-660f14b4e2df4188b3f4.js" async=""></script><script src="/webpack-runtime-6518691937f0f34ed909.js" async=""></script></body></html>